Karte: Google Maps API error

  • Hallo!

    Habe heut mein zweites Board aufgesetzt. Installiert ist der Kalender und die Galerie. Allerdings ist das Problem global und da funktioniert die Google-Karte nicht. Bei meinem anderen Board ist genau dasselbe installiert und auch die Einstellungen sind gleich.

    Bei Klick auf Kalender > Karte (auch in der Galerie wenn man den Standort eines Bildes angeben will), komm folgende Meldung:

    Quote from Google

    Hoppla! Ein Fehler ist aufgetreten.Google Maps wurde auf dieser Seite nicht richtig geladen. Technische Details dazu entnimmst du der JavaScript-Konsole.

    In der Fehlerkonsole steht folgende Meldung:


    Was ist denn da los? :|

    Edited once, last by ThomasE (June 28, 2016 at 10:28 PM).

  • Vielleicht wäre noch zu erwähnen, dass die Karte ganz kurz angezeigt wird und dann gleich die Googel-Fehlerseite kommt.

  • Ich habe das selbe Problem und noch keinen Ansatz gefunden :/
    Bei einer bestehenden Installation ist es kein Problem, alles läuft.
    Bei dem neuen Board funktioniert es nicht mit oben beschriebener Fehlermeldung.
    Braucht man da nen API Key? Und wenn ja, wo trägt man ihn ein?

  • Dachte ich hab einen Fehler gemacht. Da ich keinen Fehler feststellen konnte und so Kalender und Galerie nicht nutzbar waren hab ich das (neu erstellte) Board wieder gelöscht. Vielleicht versuch ichs später nochmal.

    Deshalb hab ich das Thema als erledigt markiert. Eine Lösung hab ich allerdings leider keine...


    Gruß, Thomas

  • Bei Google einen Browserschlüssel besorgen und die Referrer bei Google freischalten (siehe Google-Suche), sicherstellen, dass WCF 2.11 pl 1 installiert ist, Schlüssel im ACP bei Google Maps eintragen.

    Gruß, Udo

  • Ich seh grad... Das mit dem Schlüssel ist aber neu oder??? Wird denn der Schlüssel überhaupt noch benötigt? Ich mein, bei meinem bestehenden Board steht kein Schlüssel drin und es funktioniert alles.

    Hab aber vorsichtshalber einen Schlüssel erstellt ;)

  • Ich habe das gleiche Problem...

    Die Map wird ganz kurz nur geladen und ZACK kommt wieder die Fehlermeldung wie oben...

    Was ist denn da falsch?

    Welche Art von API-Schlüssel muss man denn generieren in Google?

    EDIT sagt: Es sind ja in Google mehrere Schlüssel möglich... Browserschlüssel, Serverschlüssel... egal welchen Schlüssel ich verwende (habe mehrere mal erzeugt) es wird NICHT die Karte angezeigt beim Erstellen eines Kalender-Eintrages zum Beispiel...

    Ich habe schon diese Schlüssel probiert, ohne Erfolg....

    Gruß
    Markus

    Mitglied aus dem Kartell...

    Das Kartell

    Edited 2 times, last by MDMAN (August 19, 2016 at 10:41 AM).

  • Du musst im ACP unter System -> Optionen -> System -> Google Maps einen Browser-Api-Schlüssel eintragen. Den entsprechenden Link zum generieren findest du in der Beschreibung des Feldes.

    Hallo Andrea!

    Aber genau das habe ich ja gemacht! Den Browser API-Key habe ich dort eingetragen... aber trotzdem kommt die Fehlermeldung... :(

  • Hast du den Key selbst markiert und kopiert oder auf das schöne Icon von Google geklickt? Beim selbst markieren nimmt er oft nen unsichtbares Zeichen noch mit.

    Ebenfalls drauf achten das der Key für die korrekte Domain generiert wird.

    Sowohl als auch... habe einmal kopiert und einmal mit dem Icon alles kopieren lassen...

    Ich mache es aber gleich noch mal und lösche den Key und erstelle mir einen neuen...

    Komische Sache das... :(

    EDIT: Kann es sein, dass die Key's nicht sofort funktionieren sondern etwas brauchen? Ich habe ebend nochmals ein neuen Key generiert. Dann habe ich den direkt eingegeben und.... es funktionierte nicht.... nach ca. 10 Min. bin ich dann wieder auf die Seite und siehe da.... jetzt wird alles korrekt angezeigt?!?


    EDIT 2: Was habe ich gemacht:

    • Ich habe als erstes auf den Link im ACP geklickt, der nach Goole führt.
    • Dann habe ich auf "Schlüssel anfordern" geklickt.
    • "Anmeldedaten erstellen" und auf "API-Schlüssel" und dann auf "Browser-Key" geklickt.
    • Den Namen habe ich so gelassen und als HTTP-Referrern habe ich sämtliche Variationen der Homepage eingetragen:
      *.example.de/*
      example*
      example.de/*
      https://www.woltlab.com/www.example.de/*
      *example.*
      *example*
    • Dann auf "Erstellen"
    • mit dem kleinen Icon dann den generierten Key "kopiert".
    • Den Key dann mit "Einfügen" in die ACP-Option gespeichert.

    Tja... und dann nach ca. 10 Minuten ging das Ganze dann... ;)

    Gruß
    Markus

    Mitglied aus dem Kartell...

    Das Kartell

    Edited 2 times, last by MDMAN (August 19, 2016 at 11:38 AM).

  • jetzt funktioniert es bei mir auch! Danke schön!

    Kein Problem... Man muss halt nur etwas Geduld haben, bevor der Key auch funktioniert... und man muss den richtigen Key und vor allem die richtigen Angaben bei der Domain machen!

    Beschwer dich bei Google wenn sie nicht in die Pötte kommen

    Das habe ich schon, aber dieser Großkonzern nimmt sich ja nix an!!! :(

  • Sorry das ich dieses Thema nochmals hoch hole, aber ich habe das selbe Problem. :)

    Ich habe alle so eingetragen wie von MDMAN beschrieben aber es regt sich nichts.

    Könnte es sein das es am https liegt?

    Gruß MK

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!