Frage Fehlerfreiheit der aktuellen Version des Wbb?

  • Guten Tag, uch würde gern wissen, da die Fehler der Wbb 3.1.8 offenbar auch den Einzug in die frühen 4er geschafft haben, würde ich gern wissen, wieviele Bugs diese aktuelle WbbVersion noch hat und ob es ggf. schon Programmierer gibt, die sich mit der Lösung der Probleme befassen?


    Ich habe im Auftrag einer 3.1.x Kundin Lösungen zu dem PrvateMessage System 1.1.8.pl2 - aktuelleste Fassung kein neues Fehler behebendes Update möglich - suchen wollen und habe dabei Fehler-Fragen zur 4er gefunden ;)


    Das macht nicht wirklich Appetit, auf die Idee "dann kaufen wir eben die 4.1.10 und die Fehler sind weg" ;)


    Ich würde meiner Auftraggeberin gern helfen, das PM-Problem zu lösen - und ggf. dann vlt. wenn sich da Keiner findet der das lösen kann, die 4er -Version empfehlen können, darum diese aufdringlichen Fragen


    BTW - eine Frage die ich auch nicht anderweitig stellen kann, ist für die 3.1.8 die Dateiberechtigung (CHMOD 777) für beinahe alle Dateien richtig?


    ich für meine Person habe das
    Burning Board® Version
    3.1.8 (Volcano)
    Installationsdatum
    Sonntag, 1. Mai 2016, 22:00
    Community Framework™ Version
    1.1.10 (Tempest)
    Betriebssystem
    Linux
    Webserver
    Apache
    PHP Version: 5.6.19-nmm1
    Datenbank
    MySQL Version: 5.6.27-nmm1-log
    Cache: DiskCacheSource


    wie man sieht gerade vor kurzem (erstmalig) installiert und habe gleich den Fehler mit dem PM-System mitbekommen trotz PL2
    Error-Meldung bei PM-Antworten in der 3.1.8:
    -----------------------------------------------------
    Fatal error: PHP error in file /wcf/lib/form/PMNewForm.class.php (306): preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead


    Information:
    error message: PHP error in file /wcf/lib/form/PMNewForm.class.php (306): preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead
    error code: 0
    file: /wcf/lib/system/WCF.class.php (281)
    php version: 5.6.19-nmm1
    wcf version: 1.1.10 (Tempest)
    date: Fri, 06 May 2016 16:19:46 +0000
    request: /index.php?form=PMNew&action=new&pmID=4&replyToAll=1
    referer: /index.php?page=PMView&pmID=4&folderID=0&pageNo=1&sortField=time&sortOrder=DESC&filterBySender=0
    Stacktrace:
    #0 [internal function]: WCF::handleError(8192, 'preg_replace():...', '/www/htdocs/w01...', 306, Array)
    #1 /wcf/lib/form/PMNewForm.class.php(306): preg_replace('/(^RE: RE\\[)(\\d...', '"RE[".(\\2+1)', 'RE: schau mal b...')
    #2 /wcf/lib/page/AbstractPage.class.php(90): PMNewForm->readData()
    #3 /wcf/lib/form/MessageForm.class.php(237): AbstractPage->show()
    #4 /wcf/lib/form/PMNewForm.class.php(423): MessageForm->show()
    #5 /wcf/lib/page/AbstractPage.class.php(46): PMNewForm->show()
    #6 /wcf/lib/util/RequestHandler.class.php(64): AbstractPage->__construct()
    #7 /wcf/lib/util/RequestHandler.class.php(95): RequestHandler->__construct('PMNew', Array, 'form')
    #8 /index.php(8): RequestHandler::handle(Array)
    #9 {main}
    -----------------------------------------------------
    und da ich nur der Install gefolgt bin und man da ja Nichts verstellen kann das im Weg wäre


    lohnt sich dann überhaupt die Installation der 4er? ist der Fehler da endlich raus?


    wie gesagt Fragen über Fragen und keine Lösungen


    In Diesem Sinne


    Danke für die kommenden Antworten, sofern es nicht wieder von bestimmten Leuten erneut nur Verknüpfungen zu den Problemen Anderer, statt zu Lösungen gibt


    Lösung ist das Schlüsselwort - eine Lösung hätte ich gern oder zumindestens den relevanten Hinweis das die aktuelleste 4 keine Probleme mit dem "Antworten auf PM" hat ;) - ob es dann meiner Auftraggeberin das zusätzliche Geld wert ist, werden wir dann sehen, aber erstmal ist die Fehlerfreiheit wichtig .. der Support soll ja nicht mit solchen Kleinigkeiten belastet werden ;)


    Gruß
    Anthrazit

    Hunde die bellen, beißen nicht? -> nun, ich bin kein Hund. -> Ich belle nicht. - Ich Beiße! 8o

  • Du hast nicht die aktuelle Version von Community Framework. Aktuell ist Version 1.1.10 pl 2 (Tempest). Um einen fehlerfreien Betrieb zu haben (den habe ich unter PHP 5.6 mit aktuellem Community Framework 1.1), müssen natürlich alle Pakete aktuell sein.


    Da Burning Board 4 wesentlich später entwickelt wurde, sind hier derartige Fehler nicht gegeben.

  • Klasse, dann werde ich mal zusehen das ich das Update für das wcf finde .. und dann nochmal Sorry, für die Fragerei, ich mag das so aufdringlich eigentlich nicht ..


    Danke


    Edit: ich hab mal nachgesehen, die Paketübersicht sagt:
    WCF 1.1.10 pl 2 installiert am: 2. Mai 2016, 11:51


    hab ich also offenbar doch schon, (die angaben oben waren von der SystemStatistik nicht aus der Paketübersicht)


    was mach ich nun? den fehler gibts noch immer ;(


    P.S. ich habe mal Pakete Aktualisieren ausgewählt. es sind keine Updates verfügbar - riecht nach alles aktuell?

    Hunde die bellen, beißen nicht? -> nun, ich bin kein Hund. -> Ich belle nicht. - Ich Beiße! 8o

    Edited 2 times, last by Anthrazit: fehler besteht fortgesetzt trotz aktueller Paketversion des wcf ().

  • sch* und was mach ich danun? ich hab das erstmalig installiert und weiß nur das es zB. schon komisch war das ich dem Verzeichnis, das Allinkl. für die install vorgesehen hatte "CHMOD 777 geben muste und das Verzeichnis für das WCF auch nicht automatisch mitkam sondern vorhanden sein musste? mit CHMOD 777?


    ich denke mal das ist das Paket, das da zur Verfügung steht, die 3.1.8 ...


    mehr hab ich ja nicht installiert .. wenn die "zusätzlichen Pakete die "bugfreien" sind, müsst ich die vlt. mal drüber nageln .. derzeit steht ja für die Pakete die installiert sind "keine updates verfügbar") ich will zumindestens den Fehler mit dem Fatal Error wegkriegen, wie das dann zu machen ist ..


    (hab mal ausgerechnet für die 4er Version, wenn ich die als Neukunde holen würde, wäre ich bei 580€ inkl. Profi-Support ... und Brandig-free ;)
    reichlich tiefes Loch im Brieftaschenformat - aber zumindestens kann man ja dann hoffen, das es sich lohnt und keine neuen Probleme dazu kommen ..)


    Aber vorher würd ich gern meiner Auftraggeberin helfen, das Problem los zu werden ...


    nutzt eine "neuinstallation" des verfügbaren Paketes? - der zusätzlich zu dem komplettpaket gebotenen Pakete? ich will nichts von den bisher erreichten Daten verlieren und nicht zwingend nochmal alles neu einrichten - würde ja schnell gehen, weil ich nun ja schon weiß wo wie und was .. aber neu install heißt immer Daten Weg .. und das ja kein Plan langfristig immer wieder neu und neu und neu und nochmal neu zu installieren, bis mal ein Problem gelöst ist ..

    Hunde die bellen, beißen nicht? -> nun, ich bin kein Hund. -> Ich belle nicht. - Ich Beiße! 8o

  • ok so werd ich das tun, ich meld mich dann nochmal oder kann man das thema dahin übernehmen, das hier keine neukunden schlechtes bild kriegen?


    ich werd mich mal um die Freischaltung kümmern Danke schonmal für die Hinweise


    Edit: Frage gestellt: Pm-System 1.1.8.pl2 fortgesetzter Fatal Error

    Hunde die bellen, beißen nicht? -> nun, ich bin kein Hund. -> Ich belle nicht. - Ich Beiße! 8o

    Edited once, last by Anthrazit ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!