MathJax-Integration - BBCode Problem

  • Wer weiterhin Interesse daran hat, schnuckelige mathematische Formeln in seine Beiträge zu zaubern, einfach bei mir melden. Den ursprünglichen Formeleditor gibt es jetzt auch für die WoltLab Suite. Es handelt sich dabei um die Version für das (Burning Board 4.x) die nun angepasst ist.

    Aktuell entwickle ich eine neue Version des Formeleditors, die mehr Individualität zur Verfügung stellen wird (z.B. eigene Kategorien und Zeichen). Allerdings wird das noch etwas dauern.

  • Wer weiterhin Interesse daran hat, schnuckelige mathematische Formeln in seine Beiträge zu zaubern, einfach bei mir melden. Den ursprünglichen Formeleditor gibt es jetzt auch für die WoltLab Suite. Es handelt sich dabei um die Version für das (Burning Board 4.x) die nun angepasst ist.

    Aktuell entwickle ich eine neue Version des Formeleditors, die mehr Individualität zur Verfügung stellen wird (z.B. eigene Kategorien und Zeichen). Allerdings wird das noch etwas dauern.

    Na das kommt ja wie gerufen! Ich habe mit dem Update auf die Suite bis zum Release von 5.1 gewartet und werden nun demnächst ein neues Testsystem aufbauen. Dann würde ich sehr gerne den Formeleditor testen wollen, er wird in unserem Forum sehr häufig genutzt!

  • Wer weiterhin Interesse daran hat, schnuckelige mathematische Formeln in seine Beiträge zu zaubern, einfach bei mir melden. Den ursprünglichen Formeleditor gibt es jetzt auch für die WoltLab Suite. Es handelt sich dabei um die Version für das (Burning Board 4.x) die nun angepasst ist.

    Aktuell entwickle ich eine neue Version des Formeleditors, die mehr Individualität zur Verfügung stellen wird (z.B. eigene Kategorien und Zeichen). Allerdings wird das noch etwas dauern.

    Ich bräuchte auch ein Stück vom Kuchen :whistling:

    Habe bisweilen allerdings gesehen, dass Graphen zwar in LaTeX erstellt werden können, allerdings nur mittels Plugin. Für MathJax soll es wohl so etwas nicht geben :/

  • Die eigentliche MathJax-Bibliothek in der Version 2.7.3 wird vom CDN Cloudflare bezogen. Ggf. sollte das mit in die Datenschutzerklärung aufgenommen werden. Man kann auch andere Server wählen oder die Bibliothek selbst bereitstellen. Dazu muss im WCF-Template-Verzeichnis in der Datei __mathjaxJavaScript.tpl die Pfadangabe des ersten Links entsprechend angepasst werden. Weitere Hilfen dazu findet man unter MathJax-Configuration.

    Sollte etwas nicht funktionieren oder etwas in Hinblick auf die neue Version verbessern wollen, einfach Bescheid geben.

    Wichtig: Ältere Versionen vorher unbedingt deinstallieren!

  • Hallo WollZi,

    ich habe vor kurzem ein Update auf die neuste WBB Version gemacht und musste dafür leider den LatexEditor von dir deinstallieren. Wirst du für die neuste WBB Version den auch bereitstellen? Dies wäre fantastisch :)

    Besten Dank im Voraus und viele Grüße

    inseljohn

  • Ich war mal so frei und habe das Paket ein wenig bearbeitet. Nebst Kompatibilität zum WSC 3.0 - 6.0.0 Alpha 1 habe ich die verwendete MathJax-Bibliothek auf Version 2.7.7 hoch gesetzt und darüber hinaus noch eine Option hinzugefügt, um eine URL zu einer eigenen Installation angeben zu können*. Außerdem habe ich die Plugin-Optionen verschoben (ACP -> Konfiguration -> Nachrichten -> Editor).

    Ansonsten hat WollZi hier ziemlich gute Arbeit geleistet, weshalb im großen und ganzen kaum Änderungen notwendig waren.

    Ein Update von früheren Versionen habe ich der Einfachheit halber unterbunden. Das Paket muss neu installiert und ggf. neu konfiguriert werden.

    * = Ich hätte es auch direkt ins Paket geschmissen, allerdings habe ich die Größe der Bibliothek stark unterschätzt :P

  • Ich habe es vor ein paar Tagen noch manuell installiert :/

    Unter 5.2

    Naja, du hast ja auch die Selfhost Variante Installiert. ;)


    * = Ich hätte es auch direkt ins Paket geschmissen, allerdings habe ich die Größe der Bibliothek stark unterschätzt

    Ja, am Ende ein Plugin mit ca. 90 MB ist nicht ohne. ;) Habe es vor ca. 4 Wochen, für mich in beiden Varianten erstellt. ;)

    Greetz

    Dark

    Mit dem Ende naht der Anfang mit etwas Neuen, um dann wieder zu sagen „Nach dem Update ist vor dem Update“. :S

    Edited once, last by Darklord (April 22, 2020 at 10:11 AM).

  • Hallo zusammen! Ich hab bei den 5 Seiten Thread tatsächlich nicht mehr durchgeblickt und im Plugin-Store auch nichts gefunden. Ich hoffe ihr könnt mir trotzdem helfen.

    Installieren konnte ich nur die Datei "de.wollzi.typhoon.editor.texeqnedit_v1.1.2", alles danach wurde mir als inkompatibel abgelehnt. Kann ich die Version nutzen? Wenn ja, wie? :D

  • Hallo zusammen! Ich hab bei den 5 Seiten Thread tatsächlich nicht mehr durchgeblickt und im Plugin-Store auch nichts gefunden. Ich hoffe ihr könnt mir trotzdem helfen.

    Installieren konnte ich nur die Datei "de.wollzi.typhoon.editor.texeqnedit_v1.1.2", alles danach wurde mir als inkompatibel abgelehnt. Kann ich die Version nutzen? Wenn ja, wie? :D

    Das Paket hier ist mit WSC 3.0.0 bis 6.0.0 kompatibel.

  • Sorry, falls das eine dumme Frage ist, aber wo? Unter Konfiguration > Pakete > Pakete > "Nach Updates suchen" erhalte ich nur "Dein System ist auf dem aktuellen Stand, es wurden keine ausstehenden Updates gefunden."

    EDIT: Habe mal das Paket [Entwickler] Optionen-Kategorie "Editor" installiert, dann starrtet die Installation von MathJax. Jetzt kriege ich folgenden Fehler:

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!