HTTP 404 error when there are not threads in a forum

  • Affected App
    WoltLab Suite Forum

    The empty forums show 404 error for search crawlers. The users can view the forum, but the search crawlers receive a 404 status code.

  • Hi @Alexander Ebert,

    If the page exists the forum should not send 404 because the empty forums will be removed from Google search, you will receive 404 error every day in the Webmaster Tool and you can be banned from Google Adsense (the ads in the 404 pages are prohibited).


    I mean, you have rightfully complained about these soft 404s back there: Soft 404


    In this case it was a bug. The forum did not send any code (404 or 200). The response code column was empty.

  • If the page exists the forum should not send 404 because the empty forums will be removed from Google search

    This also affects pages that are filtered by parameters which in return yield no results. There are only two possible options to solve this:

    You either have to go with one of these options, you can't suppress soft-404 from popping up if you decide to send the status code 200. Well, Soft-404 and 404 are perfectly fine and Google won't punish you for it, but unfortunately people don't accept this fact (despite Google itself says it, see link above!).

    If the page exists the forum should not send 404 because the empty forums will be removed from Google search

    That's a negative, you can validate it by yourself by using "Fetch as Google", you can see that it will always send a status code and in case of empty forums it send a HTTP 200. PHP always sends a 200 unless a different status code was set or PHP itself fails (error 5xx). It is not possible to not send a status code, because at least the webserver will always set one.

  • I have a doubt...

    Imagine this forum:

    How the search crawlers going to find effectively forums into the "Painting" forum if this forum displays 404 for search engines? Is not better use noindex metatag for large urls with filter parameters?

  • 404 and noindex have the same result and search engines treat 404 as a sign of a healthy website which won't hurt your rank, especially Google has explicitly confirmed this.

    But Google follow the urls into this page? If Google search the "painting" forum with 404 response code, Google follow the links to the other forums (classicism and avant-garde)?

    Edit. @Alexander Ebert can you confirm me this?

    Edited once, last by Aethior (June 14, 2015 at 1:36 PM).

  • About this... HTTP 404 error when there are not threads in a forum

    But Google follow the urls into this page? If Google search the "painting" forum with 404 response code, Google follow the links to the other forums (classicism and avant-garde)?
    Edit. @Alexander Ebert can you confirm me this?

    After not receive response I did a experiment: http://www.aethior.com/lab/woltlab-burning-board/

    The forums into a empty forums isn't indexed. The 404 status for empty forums are complicating the indexation.

    Notes.

    • This is the goal: http://www.aethior.com/lab/woltlab-burning-board/thread/2-lorem-ipsum-dolor-sit-amet-waiting-indexation/
    • I sent the URL (http://www.aethior.com/lab/woltlab-burning-board/) to Google by Webmaster Tool using URL and linked pages submitted to index option.
    • You can check the indexed threads using site:www.aethior.com/lab/woltlab-burning-board/thread/
    • The past days I edited some threads with other title and information and Google updated the index correctly.


    Edit. Who moved this post? This post was posted in General Discussion because I can't reply in this thread. This post it isn't a bug report, It is a feedback about the software.(cc @Alexander Ebert)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!