[beta 4] Must clear cache for Maintenance Mode

  • Affected App
    WoltLab Suite Forum

    So I noticed that I must always clear the cache for changes to take affect. This include turning on Maintenance Mode.

    • Official Post

    There were no changes affecting this at all, do you use some kind of opcache? The options set in the ACP are written to the wcf/options.inc.php file, probably the file change is not properly detected by the opcache, thus the new file is not read at all. I remember that early versions of APC were prone to this error, but these are really old versions, so this might no be the case.

  • There were no changes affecting this at all, do you use some kind of opcache? The options set in the ACP are written to the wcf/options.inc.php file, probably the file change is not properly detected by the opcache, thus the new file is not read at all. I remember that early versions of APC were prone to this error, but these are really old versions, so this might no be the case.

    I noticed this in the previous beta's, but kept forgetting to report it. I do indeed use opcache on php 5.6.5 (current). So I'm not using an old version.


    Have a look for yourself


    https://sociallyuncensored.com/check.php

  • Hi


    you have to enable opcache.revalidate_path. you should set opcache.revalidate_freq to a smaller value.

    I was going to say... Enabling opcache.revalidate_path would be counter productive. Zend OPcache themselves tell you keeping it disabled, is how the optimization works best.


    http://files.zend.com/help/Zen…r-opcache.revalidate_path



    What would you suggest for an optimum value for opcache.revalidate_freq? I personally believe it's fine.

    • Official Post

    I have applied a small change which will force cache invalidation when the options file is rewritten, that should resolve that issue for you. Please try out the file attached (overwrite the file in wcf/lib/data/option/), it should work smoothly for you now without requiring any changes to your config.


    By the way, the default value is pretty low (2 seconds) to avoid these kind of issues, while having a greater value is okay, you should keep an eye on it.

    • Official Post

    I just realized that this rather enormous setting might cause a lot more issues as it affects the package installation (files updated between requests), compiled templates and all this stuff.

  • I just realized that this rather enormous setting might cause a lot more issues as it affects the package installation (files updated between requests), compiled templates and all this stuff.

    Are we talking about my setting or your changed file? I'm sorry, I'm a little thick. lol

  • I have applied a small change which will force cache invalidation when the options file is rewritten, that should resolve that issue for you. Please try out the file attached (overwrite the file in wcf/lib/data/option/), it should work smoothly for you now without requiring any changes to your config.


    By the way, the default value is pretty low (2 seconds) to avoid these kind of issues, while having a greater value is okay, you should keep an eye on it.

    This file works nicely. Thank you :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!