Fehlende PHP 5.5 Kompatibilität

  • Mit dem WCF 1.1.10 sowie WBB 3.1.8 wurden einige Fehler behoben, welche ein Betrieb unter PHP 5.5 verunmöglichten. Jedoch sind immer noch teils Fehler enthalten, welche einen Betrieb unter PHP 5.5 momentan nicht möglich machen. Untenstehend z.B. aus dem Private Message System:


    • Official Post

    Die Stelle kann ich bestätigen, wurde in der Entwicklungsversion bereits behoben. Ein Patch Level-Update erfolgt kurzfristig.


    Weitere derartige Stellen kann ich nicht bestätigen. Falls dir welche bekannt sind, bitte hier melden.


    Edit: Das besagte Update steht inzwischen über den Update-Server zur Verfügung.

    Marcel Werk
    WoltLab CEO

  • SoftCreatR


    Hast du die Version 1.1.10 des WCF installiert? Bei mir sieht die besagte Zeile folgendermassen aus:


    PHP
    $alterStatements[2][$key] = preg_replace("~('[^'\\\\]*(?:(?:'(?=')|\\\\).[^'\\\\]*)*')~s", "''", $alterStatements[2][$key]);
  • Hallo zusammen,

    vermutlich bin ich der letzte, der das WCF 1.1 noch einsetzt (ich weiss, kein Support mehr) doch nun will ich endlich mal updaten.

    Das Problem ist, dass die WS 3.1 mindestens mysql 5.5 braucht, aktuell läuft auf dem Server aber noch 5.1


    Ein Update ist kein Problem, aber wird mein altes Forum dann noch laufen, damit ich das neue vorbereiten und dann die Daten ins neue importieren kann? Das geht sicher nicht an einem Tag...


    wcf/lib/acp/package/plugin/SqlPackageInstallationPlugin.class.php hat's noch drin.

    Das habe ich gerade mal nachgetragen.


    Viele Grüße,

    Martin

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!