Anzeigefehler

  • Affected App
    WoltLab Suite Forum

    Hallo zusammen


    Im Moment bin ich am überlegen, ob ich für ein neues Projekt das neue WBB4 nach der Veröffentlichung nehmen werden. Allerdings ist mir beim surfen in diesem aufgefallen, das auf meinem Arbeitsrechner das Forum fehlerhaft dargestellt wird. Ebenso sind einige Funktionen blockiert. Zum Beispiel Dateianhänge. Daher kann ich gerade auch keinen Screenshot anhängen.


    Browser vom Arbeitsrechner ist Internet Explorer 8 und Betriebssystem ist Windows XP. Die Sicherheitseinstellungen sind auf Mittel. Fehlermeldungen haben ich mitangehängt.


    Meine Frage daher, ist dies im Moment normal und wird noch angepasst? Kann es vorkommen, dass auf einigen Rechner dass Forum nicht funktioniert? Oder habe ich als Betreiber die Möglichkeit, dass wenn der Nutzer bestimmt Vorraussetzungen nicht erfüllt, er eine alternative Darstellung angeboten bekommt?.


    Details zum Fehler auf der Webseite


    Benutzer-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0)
    Zeitstempel: Wed, 30 Oct 2013 13:19:18 UTC



    Meldung: Object doesn't support this property or method
    Zeile: 4
    Zeichen: 6105
    Code: 0
    URI: http://ajax.googleapis.com/aja…query/2.0.1/jquery.min.js



    Meldung: 'jQuery' is undefined
    Zeile: 5
    Zeichen: 1
    Code: 0
    URI: http://ajax.googleapis.com/aja…i/1.10.3/jquery-ui.min.js



    Meldung: Object doesn't support this property or method
    Zeile: 4
    Zeichen: 6105
    Code: 0
    URI: http://beta.woltlab.com/wcf/js…/jquery.min.js?v=5a725ae1



    Meldung: 'jQuery' is undefined
    Zeile: 5
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js…uery-ui.min.js?v=5a725ae1



    Meldung: 'jQuery' is undefined
    Zeile: 13
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js…ortable.min.js?v=5a725ae1



    Meldung: 'jQuery' is undefined
    Zeile: 4
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js…epicker.min.js?v=5a725ae1



    Meldung: 'jQuery' is undefined
    Zeile: 1
    Zeichen: 13
    Code: 0
    URI: http://beta.woltlab.com/wcf/js/WCF.min.js?v=5a725ae1



    Meldung: 'WCF.User' is null or not an object
    Zeile: 464
    Zeichen: 2
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: 'WCF' is null or not an object
    Zeile: 1
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js/WCF.Message.min.js?v=5a725ae1



    Meldung: 'WCF.User' is null or not an object
    Zeile: 1
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js/WCF.User.min.js?v=5a725ae1



    Meldung: 'WCF' is null or not an object
    Zeile: 1
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js/WCF.Like.min.js?v=5a725ae1



    Meldung: 'WCF' is null or not an object
    Zeile: 1
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js/WCF.Label.min.js?v=5a725ae1



    Meldung: 'WCF.Collapsible' is null or not an object
    Zeile: 1
    Zeichen: 25
    Code: 0
    URI: http://beta.woltlab.com/js/WBB.min.js?v=5a725ae1



    Meldung: 'Class' is undefined
    Zeile: 1
    Zeichen: 30
    Code: 0
    URI: http://beta.woltlab.com/blog/js/Blog.min.js?v=5a725ae1



    Meldung: 'Class' is undefined
    Zeile: 1
    Zeichen: 38
    Code: 0
    URI: http://beta.woltlab.com/fileba…ilebase.min.js?v=5a725ae1



    Meldung: Object expected
    Zeile: 476
    Zeichen: 2
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: 'jQuery' is undefined
    Zeile: 8
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js/3rdParty/slimbox2.min.js



    Meldung: 'WCF' is null or not an object
    Zeile: 1
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js…eViewer.min.js?v=5a725ae1



    Meldung: Object expected
    Zeile: 578
    Zeichen: 3
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: Object expected
    Zeile: 593
    Zeichen: 3
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: Object expected
    Zeile: 621
    Zeichen: 6
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: 'WCF' is null or not an object
    Zeile: 1
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js…rsation.min.js?v=5a725ae1



    Meldung: Object expected
    Zeile: 637
    Zeichen: 5
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: 'WCF.Search' is null or not an object
    Zeile: 1
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js…Message.min.js?v=5a725ae1



    Meldung: Object expected
    Zeile: 651
    Zeichen: 3
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: Object expected
    Zeile: 658
    Zeichen: 3
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: 'WCF' is null or not an object
    Zeile: 1
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js/WCF.Tagging.min.js?v=5a725ae1



    Meldung: Object expected
    Zeile: 673
    Zeichen: 2
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: Object expected
    Zeile: 681
    Zeichen: 3
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: 'WCF' is null or not an object
    Zeile: 1
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/wcf/js…achment.min.js?v=5a725ae1



    Meldung: Object expected
    Zeile: 689
    Zeichen: 2
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: Object expected
    Zeile: 708
    Zeichen: 2
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: Object expected
    Zeile: 716
    Zeichen: 2
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/



    Meldung: Object expected
    Zeile: 735
    Zeichen: 1
    Code: 0
    URI: http://beta.woltlab.com/index.php/ThreadAdd/7/

    • Official Post

    Internet Explorer 8 wird von uns nicht mehr unterstützt, ich zitiere aus der Ankündigung zu Burning Board 4:


    Systemvoraussetzungen


    Für die Installation und Nutzung von WoltLab Burning Board 4.0 müssen folgende Voraussetzungen erfüllt sein:


    Webserver mit PHP 5.3.2+
    MySQL 5.1.17+
    20 MB Festplattenspeicher
    Aktueller Webbrowser (Chrome 27+, Firefox 21+, Internet Explorer 9+, Safari 6+)

  • Demnach schliesse ich alle Nutzer aus, die diese Vorraussetzung nicht erfüllen. Nicht gut.


    Gibt es eine Möglichkeit. Das wenn ein Internet Explorer 8 Nutzer auf meine Seite surft, dass er darauf aufmerksam gemacht wird? Oder ist etwas geplannt, dass zumindest die Seite einigermasen gut dargestellt wird? Ich möchte ungern einen Teil meiner Besucher vom Forum ausschliessen, nur weil Sie den falschen Browser benutzen.

    Edited 2 times, last by Maikeeey ().

    • Official Post

    Jedes Windows-Betriebssystem nach Windows XP unterstützt Internet Explorer in Version 9 oder höher.


    Die vollständige Unterstützung für Windows XP wird am 8. April 2014 endgültig eingestellt, das heißt es gibt absolut nichts mehr, selbst bei schwerwiegenden Sicherheitslücken wird Microsoft nichts mehr beheben. Wer ab diesem Zeitpunkt weiterhin Windows XP einsetzt handelt grob fahrlässig.


    Der Aufwand Internet Explorer 8 zu unterstützen rechnet sich schlicht nicht, dieser Browser unterstützt nicht mal im Ansatz halbwegs aktuelle Techniken.

  • Vielen Dank für die Antworten und Hilfe.


    Unter diesen Umständen werde ich mich wohl gegen das WBB4 entscheiden. Leider gibt es noch zu viele Nutzer für mich die Internet Explorer 8 oder früher nutzen und diese werde ich nicht ausschliesen.


    Wenn es zumindest ein Plugin gebe, dass Nutzer eines veralteten Browsers erkennt und darauf hinweist, wäre es noch nachvollziehbar. Aber so ist die Software für ein grosses Forum für mich im Moment leider nicht brauchbar.

  • Vielen Dank für die Antworten und Hilfe.


    Unter diesen Umständen werde ich mich wohl gegen das WBB4 entscheiden. Leider gibt es noch zu viele Nutzer für mich die Internet Explorer 8 oder früher nutzen und diese werde ich nicht ausschliesen.


    Wenn es zumindest ein Plugin gebe, dass Nutzer eines veralteten Browsers erkennt und darauf hinweist, wäre es noch nachvollziehbar. Aber so ist die Software für ein grosses Forum für mich im Moment leider nicht brauchbar.


    Ja, dann lasse es doch. Ich kann das verstehen, warum sollte man alte Browser noch unterstützen, wenn jeder seinen Browser aktualisieren kann?
    Mit der Argumentation müsste man ja auch noch den IE7, IE6, IE5 etc. unterstützen. Das geht einfach nicht, da die Techniken der Browser einfach nicht in der Lage sind, die neuen Standards darzustellen. Würde man die unterstützen, würden die neuen Browser irgendwann nicht mehr gehen, da alte Funktionen aus den Browsern entfernt werden. So würde man dann die neuen Browser ausschließen und das ist auch nicht besser.


    Mit der Zeit gehen und nicht in der Steinzeit warten...

  • Ist schon nachvollziehbar, dass wegen der neuen Funktion nicht alle Browser unterstütz werden können. Aber eine Möglichkeit den Nutzer darauf aufmerksam zu machen, ohne das er einfach ein grauenvoll präsentiertes Forum vorgesetzt bekommt, wäre denke ich angebracht.


    Von Steinzeit zu reden finde ich schon sehr frech. Ich hoffe, dass hier nicht alle so ticken. Hast du dir mal aktuelle Nutzungsstatistiken der Versionen vom Internet Explorer angeschaut, wenn man eine breite Masse ansprechen möchte, muss man diese Kunden auch berücksichtigen.

  • Ich kann das verstehen, warum sollte man alte Browser noch unterstützen, wenn jeder seinen Browser aktualisieren kann?


    Bitte mal einen Blick über den Tellerrand wagen: Nicht jeder kann den verfügbaren Browser (z.B. des Arbeitsplatzrechners) aktualisieren. Es hat schon seine Gründe, warum der IE8 noch einen Marktanteil von ca. 20% hat...
    Trotzdem ist es recht einfach: wer auf betroffene User zumindest zeitweise verzichten kann, wechselt. Wer nicht, wechselt eben nicht.

    utester

  • Es hat schon seine Gründe, warum der IE8 noch einen Marktanteil von ca. 20% hat...


    Naja, das ist doch etwas geschönt ;)


    Weltweit ca 10%, In Europa ca 7% und in Deutschland unter 5%.


    Mit der 2014 endenden Unterstützung von XP werden außerdem auch viele Firmennetzwerke geupdated werden (müssen), was die Zahlen nochmal drastisch nach unten korrigieren dürfte. Sieht man sich an, dass WCF2 / WBB4 langfristig zukunftsfähig sein sollen, so macht eine Unterstützung wenig Sinn (ich habe hier auch noch nen WIn XP Rechner stehen, der regelmäßige Benutzung erfährt, insofern kann ich gut nachvollziehen, wenn jemand nicht updaten kann, ich kann das also durchaus nachvollziehen).

    "A life is like a garden. Perfect moments can be had, but not preserved, except in memory. LLAP" — Leonard Nimoy

  • Moin,


    sorry, die Angabe "ca. 20%" bezog sich auf die IE-Versionen, nicht auf den gesamten Browsermarkt. ACK zum Rest; siehe auch mein o.a. "zumindest zeitweise".


    Mir ging es nur um die gequotete Aussage, dass jeder seinen Browser aktualisieren kann.

    utester

  • Portable-Versionen von Browsern kann jeder auch im Firmennetzwerk starten, so lang das nirgendswo verboten wird (vertraglich).
    Aber ganu durch so ein Verhalten, alte Versionen in Unternehmen zu nutzen, werden diese gehackt und meine Daten (Kundendaten) fliegen dann überall im Netz herum. Das ärgert mich tierisch. Ich arbeite in einem Krankenhaus (EDV-Abteilung). Würde ich die Systeme da nicht aktualisieren und Patientendaten würden entwendet werden, wäre das Geschrei groß. Ich finde es fahrlässig, die Systeme nicht zu aktualisieren. Und den IE10 kann sich jeder installieren, wenn Windows 7 mindestens installiert ist. Und das im Jare 2013 sollte aus meiner Sicht in jedem Unternehmen das Minimum sein.


    Das ist halt meine Meinung. :)

  • Ich hatte früher Beruflich auch viel mit Firmen zu tun und konnte manchmal ihre alten Schinken sehen die schon sehr alt waren.
    Das hat aber meistens ein Grund, sie vertreiben ein Produkt und dass meistens auch mit ihrer eigenen Software und da ändert sich nicht jedes Jahr immer alles und Mitarbeiter müssen dann auch neu gelernt werden. So verzichtet man auf neue Systeme solange man noch damit auskommt.


    Bei einer Firma wo wir die Firmenspedition waren konnte ich es mal mit erleben was das für ein Problem war als die Firmensoftware ausgetauscht wurde, die haben dann zum teil die Lieferscheine auch von Hand komplett geschrieben wenns Probleme gab, weil sie wieder mal mit der neuen Software nicht klar kamen oder diese noch kleine Macken hatte. Denen wurde sogar Vertraglich verboten überhaupt ins Internet zu gehen.


    Wir brauchen da nicht weit gehen, ich habe noch ein Laptop aus dem Jahr 2005. Damals hat es mich 1400 Euro gekostet und war eines der besten Laptops. Heute kann ich es nur noch fürs Internet nutzen. Neue Programme oder Spiele die damals super liefen gibt es nicht mehr dafür, denn die Hersteller stellen sich auch hier immer auf neue Systeme und können alte Systeme die Hardware bedingt solch eine Technologie nicht haben berücksichtigen. Aber selbst hier kann ich noch mit dem XP aktuelle Browser nutzen, zumindest was FireFox und IE10 angeht.


    Ich habe letztens mein Forumstyle etwas bearbeitet und hatte schon Schwierigkeiten es an die aktuellen Browser richtig darstellen zu lassen.
    Aber ich hatte es geschafft und war richtig happy.
    Bis mich dann ein Mitglied darauf aufmerksam machte dass die Darstellung auf seinem Firmenrechner mittels IE9 nicht richtig dargestellt wurde, meine Hintergrundfarben in bestimmten Bereichen die ich extra eingerichtet hatte wurden nicht angezeigt. Ich habe auch dieses am ende hin bekommen, aber im IE8 und niedriger ist hier aber auch schon eine Grenze erreicht. Hier kann ich aber nichts daran ändern außer vielleicht ein Sytle zu verwenden der halbwegs gut angezeigt wird und man selbst auswählen kann.


    Ich denke es ist richtig mit der Zeit zu gehen und deren Technischen Möglichkeiten ausschöpfen zu können und da kann man es leider der alten Systeme nicht immer recht machen.


    Gruß Coolman

  • Aber selbst hier kann ich noch mit dem XP aktuelle Browser nutzen, zumindest was FireFox und IE10 angeht.


    Der IE 8 ist der aktuellste IE, der auf XP läuft ^^
    Aber gibt ja genug moderne Browser, die auch auf XP noch laufen.
    Bei mir in der Schule ist zum Glück ein Firefox installiert, auch wenn der schon nachm Öffnen des Browsers nur noch am Swappen ist - 256 MB RAM sind einfach 3,813 GB RAM zu wenig :P
    Linux vom USB Stick läuft da runder als XP *duck*
    Mal sehen, was die Schule macht, jetzt wo XP ja (endlich) langsam ausstirbt. Neue Computer mit einem Windows 7 wären voll in Ordnung.
    Windows 8 kann man da keinem antun, vor allem den Lehrkräften nicht.

    » Hat zu tief ins Glas geschaut: Hellseher verletzt sich an Wahrheitskugel «

    GitHub

  • Der IE 8 ist der aktuellste IE, der auf XP läuft


    Also dem IE8 habe ich nicht drauf da bin ich mir sicher!
    Muss aber mal schauen ob es der IE9 ist.


    Edit: Ok, ich nehme es zurück hast Recht, habe nachgesehen, ist doch der IE8.
    Ich nutze den Laptop normal nicht mehr und hatte ihn schon lange nicht mehr an.


    Dann habe ich mich halt geirrt. :)
    Aber es hat schon ein Grund wieso ich ihn schon lange nicht mehr genutzt habe, da ich meinen Rechner habe und der auf dem Aktuellen Stand ist. ;)


    Gruß Coolman

  • Wenn es zumindest ein Plugin gebe, dass Nutzer eines veralteten Browsers erkennt und darauf hinweist, wäre es noch nachvollziehbar.


    Ich habe es zwar nicht selbst getestet, aber schau dir mal das hier an:
    www.browser-update.org


    Du kannst ja mal im Footer-Code folgendes einfügen:


    Edit:
    Ich habe das jetzt mal in ein Plugin gepackt (Screenshot 163). Ich kläre noch die Lizenz genauer ab und wenn ich darf lad ich das mal hoch. :)

  • Die vollständige Unterstützung für Windows XP wird am 8. April 2014 endgültig eingestellt, das heißt es gibt absolut nichts mehr, selbst bei schwerwiegenden Sicherheitslücken wird Microsoft nichts mehr beheben. Wer ab diesem Zeitpunkt weiterhin Windows XP einsetzt handelt grob fahrlässig.


    Immer Lustig: Viele haben immer das neuste Handy auf dem Markt, aber krebsen Zuhause mit einer alten Möhre mit WinXP noch herum. Wenn man so viel Geld raus wirft für teure Marken-Handys (ja ich meine das schei** Apfelhandy), dann sollte man wenigstens auch mal einen ordentlichen PC in der Ecke stehen haben auf dem logischer Weise auch mind. IE9 läuft oder ein aktueller anderer Browser. Ich finde es gut das WoltLab nicht jedem Rentner es Recht machen möchte und in diesem Punkt mit der Zeit geht.

    WoltNet - Wir haben die aktuellen Nachrichten der WoltLab-Szene!

  • Ich habe es zwar nicht selbst getestet, aber schau dir mal das hier an:
    www.browser-update.org


    Du kannst ja mal im Footer-Code folgendes einfügen:


    Edit:
    Ich habe das jetzt mal in ein Plugin gepackt (Screenshot 163). Ich kläre noch die Lizenz genauer ab und wenn ich darf lad ich das mal hoch. :)


    Super MysteryCode, endlich jemand der konstruktiv mitwirkt. Genau das habe ich gesucht. Das löst mein Problem völlig. Perfekte Arbeit :)

    Edited once, last by Maikeeey ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!