WoltLab Cloud Thread Top Info 5.3.1

Adds information to a topic below the topic title.

This small plugin (almost too little for a plugin...) adds additional information to a topic below the topic title. It is the adaptation for WoltLab Suite 5.3 and 5.4. a version for the older forum versions is available separately.


Prerequisite:

At least WoltLab Suite Forum 5.3.15. The plugin also runs under WoltLab Suite 5.4.


Displayed is a message in the form There are 68 replies in this topic which has been viewed 1713 times. The latest post (Jan 01, 2022) is by djblueprint..


If a topic has no reply(s) yet, no message is displayed.


Here "last post" is linked to the last post in the topic and the author of the last post is linked as usual (including hover).


There are no additional options. Just install it and the message is available on every thread. The text can be customized via a language variable:


wbb.thread.en.3d-board.threadTopInfo (DE and EN are included).


The message has been given its own CSS class (threadTopInfo), so it can be easily adapted to different styles via CSS.


For example, to increase the distance between the thread title block and the ThreadTopInfo, this CSS code can be used:

Code
/* Styling für ThreadTopInfo Plugin */
.threadTopInfo {    margin-top: 10px;
}

Questions info, suggestions in the comments or on https://www.wsc-support.de

Images

  • Version 5.3.1

    Bugfixes (spelling mistake, XSDs)

  • Version 5.3.0

  • Sehr gut, optisch würde ich es besser finden wenn die Info direkt unter dem Titel und Label beginnt statt unter dem Avatar. Aber sonst, sehr gut.

    Thanks 1
    • Danke, ich kann mal schauen, ob ich das optional einbaue.

      Thanks 1
  • Großartig, das kenne ich noch von der alten Version des Forums 3.1.7 oder so.

    Vielen Dank dafür, top Plugin :thumbup:

    Like 1
  • Verwende bitte {#$thread->views} statt {@$thread->views}


    Zudem hast du in der englischen Sprachdatei zwei Punkte hintereinander.


    Die XML-Dateien nutzen veraltete XSDs und der Aufbau der package.xml ist auch nicht State of the Art.

    Thanks 1
    • Danke für die Hinweise. War lange raus und muss mich erstmal in die neuen Anforderungen reinfinden. Die alte Version hatte ein Update auf 5.x verhindert, da wollte ich vor allem eine lauffähige Version zur Verfügung stellen. Werde das anpassen.

      Thanks 1
    • Habe soeben eine korrigierte Version (5.3.1) hochgeladen, danke nochmal :)
      Gruß,
      Sascha

      Like 1 Thanks 1