WoltLab Cloud WSC-Connect - Smartphone app with push messages for your forum (WSC version) 3.0.20

WSC-Connect connects all your favorite WSC (WoltLab® Suite Core)-Apps in one place. Receive notifications via push message and more.

You can find the version for the WBB 4.1/WCF 2.1 here:


WSC-Connect connects all your favorite WSC (WoltLab® Suite Core)-Apps in one place. Receive notifications via push message and more:

  • Multiple WSC-Apps in one native smartphone App
  • Push notifications
  • Send custom push messages from the web interface
  • and more …

All in one

With WSC-Connect you access all your sites in one app. Check your notifications, conversations and the website right from the app.


Admin area

The dashboard on http://www.wsc-connect.com gives you an overview of your app and your users. Additionally you can send push messages to all of your users.


Go to https://www.wsc-connect.com/ to find more information and the free registration.

Images

  • Version 3.0.20

    - Usage of a new event in WSC 5.2 to only send proper created notifications (https://github.com/Christopher…8e18239de230afd30d2d85066)

  • Version 3.0.19

    - Fixes a problem with the API-URL

  • Version 3.0.18

    - Fixes a problem with too big notifications

  • Version 3.0.17

    - Fixes potential bug with language variable

  • Version 3.0.15

    - New style for info banner & display it on iOS devices

  • Version 3.0.14

    - Fixes a problem with multiple devices

    - Small changes for the new API

  • Version 3.0.13

    - Supports multiple devices (logout & login necessary)

  • Version 3.0.12

    - the latest conversation messages are now at the top

  • Version 3.0.11

    Privacy update: The content of the push notifications are now encrypted

  • Version 3.0.10

    - Fixes a possible bug with the Apache webserver

    - Compatibility with WSC 3.1

  • Hello Darkwood.Design,


    It appears that the WSC-Connect app (and website) can't connect to anyone's forum/community since earlier today (the app shows 0 connected websites, and trying to use the app on my own phone just results in an endless loading once I open it). Can you take a look?


    Thank you!

    • Thanks for the report. After a server restart, the service did not start properly. The problem has been fixed. The app is up again.

      Like 1
  • Moin


    Das WSC-Connect habe ich bereits seit 5.3 auf unserem Board. Mit der 5.5 bekomme ich nun von meinen Usern die Rückmeldung das sie sich nicht mehr abmelden können, weil da so eine "komische Werbung" über dem Abmelden Button ist.

    Ja es stimmt. Der Hinweis das dieses Forum WSC-Connect benutzt und man es doch gerne downloaden kann, verdeckt den Abmelden Button im Menü. Ich nutze übrigens das Standarddesign mit ein paar kleinen Anpassungen. Mir ist das zunächst nicht aufgefallen, da ich die App ja installiert habe. Natürlich kann man den Balken einfach weg klicken aber schöner wäre es wenn das Menü über dem Hinweis eingeblendet wird.


    Ist dies ein Problem des Plugins oder eines seitens Woltlab? Oder gibt es sogar ein Workaround um das einfach zu beheben?


    LG und lieben Dank

  • Hallo Darkwood,

    seit gestern erhalte ich push Nachrichten von WSC(Android) mit ein paar Zeilen Code, kennst du das Phänomen?

    Soll ich bei dir ein Ticket aufmachen?

    lg

  • Hi,


    ist WSC Connect mit 5.5 kompatibel?

    lg

  • Hallo,


    ich habe unter WSC 5.4 das wsc-connect installiert und auch auf der entsprechenden Webseite mich registriert und erfolgreich mein WSC Forum eingetragen. Auf dem iPad wie auch iPhone kriege ich nun die Benachrichtigungen meines Forums. Leider funktioniert es mit den Nachrichten nicht. Auch das Forum kann ich nicht sehen. Vermutlich muss man da noch irgendeine Berechtigung setzen, welche ich bis jetzt nicht gefunden habe.

    Ich habe mich dann an einem anderen Forum angemeldet und auch hier funktioniert nur die Benachrichtigung. Was mache ich den falsch?


    Mein Forum http://www.8er.org


    LG

    Christoph

  • Hello,


    Thanks for such a good plugin. I have got a question :


    How to complete this? Which plugin exactly to install?


    Tab: Conversations (Requirement: The conversation plugin from WoltLab has to be installed)

  • I'm having the error "ERR_CLEARTEXT_NOT_PERMITTED" error. my forum members cannot access the website via WSC connect


    The url in the app is the correct one : https://vlaamshobbybrouwforum.be/forum/


    Can you please have a look?

    • Your webserver has multiple redirects, one which redirects to http: https://i.imgur.com/3Q5bnmd.png

      Fix the http redirect and it should work fine!

    • Thanks, problem solved. :thumbup: Great support :)

    • Unfortunately, the issue is back again. There are no redirects anymore but for some reason the app keeps referring to the http:/ path instead of https:/ ?

  • Moin


    Leider bekommen wir seit zwei Tagen immer wieder die Meldung das die App deaktiviert wurde. Die URL wurde jedoch nicht verändert. In den App-Einstellungen ist die WSC-Connect-API vorgegeben und auch genauso im Profil eingetragen. Der Aufruf der API-Seite ergibt folgende Meldung:


    Code
    {"code":403,"file":null,"line":null,"message":"Access not allowed","previous":[],"returnValues":[]}


    Was können wir tun um das Problem zu lösen.


    Vielen Dank

  • Hi

    If I am logged in with a smartphone and try to enter the forum from a computer at the same time, the forum crashes, I have to log out of WSC-Connect on the smartphone, then everything will be normal on the forum again :?:

    • What does


      Quote

      the forum crashes

      mean? Any error message?

    • Sorry, it was my own fault, I have translated the xml file into Norwegian, but I translated a little too much.
      sorry everything is ok

  • hello there,


    tis app is not working after uploading to the latest version of wbb 5.4.2

    what could be the problem, it keeps saying, i reinstalled the plugin still no successs


    it gives following error


    Code
    {"code": 403, "file": null, "line": null, "message": "Access not allowed", "previous": [], "returnValues": []}

    pus i am not in maintenance mode. Please help


    Your API URL is wrong or not accessible

  • Ich habe ein merkwürdiges Problem, ich habe 2 Foren, aktuellste 5.3.7, in dem einen Forum klappt alles, Nachrichten werden durch die App angezeigt, Push Nachrichten, alles ist perfekt.

    Wenn ich dort mit dem Handy über Telefon, nicht wlan, eingeloggt bin, wird mir im Forum am PC das Handy richtig angezeigt.

    Im zweiten Forum, ich bin über Handy ohne wlan in der App im Forum eingeloggt, zeigt es mir am PC an, ich bin mit keinem Gerät eingeloggt.

    Ich bekomme in der App Benachrichtigungen und Nachrichten als vorhanden angezeigt, dann kommt eine weiße Seite und es lädt sich tot.

    Passiert weiter nichts, wird nichts geladen. Ich habe Push Nachrichten über WSC Connect verschickt, 2x und über Wsc connect.com wird mir der Versand bestätigt.

    Angekommen ist nichts bei dem einen Forum.

    Beide Foren auf gleichem Server, identische Einstellungen.

    Was ist da los?

    Hat sich erledigt, App neuinstalliert, geht wieder alles.

  • Die Website unter xxx.xx konnte nicht geladen, weil:


    Code
    net::ERR_CLEARTEXT_NOT_PERMITTED
    • Du hast vermutlich die falsche Domain hinterlegt. Um welche Website geht es?

    • Habe dir eine PN geschrieben.

  • Aus bisher ungeklärten Gründen enthalten wir seit neuestem folgende Fehler:


    Code
    openssl_public_encrypt(): key parameter is not a valid public key


    Offensichtlich können die Schlüssel aus der Datenbank nicht (mehr) richtig gelesen werden.

    • Hm, höre ich jetzt zum ersten Mal. Gabs ein DB-Umzug oder servertechnisch irgendwelche Änderungen?

      Sehen die Keys in der DB denn OK aus oder irgendwas kaputt?

    • Auf den ersten Blick sehen die Keys in der Datenbank in Ordnung aus. Vielleicht sind auch nicht die Keys das Problem, sondern das Fallback, wo der Pubkey vom Plugin verwendet wird?

    • Könntest du da mal ein kleines Logging einbauen?


      PHP
              try {
                  openssl_public_encrypt($secret, $encryptedSecret, $publicKey, OPENSSL_PKCS1_OAEP_PADDING);
                  openssl_public_encrypt($iv, $encryptedIv, $publicKey, OPENSSL_PKCS1_OAEP_PADDING);
              } catch (\Exception $e) {
                  $e2 = new \Exception("publickKey: {$publicKey}", 0, $e);
                  \wcf\functions\exception\logThrowable($e2);
                  throw $e2;
              }

      Das logThrowable brauch man vermutlich gar nicht, wird ja automatisch geloggt. Damit könnte man zumindest sehen, an welchem Key es liegt.

  • Leider ist die Registrierung bei mir erst garnicht möglich :/


    erhalte beim anmelden die Mldung : Deine API-URL ist nicht erreichbar

    (https://botendeszorns.de/core/index.php?wsc-connect-api/)

    Code
    {"code":403,"file":null,"line":null,"message":"Access not allowed","previous":[],"returnValues":[]}
    • Wartungsmodus deaktivieren

    • vielen dank, ja das war es dann. aber gut zu wissen das wenn man eine seite einrichtet, dieses dann nur im "online" betrieb geht :)

  • Hi!


    Ich habe ihre App bzw. ihr Plugin getestet und bisher bin ich sehr zufrieden.


    Leider habe ich nur ein Problem. Ich nutze den Mobilen Stilewechsler von Kittmedia: Mobiler Stilwechsler / Mobile Erkennung


    Ich hab einen Desktop-Stile und einen Mobile-Stile. Wenn ich Ihre App nutze, wird mein Desktop-Style geladen. Ist es möglich eine "kleine" Änderung vorzunehmen, dass nur der Mobile-Stile geladen wird?


    Grüße v. Seferd

    • Hallo,


      In der App wird deine Seite in einem WebView geladen, welcher als mobiler Browser erkannt wird. Wieso der mobile Stilwechsel den nicht erkennt, weiß ich leider nicht. Frage bitte dort mal nach.

      Thanks 1
  • Leider läuft die App seit einigen Tagen nicht mehr.


    "Status: Deine App ist nicht aktiv. Bitte kontrolliere deine ACP-Optionen und vergewissere dich, dass deine API-URL (https://www.dampfer-board.de/wcf/wsc-connect-api/) erreichbar ist. Wenn sich deine API-URL durch einen Server-Umzug geändert hatte, passe diese unten entsprechend an."


    Ich bin der Meinung, alles stimmt. Plugin wurde auch mal neu installiert, hat aber nichts geholfen.


    Grüße

    • Hi, deine App sollte nun wieder aktiv sein. Ich musste einige Änderungen vornehmen, da es Probleme mit den SSL-Zertifikaten gibt.

      Wenn es weitere Probleme gibt, melde dich einfach.


      Grüße

    • Sorry, habe mich lange nicht darum gekümmert. Aber es geht immer noch nicht. Gleiche Fehlermeldung.

    • Ich habe nochmal etwas geändert und deine App wieder aktiviert. Bitte mal für ein paar Tage testen und schauen, ob alles passt :)

    • Hallo,


      habe garnichts gemacht. Bin gerade auf die Seite Übersicht und sehe wieder das rote Fenster:


      Quote


      Status: Deine App ist nicht aktiv. Bitte kontrolliere deine ACP-Optionen und vergewissere dich, dass deine API-URL (https://www.dampfer-board.de/wcf/wsc-connect-api/) erreichbar ist. Wenn sich deine API-URL durch einen Server-Umzug geändert hatte, passe diese unten entsprechend an.

      Kann ich da noch etwas anderes tun?


      Die URL zeigt folgendes an

      Code
      {"code":403,"file":null,"line":null,"message":"Access not allowed","previous":[],"returnValues":[]}

      Passt das?


      Wäre schön wenn wir das zum Laufen bekommen.


      Grüße.

    • habe bei mir das selbe Problem seit dem update zu 5.2

      https://forum.libreelec.tv/core/wsc-connect-api/

      Code
      {"code":403,"file":null,"line":null,"message":"Access not allowed","previous":[],"returnValues":[]}
  • Kleiner Verbesserungsvorschlag von mir: Eventuell auf der Webseite auch das Supportforum verlinken?
    Wenn man nicht so tief in dem ganzen drinnen ist, ist es für Außenstehende nahezu unmöglich, das Supportforum zu finden.

    Like 1
  • hallo zusammen,
    ich habe gerade die iOS app installiert und registriert. jetzt habe ich mich in meinem forum angemeldet. allerdings sehe ich nur 2 spalten ... "benachrichtigungen" und "nachrichten", das war's. habe ich irgendetwas falsch gemacht?

    vielen dank schon mal im voraus


    gruß chickengeorge

  • Habe folgende Fehlermeldung im Log:


  • ich habe seit kurzem das Problem das meine App Deaktiviert wurde da er auf die URL nicht zugreifen kann. Ich verwende ein Gekauftes SSL Zertifikat . Er Zeigt mir das an wenn ich die URL Manuel aufrufe

    Code
    "code":403,"message":"Access not allowed"

    Wie kann ich das Problem Lösen ?

  • seit dem update auf 5.2 bekommen alle Admins und Moderatoren Benachrichtigungen bei neuen Registrierungen, selbst wenn die Notifications ausgeschalten sind.

    • Das lässt sich nicht deaktivieren, da WoltLab das fix eingebaut hat, wieso auch immer ;)

      Sad 1
    • hm, in Woltlab konnte ich es deaktivieren, nur WSC Connect hat das irgendwie nicht mitbekommen.
      Anfangs bekam ich auch Benachrichtigungen von Woltlab, die konnte ich abschalten. Nur die App benachrichtigt fleißig weiter.

    • @Christopher Walz theoretisch gibt es dazu eine Einstellung (User-Option Benachrichtigungen), aber um das korrekt abzufangen, müsste das Plugin die Notifications zu einem anderen Zeitpunkt abgreifen oder du musst den ganzen Bogus, den WoltLab danach abfragt, parallel auch nochmal machen.

      Referenz: https://github.com/WoltLab/WCF/issues/3016 & https://github.com/WoltLab/WCF/pull/3017

      Thanks 1
  • Installieren geht wunder bar nur beim einrichten sagt der immer das meine seite nicht erreichbar ist das kann aber nicht sein denn sie ist erreichbar bitte um aufklärung euer seitz.

  • top zufrieden damit ausser das es schön wäre wenn ich bei den Nachrichten einen Link zum Thema anhänge, dass dieser im Explorer vom Handy aufmacht und nicht in der App!!

    Könnte man das noch lösen??

    Über 100 Leute verwenden die App auf mein Forum und einige haben mich schon angeschrieben und gefragt!?


    LG und danke für die App

  • Lässt sich nicht sauber deinstallieren, zerstört dabei eine WSC Installation... schade!

    • Das bezweifel ich einfach mal stark. Vermutlich liegt das Problem woanders.

  • Grüße :)

    Gibt es eine möglichkeit, das Benutzer die mit WSC-Connect von meinem Forum verbunden sind eine Trophy zu geben ?

    Bzw. das ich dafür ein Kriterium finden kann. (z.B. wie bei anderen Trophys, ist in Benutzergruppe XY oder hat über 25 Beiträge )

  • In der IOS App tritt jedes Mal ein Fehler wegen der Datenschutzbestimmung auf und unten mittig ist nur ein weißer Balken. Kannst du diesen Bug bitte beheben?

    • Hast du den Fehler denn bereits bei mir im Forum gemeldet?

      Nutzt du den Dark mode? Bitte genaue Infos über iOS-Version etc. Bereitstellen und im Forum melden.

      Danke

    • IOS Version: 13.2.2

      Dark-Mode: Ja

      Im Light Mode gehts mit der Datenschutzbestimmung


      Fehler habe ich bisher nur hier gemeldet

    • Das Problem ist in der Testflight Version behoben. Wird dann die Tage hoffentlich auch für alle veröffentlicht.

      Like 1
  • Clicking on notifications takes me to my website homepage and not the thread / post.


    Is this how it is supposed to behave?

    • If u're logged in in your browser, it should take you directly to the notifications content link.

    • It isn't doing that - it's taking me to my dashboard / latest posts page (which I have as my homepage)

    • Does it work for other apps? Try cwalz.de

    • Thank you - created a thread in "test", will have to wait for a notification :)

  • Grüß Dich,


    im Dashboard vom WSC-Connect seh ich leider nur die Benutzer-ID und nicht den Benutzernamen des Mitglieds, welches diese App nun nutzt. Gibt es evt eine Möglichkeit auch den Benutzernamen gleich angezeigt zu bekommen ?

    • Nein, zwecks DSGVO wird der Benutzername nicht mehr gespeichert.

    • ach ja, daran habe ich gar nicht mehr gedacht. ;)


      Gibt es denn eine Möglichkeit, das man sowohl im Dashboard, als auch später in der App die Push-Nachrichten, die ich verschickt habe, wieder zu löschen ?

    • Bisher nicht, nein.

    • ich weiß, ich frage viel ... in naher Zukunft geplant oder das man in der Datenbank evtl. sie löschen kann, falls nicht geplant ?

  • Push-Benachrichtigungen für generell neue Beiträge geplant ?

    • Was genau ist damit gemeint?

    • Sowas in der Art wie "Es sind neue Beiträge / Themen vorhanden".


      Z.B wenn ich jetzt alle Themen als gelesen eingestellt habe und in ein paar Stunden wieder ein oder mehr neue Beiträge oder Themen hinzugekommen sind, dass man dann eben auch eine Nachricht bekommt wie "Es sind neue Themen / Beiträge vorhanden".


      Das wäre wirklich super, um den User zu einem Besuch zu bewegen.


      LG

    • Ist sowas geplant, oder finde ich eine Einstellung nicht?

    • Nein, ist es nicht. Vllt. Klappt das mit UdoZ Bot aber.

    • Schade.


      Ich weiß absolut nicht, wie ich mit dem Bot Push-Benachrichtigungen anzeigen lassen sollte.

  • Muss ich beim Einsatz von WSC Connect meine Datenschutz Bestimmungen Anpassen?

    • Ich meinte eigentlich, was ich angeben muss wenn ich diese App verwende (was ich tue)?

    • Dazu kann ich dir leider keine Vorlage liefern. Wie du auf der Datenschutz-Seite aber sehen kannst, speichern wir keine personenbezogenen Daten der Nutzer, lediglich die E-Mail-Adresse des Admins mit der er sich angemeldet hat.

  • Habe den WSC- Connect Banner bereits auf anderen Seite gesehen, mich dafür aber nie interessiert, bis jetzt.

    Da sich im Alltag aber immer mehr auf Mobilgeräte abspielt, ist es ja schon nicht schlecht Mitteilungen von einer oder mehreren Seiten direkt als Push zu erhalten.

    Gerade das Feature der Konventionen ist hilfreich.

    Das WSC-Connect zudem noch kostenlos ist, ist eine Supersache, wird es bei uns auch in Zukunft genutzt, werden wir das Projekt unterstützen.

  • Fertig! Deine App ist nun aktiv und in unserer Android-App sichtbar.

    Alles gut in der neuen Version:D Guter Job!

  • Cooles Plugin

    Funktioniert bestens, ich bin immer top aktuell wenn etwas auf der Seite passiert :):thumbup:

  • Alles super

    Bei mir läuft alles prima. 👍🏻