Fatal Error nach Datenbankwechsel

  • Affected Version
    WoltLab Suite 6.0
    Affected App
    WoltLab Suite Forum

    Hallo zusammen,

    den Fehler habe ich selbst verursacht und weiß leider nicht mehr weiter. Was habe ich gemacht:
    - ich habe eine neue mysql datenbank angelegt mit der Version 8 da die 4er nicht mehr für das Update auf WLS 6 geeignet ist.
    - ich habe die Daten der alten Datenbank exportiert und erfolgreich in die Version 8 importiert
    - danach habe ich die Datenbank der 4er Version gelöscht.

    Jetzt kommt natürlich die Fehlermeldung in WoltLab, dass die alte Datenbank nicht mehr da ist. Wie kann ich das wieder kitten?

    Vielen Dank für die Hilfe!

    Torstenw100

  • In der Datei config.inc.php kannst Du die Daten der aktuellen Datenbank angeben.


    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier und hier.

  • Aber ich habe gerade eine Idee ... das ist die gesamte Fehlermeldung:

    Original Error

    • Error Type:

      PDOException

    • Error Message:

      PDO::__construct(): php_network_getaddresses: getaddrinfo for db508483565.db.1and1.com failed: Name or service not known

    • File:

      */lib/system/database/MySQLDatabase.class.php (50)


    Vermutlich muss ich diese Datei editieren?

  • Damit bin ich weitergekommen und es hat geklappt ... jetzt kommt es zum nächsten Fehler :(

    Langsam glaube ich, dass ich neu Aufsetzen darf :(

    "Original Error

    • Error Type:

      PDOException

    • Error Message:

      SQLSTATE[HY000] [1044] Access denied for user 'o12734585'@'%' to database 'db5015591578'

    • Error Code:

      1044

    • File:

      */lib/system/database/MySQLDatabase.class.php (50)"

  • Sämtliche Informationen zu der Datenbank stehen in dieser Datei. Überprüfe bitte ob die eingetragenen Daten wie Passwort, Benutzername, Host und auch Datenbankname korrekt sind.

    $dbHost = 'db5015591578 (habe nur bis hierher ausgeschnitten)
    $dbUser = 'dbu2093338';

    SQLSTATE[HY000] [1044] Access denied for user 'o12734585'@'%' to database 'db5015591578'

    Also stimmt der User nicht, der aber richtig geändert wurde.

    Noch eine Idee dazu?

  • Hallo,

    ich habe es bislang noch nicht erlebt, dass die Fehlermeldung inkorrekt ist. Ich bin mir daher absolut sicher, dass die Zugangsdaten tatsächlich falsch sind.

    Meine Empfehlung: Die Daten einmal komplett entfernen und dann Stück-für-Stück reinkopieren. Manchmal übersieht man beim Kopieren ein Zeichen am Anfang und Ende.

  • Hallo,

    ich habe es bislang noch nicht erlebt, dass die Fehlermeldung inkorrekt ist. Ich bin mir daher absolut sicher, dass die Zugangsdaten tatsächlich falsch sind.

    Meine Empfehlung: Die Daten einmal komplett entfernen und dann Stück-für-Stück reinkopieren. Manchmal übersieht man beim Kopieren ein Zeichen am Anfang und Ende.

    Der DAU-Award des Tages geht wohl heute an mich ... habe eine Variable NICHT geändert und das war das Gesamtproblem.

    Vielen Dank an alle, die zur Lösung meines Problems beigetragen haben. Das Update konnte ich jetzt vollständig durchführen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!