Upgrade kaufen Problem beim Updaten

  • Affected Version
    WoltLab Suite 6.0
    Affected App
    WoltLab Suite Core

    Wollte eben mal einen Test machen und ein Update auf das WSC 6.0 durchführen, ich erhalte dann die Meldung dass ich für ein Paket ein Upgrade erwerben muss. Das besagte Paket habe ich zum einen hier im Pluginstore gekauft und zum anderen auch beim Entwickler als ich eine zweite Lizenz benötigte. Nun habe ich das Upgrade aber nur beim Entwickler gekauft und nicht hier im Pluginstore.

    Der Paketserver des Entwicklers ist hinterlegt und der Authentifizierungscode auch, dennoch erhalte ich die Meldung dass ein Kostenpflichtiges Upgrad von nöten ist.

  • Hallo,

    das Paketsystem ist grundsätzlich nicht darauf ausgelegt, das dasselbe Paket auf mehr als einem Paket-Server gleichzeitig verfügbar ist. Mit dem Authentifizierungs-Code konnten wir das Problem insofern reduzieren, in dem dies als ein explizites Opt-Out gewertet wird.

    Das aktuell vorliegende Problem ist aber nicht auflösbar, denn es ist durchaus gewollt, dass Informationen über neue, aber unzugängliche Updates von erworbenen Paketen angeboten wird. Nur so kann die Information bereitgestellt werden, dass der Kunde ein kostenpflichtiges Update eines zuvor erworbenen Produktes erwerben kann.

    Im Zweifelsfall können wir anbieten, das „ältere“ Produkt aus dem Kundenkonto zu entfernen, um so den Konflikt aufzulösen. In dem Fall greift der Authentifizierungs-Code wieder, denn dann ist das Paket effektiv nur auf einem Paket-Server verfügbar.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Kopiere mal die Antwort hier hin.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!