Problem nach Neukauf von WoltLab Suite Forum 5.5.12 und neu installiertem Ubuntu

  • Affected Version
    WoltLab Suite 5.5
    Affected App
    WoltLab Suite Forum

    Guten Abend oder Guten Morgen,

    ich habe mir heute das WoltLab Suite Forum in v5.5.12 gekauft und einen Root Server gemietet vor einiger Zeit gemietet.
    Ich hab den Root Server gestern komplett neu installieren lassen auf und es läuft nun auf der Version "Linux Ubuntu-2204-jammy-amd64-base 5.15.0-73-generic #80-Ubuntu" (Info aus der Konsole)
    Ich hab auch wie es sich gehört als erstes apt update und apt Upgrade gemacht um die aktuellste Version mit allen Updates zu haben und habe danach PHP in Version "PHP 8.1.2-1ubuntu2.11", Apache2 in Version "Server version: Apache/2.4.52 (Ubuntu)" und MYSQL in Version "mysql Ver 8.0.33-0ubuntu0.22.04.2" (Info ebenfalls aus der Konsole) installiert.

    Ebenso habe ich mich an die Vorgehensweise der "Lies Mich.txt" die ich beim entpacken erhalten habe gehalten.

    Nun habe ich das Problem das wenn ich die test.php öffnen ich folgende Rückmeldung bekomme

    und wenn ich danach auf den Button "Installation starten" Klicke ich folgenden Fehler erhalte.

    An diesem Problem stehe ich jetzt seit gestern 18 Uhr und komme nicht weiter. Aus dem Grund des Selbstlernen habe ich dann versucht ChatGPT zu fragen das dann meinte ich brauche die PHP Module "DOM" und "XML" die ich dann im Nachgang installiert und aktiviert habe aber es bleibt bei dem Fehler wie im Bild 2 weshalb ich jetzt bei dem Profis nachfrage in der Hoffnung nicht solche Antworten zu erhalten "Wieso macht man das wenn man sich nicht auskennt".

    Ich bedanke mich für eure Hilfe und wünsche allen einen schönen Sonntag.

    Besten Gruß
    ArrcoWolf91 aka Daniel

    PS: Falls noch Infos Fehlen bitte Melden. Ich reiche sie schnellstmöglich nach.

  • Problem hat sich gelöst. WoltLab Suite Forum funktionert nicht wie angeben mit der PHP 8.1 Version.

    Hab mit dem Befehlt "sudo add-apt-repository ppa:ondrej/php" alle PHP Versionen freigeschalten

    Danach habe ich mit "sudo apt install php8.0 php8.0-mysql php8.0-gd php8.0-mbstring php8.0-xml" PHP in Version 8.0 installiert und das Forum ist endlich installiertbar.

    Schöne Zeit zusammen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!