Umgezogene Installation testen

  • Affected Version
    WoltLab Suite 5.3

    Hallo zusammen,

    gibt es eine Möglichkeit, eine gespiegelte WBB-Installation zu testen, bevor die dazugehörige Domain auf den neuen Speicherort umgeleitet wird?

    Hintergrund: Ich möchte meine Suite 5.3.6 auf einen anderen Webserver ziehen, da ich beim bestehenden mangels technischer Voraussetzungen nicht mehr updaten kann.

    Ich möchte den Umzug einmal durchspielen und habe eine Version auf dem neuen Server kopiert, DB importiert, Zugangsdaten angepasst etc. Laut der Migrationsanweisung ist nichts weiter zu tun.

    Wenn ich die Kopie aufrufe, werde ich jedoch sofort auf die Live-Version umgeleitet. Ich weiß nicht, ob das ein gutes oder ein schlechtes Zeichen ist. Ich nehme an, das hängt mit der Lizenz zusammen? Gibt es dennoch eine Möglichkeit, die korrekte Funktion der Kopie zu testen? Ich möchte nicht die Domain gleich auf mit die Kopie verweisen lassen ohne zu wissen, ob ich alles richtig übertragen habe. Noch dazu handelt es sich um 2 verschiedene Anbieter, so dass der Sprung zurück wieder mit Aufwand und Ausfall verbunden wäre..

  • Die Umleitung erfolgt aufgrund der Domain die du im ACP eingestellt hast.

    Das sollte jederzeit aufrufbar sein (einfach an die Adresse anhängen), dann kannst du darin es anpassen und nach leeren der Cache es ganz normal aufrufen.

    Projekte:

    XIVDATA - Eorzea Database

    A red dragon falls from the heavens... Ah, that memory has been lost. A shame. It was a favorite of mine...

  • Ah okay, das ACP ist nicht direkt aufrufbar, allerdings erscheint stattdessen eine "Systemwiederherstellung".

    Hier habe ich nun natürlich den falschen Pfad eingetragen und ich komme nicht mehr zurück :)
    Weiß jemand, an welcher Stelle (in der DB) das abgelegt wird (Domain, Pfade zu den Apps)?

  • Einfach/acp auf dem neuen Server aufrufen. Normalerweise wirst du dann auf ein Formular geleitet, in dem du deine Test-Domain hinterlegen kannst, ganz ohne manuelle Veränderungen an der Datenbank.

    Ja, die Systemwiederherstellung. Die hatte ich mit dem falschen Pfad gefüttert, und anschließend war sie nicht mehr aufrufbar. Das ist das aktuelle Problem. Das DB-Feld sehe ich mir an.

  • Wollte kurz Rückmeldung geben: Umzug hat geklappt, war zusammenfassend überraschend unkompliziert. Einzig TinyImg 5 muss im Backend angepasst werden, dort steht nach dem Umzug unverändert der alte Speicherpfad für die Backups drin. Fällt erst durchs Fehlerlog auf.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!