Beitragszeiten werden bei späterem veröffentlichen nicht aktualisiert.

  • Affected Version
    WoltLab Suite 5.5
    Affected App
    WoltLab Suite Forum

    Folgendes Szenario:

    -Beitrag wird erstellt mit der Option "Beitrag zu einem späteren Zeitpunkt veröffentlichen"

    -Beitrag wird später dann manuell veröffentlicht mit aktivierter Option "Sofort veröffentlichen" UND "Erstellungsdatum auf die aktuelle Uhrzeit setzen"

    -Beitrag wird veröffentlicht aber die Uhrzeit/Datum wird nicht aktualisiert

    -Im Beitrag selbst stimmt die Uhrzeit/Datum, aber außerhalb des Threads steht die Uhrzeit, die beim erstellen des Beitrags/Threads gespeichert wurde und demnach wird es nicht unter den aktuellen Beiträgen angezeigt.

    Hierbei spielt es auch keine Rolle, ob es ein neues Thema oder nur ein Beitrag mit verzögerter Veröffentlichung ist.

    Beispiel:

    • Zeitpunkt des erstellten und deaktivierten Beitrags 21.02.2023 / 5:00 Uhr
    • Veröffentlichung mit aktueller Uhrzeit 23.02.2023 / 12:00 Uhr
    • Beitragszeit in der Themenauflistung: 21.02.2023 / 5:00 Uhr <- Falsch

    Ich meine auch, dass der Fehler erst mit dem WCF 5.5 aufgetaucht ist.


    Nachtrag mit Screenshots:

    Neuer Beitrag mit späterer Veröffentlichung


    Beitrag wird freigeschaltet mit aktueller Uhrzeit


    Im Beitrag stimmt die Zeitangabe


    In der Themenauflistung wird aber das Datum des Erstellzeitpunkts angezeigt und nicht das aktuelle.

    Edited once, last by Captain Crunch (February 23, 2023 at 8:38 PM).

  • Marcel Werk March 3, 2023 at 3:17 PM

    Added the Label 5.5.10
  • Marcel Werk March 3, 2023 at 3:17 PM

    Added the Label Fixed

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!