Fehlermeldung "Der Parameter „objectIDs“ fehlt oder ist ungültig." Menüpunkte im "Thema bearbeiten" (contentInteractionButtons a.jsThreadInlineEditor) sind träge.

  • Affected Version
    WoltLab Suite 5.5
    Affected App
    WoltLab Suite Forum

    Hallo Zusammen,

    das Forum gibt reversibel die Fehlermeldung "Der Parameter „objectIDs“ fehlt oder ist ungültig." aus, wenn versucht wird einen Thread zu deaktivieren, in welchen nur deaktivierte Posts vorhanden sind. Das geschieht ausschließlich unmittelbar nachdem man den letzten Post im Thread deaktiviert hat, die Seite nicht neugeladen hat und versucht, den Thread zu deaktivierten.
    Ich poste diese Beobachtung dennoch, weil im Freischaltungsprozess der Thread ebenfalls ohne Reload freigeschaltet wird.

    Beschreibung zur Reproduktion:

    - User mit Moderation für das Forum nutzen (User muss Beiträge/Threads deaktivieren und Freischalten können)
    - Thread mit wenigen aktiven Posts öffnen

    - alle Postings per Checkbox (messageClipboardCheckbox) markieren und über die pageActionButtons unten rechts deaktivieren.

    - Die Seite NICHT neuladen

    - Über "Thema bearbeiten" (contentInteractionButtons a.jsThreadInlineEditor) wird "Deaktivieren" angeboten. Diese Option klicken.

    Warum ist das komisch?
    a) Während beim Freischalten eines deaktiverten Posts im deaktivierten Thread das contentHeaderIcon direkt ohne Reload geändert wird, geschieht das im umgekehrten Fall (Letzte aktive Post im Thread deaktivieren) nicht. Der Moderator sieht ohne Reload der Seite nicht, dass der Thread bereits deaktiviert wurde.

    b) Und das Menü hinter "Thema bearbeiten" wird dementsprechend auch nicht dynamisch geändert.

    Beste Grüße
    pro8a

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!