Absturz beim aktivieren des Wartungsmodus

  • Affected Version
    WoltLab Suite 3.0
    Affected App
    WoltLab Suite Forum

    Hallo ich wollte einige Updates einspielen und dazu den Wartungsmodus aktivieren.

    Dann hatte ich sofort sowohl im ACP als auch im Forum eine Fehlermeldung.


    Nach einen Restore des Webspace ging es wieder, ist aber bei einem zweiten Versuch wieder so passiert. Und dann ein drittes mal als ich den Cache leeren wollte.

    Hier mal eine Fehlermeldung:


  • Irgendetwas passt da nicht zusammen. Laut Fehlermeldung geht es um eine WSC 3.0-Installation, in der es die als fehlerhaft beanstandete Datei apiVersion.scss noch gar nicht gibt.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Du musst eine ältere PHP-Version verwenden, der SCSS-Compiler von WoltLab Suite 3.0 (RIP) läuft nicht mit PHP 7.4.

    Wir😳leben😳auf😳einer😳Kugel😳und😳du😳wunderst😳dich😳ernsthaft😳über😳etwas😳



    🐶 x 27 ♥️ x 248

  • Mein WSC 3.0 läuft schon seit mindestens einem Jahr auf PHP 7.4. Weil mein Hoster im November PHP 7.4 aber abschaltet will ich jetzt (erstmal) aufs WSC 5.4 updaten.


    Die apiVersion.scss auf dem Server hat das Datum vom 1.6.22 alle anderen Dateien in dem Verzeichnis sind vom 30.8.19.


    Ich habe die letzten Tage nichts neues installiert. Am Samstag ging auch der Wartungsmodus noch.

    Nach der Fehlermeldung hat auch ein Restore aller Dateien von heute Nacht den Fehler behoben, beim zweiten Versuch den Wartungsmodus einzuschalten war es aber wieder das selbe. Inzwischen habe ich auch die Datenbank neu aus einem Backup importiert. Habe aber noch keinen Neuversuch gewagt.


    Das einzige was ich gemacht habe bevor der Fehler aufgetreten ist war die Templates meines Styles an denen Veränderungen gemacht wurden habe ich in eine .txt Datei kopiert, aber nichts daran geändert. Meinen Stil kann ich leider nicht direkt updaten sondern muss ihn deinstallieren und nach dem Update wieder installieren (Link) .

  • Da es ja was mit dem Style zu tun haben muss, wollte ich diesen jetzt deinstallieren und neu installieren. Sowohl im ACP als auch im Forum wieder die selbe Fehlermeldung.
    Ich kann im ACP also fast nichts mehr machen.

    • Official Post

    Hallo,


    lösche die Datei, diese gehört zur WoltLab Suite 3.1. Offenbar wurde zuvor ein Upgrade versucht und das Backup anschließend fehlerhaft zurückgespielt, so dass noch Daten der neuen Version übrig geblieben sind.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Danke für die schnelle Antwort.


    Das löschen dieser einen Datei hat zwar nicht gereicht, danach löste eine andere Datei einen Fehler aus.

    Ich musste jetzt meinen ganzen Webspace löschen und ein Backup von vor dem fehlgeschlagenen Updateversuch aufspielen.

    Jetzt scheint widr alles zu funktionieren.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!