Fehler nach Update auf 5.5.0 von aktueller vorheriger Version (Could not compile SCSS: Undefined variable $wcfUserMenuTextActive:)

  • Affected Version
    WoltLab Suite 5.5
    Affected App
    WoltLab Suite Forum

    Beim Update erscheint ein Fehler und meine Seite ist leider nicht mehr erreichbar:


    Kann hier jemand helfen? :)

    Danke Euch und viele Grüße

  • Hallo,

    für Betroffene des fehlerhaften Updates von 5.4 auf 5.5.0 (5.4 → 5.5.1 und neuer sind nicht betroffen!):

    Bitte die Datei style/ui/pageMenu.scss und style/ui/userMenu.scss mit der Version aus dem Anhang ersetzen. Anschließend über das ACP das Update auf 5.5.1 durchführen.

  • Ist das richtig? Die Datei austauschen? Hatte ich gemacht, komme aber nicht ins acp rein.

    /htdocs/meinedomain.de/wcf/style/ui/pageMenu.scss

    Ja, wenn ich das nicht hinkriege, dann überlege ich mir, ob die Cloud nicht das beste für mich wäre ^^

    viele Grüße

  • Ist das richtig? Die Datei austauschen? Hatte ich gemacht, komme abver nicht ins acp rein.

    /htdocs/meinedomain.de/wcf/style/ui/pageMenu.scss

    Ja, wenn ich das nicht hinkriege, dann überlege ich mir, ob die Cloud nicht das beste für mich wäre ^^

    Bei uns hat geholfen, die Datei "userMenu.scss" mal kurz 'aus dem Rennen zu nehmen', sprich umzubenennen.

  • Hallo,

    für Betroffene des fehlerhaften Updates von 5.4 auf 5.5.0 (5.4 → 5.5.1 und neuer sind nicht betroffen!):

    Bitte die Datei style/ui/pageMenu.scss und style/ui/userMenu.scss mit der Version aus dem Anhang ersetzen. Anschließend über das ACP das Update auf 5.5.1 durchführen.

    Ich muss mich nochmals bedanken. nach dem Austausch der zwei Dateien konnte ich ein Update machen

    viele Grüße

  • Wenn ich es recht in Erinnerung habe, war es damals beim Burning Board 3.0.0 kürzer, ebenso aus einem Fehler, den WoltLab einfach nicht vorhersehen konnte. :)

    Wobei das Team wahrscheinlich froh drum ist, dass es nur dieser eine Fehler war. :D

    Es gibt nur eine Sache die sich niemals ändern wird; das ist die Tatsache, dass sich Dinge ständig ändern.

    WinchesterLegacy.de
    -> Meine Seite über Supernatural


    Gentlemantis.de
    -> Eigener Bereich

  • Es war ein vermeidbarer Fehler, denn beim Testen der Änderung hatte ich das relevante Archiv zwar neu erzeugt, nicht aber im Repository aktualisiert. Nach dem Test habe ich die Updates für 5.3 und 5.4 gebaut und dadurch offenbar versehentlich die Änderung verworfen. Da sich nach meinem Test nichts mehr an 5.5 verändert hatte, habe ich das anschließend erzeugte Update nicht neu getestet.

    Unterm Strich sind solche Fehler aber einfach nur ärgerlich und im Falle der betroffenen Kunden „lediglich“ mit etwas Zeitaufwand verbunden. Für mein Verständnis ist es viel wichtiger, dass es bei solchen Fehlern zu keinem Datenverlust kommt.

  • „Vermeidbar“ vielleicht, aber dennoch möglich, da ihr auch nur Menschen seid und ich bezweifle stark, dass es geplant war, dieses Thema in eine Kritik zu verwandeln. :)

    Es gibt nur eine Sache die sich niemals ändern wird; das ist die Tatsache, dass sich Dinge ständig ändern.

    WinchesterLegacy.de
    -> Meine Seite über Supernatural


    Gentlemantis.de
    -> Eigener Bereich

  • Bei mir geht jetzt gar nichts mehr. Nachdem das Update von 5.4.19 auf die 5.5.0 gründlich schiefgelaufen ist, habe ich nun per SSH eine FTP- und DB-Sicherung von gestern Abend (5.4.19) eingespielt. Ins Forum und ACP komme ich, wenn ich jedoch den Offlinemodus, der jetzt besteht, wieder abschalten will, kommt untenstehende Fehlermeldung, sprich, trotz eingespielter Sicherung scheint da durch das schiefgelaufene Update etwas nachhaltig beschädigt/geändert worden zu sein. Hat jemand einen Tipp, wie ich das Problem beheben kann? Sprich, wieder mein funktionierendes Forum von gestern zu bekommen.

  • kreuz-horst - Fotografie Eventuell liegt dein Problem an deiner PHP-Version 7.3.33-nmm2, denn:

    Quote

    Systemvoraussetzungen: Für den Betrieb der Software wird ein Server bzw. ein Webspacepaket mit den folgenden Eigenschaften benötigen: PHP 7.4.21+

    Gruß Markus

    WoltLab Suite 5.5.22

  • Webmark: Meinst du für die 5.4.19 oder 5.5.0? Ich verstehe jetzt nur nicht, warum manche Daten auf dem Webspace das Datum von heute haben, wenn ich das Backup von gestern eingespielt habe. Wenn ich die beiden fehlerhaften Dateien auf dem FTP lösche, ist zwar das Forum wieder da, jedoch sehe ich beim Aufruf der ACP-Seite die gleiche Fehlermeldung. Oder macht es Sinn, wenn ich den Ordner, in welchem das Forum installiert ist, komplett leere und DANN erst das Backup einspiele? Oder den Ordner komplett lösche?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!