Fehler bei Elastic Search Core Modul

  • Affected Version
    WoltLab Suite 5.2

    Hi,


    seit einigen Wochen taucht immer wieder dieser Fehler auf, mit dem ich nicht viel anfangen kann.

    Könnt ihr mir hierbei ein wenig weiter helfen, bitte?

    VIelen Dank! :)

    LG

  • Bitte mal den Inhalt von dieser Datei zeigen.

  • Die WoltLab Suite 5.2 ist übrigens nicht mit PHP 8.0 kompatibel, diese PHP-Version wird erst ab der WoltLab Suite 5.4 unterstützt.

    Was genau wird nicht unterstützt?
    Das Forum läuft aller erste Sahne mit Version 8. :)

    • Official Post

    Failed to connect to 127.0.0.1 port 9200: Connection refused (code 7)

    PHP kann keine Verbindung aufbauen: Der Elasticsearch-Server läuft nicht auf der angegeben IP und Port oder die Firewall ist nicht korrekt konfiguriert.


    Das Forum läuft aller erste Sahne mit Version 8. :)

    Ich denke mir so etwas doch nicht aus. Teile der alten Software sind nicht mit PHP 8 kompatibel und daher dysfunktional, insbesondere das Paketsystem ist davon betroffen.


    Es gibt übrigens keinen Grund noch die Woltlab Suite 5.2 einzusetzen, die Version 5.3 war de facto ein kostenfreies Upgrade für alle Lizenzinhaber der Version 5.2.

  • PHP kann keine Verbindung aufbauen: Der Elasticsearch-Server läuft nicht auf der angegeben IP und Port oder die Firewall ist nicht korrekt konfiguriert.

    OK, gerade war der DIenst tatsälich down....

    Code
    root@h2903112:~# systemctl status elasticsearch.service 
    ● elasticsearch.service - Elasticsearch
       Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
       Active: active (running) since Sat 2022-02-26 11:40:35 CET; 6min ago
         Docs: https://www.elastic.co
     Main PID: 1642 (java)
        Tasks: 82 (limit: 105)
       CGroup: /system.slice/elasticsearch.service
               ├─1642 /usr/share/elasticsearch/jdk/bin/java -Xshare:auto -Des.networkaddress.cache.ttl=60 -Des.networkaddress.cache.negative.ttl=10 -XX:+AlwaysPreTouch -Xss1m -Djava.
               └─1844 /usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/bin/controller

    Ich habe ihn neu gestartet.

    Aber warum wurde er gestoppt?

  • Es gibt übrigens keinen Grund noch die Woltlab Suite 5.2 einzusetzen, die Version 5.3 war de facto ein kostenfreies Upgrade für alle Lizenzinhaber der Version 5.2.

    War? Wir können nicht auf die Updates zugreifen. Warum?

    Der dazugehörige Paketserver ist aber eingetragen.

    • Official Post

    Die Aktualisierung auf die aktuelle Version erfolgt direkt über die Administrationsoberfläche. Dazu muss die Aktualisierung der Reihe nach durchgeführt werden, die einzelnen Schritte sind in unserem Handbuch beschrieben. Zu keinem Zeitpunkt müssen manuell Dateien herunter- oder hochladen werden.

  • Ich denke mir so etwas doch nicht aus. Teile der alten Software sind nicht mit PHP 8 kompatibel und daher dysfunktional, insbesondere das Paketsystem ist davon betroffen.

    Hier hast du doch deine Antwort das Paketsystem ist davon betroffen daher funktioniert vermutlich auch das Update nicht ordnungsgemäß.

  • Hallo zusammen,


    ich bin gerade dabei, mein Forum von 5.2.x auf 5.3 upzudaten.

    Aber ich komme nicht dazu, da es meckert, dass erst einmal das Elastic-Search Plugin auf 5.3.0 zu heben ist.

    Aber wo finde ich das Update? In der Dropdown-Auswahl ist nur die 5.3.13 drin?




    Ich habe die Paketserver für die 5.3 alle eingefügt.

    Was habe ich übersehen?

  • Du gehst offensichtlich nicht danach vor, wie es dir genannt wurde:

    Die Aktualisierung auf die aktuelle Version erfolgt direkt über die Administrationsoberfläche. Dazu muss die Aktualisierung der Reihe nach durchgeführt werden, die einzelnen Schritte sind in unserem Handbuch beschrieben. Zu keinem Zeitpunkt müssen manuell Dateien herunter- oder hochladen werden.

    An irgendeiner Stelle scheinst du von diesen Anleitungen abzuweichen und deshalb geht es nicht.

    Schreibe am besten mal Schritt für Schritt nieder, wie du vorgehst, um das Upgrade durchzuführen.

  • Also, ich habe die Anleitung befolgt von 5.2 auf 5.3.
    Da kann man ja eigentlich nichts falsch machen.

    - Die beiden nötigen Paketserver hinzugefügt. *CHECK*

    - Dann auf Updates suchen geklickt. *CHECK*

    - Dann ganz unten auf "update" geklicjkt *CHECK*

    -> Dann kam die Meldung mit Elastic-Search 5.3.0 *KOTZ*

  • Danach habe ich, da die geforderte Version nicht zur Auswahl stand, die 5.3.0 heruntergaladen und wollte diese eben zu Update hochladen. Aber das will Euer System nicht... Meldung siehe oben

  • Ein manuelles Update ist nicht vorgesehen. Entferne bitte die neuen Paketserver, suche erneut nach Updates und installiere dann die ggf. noch ausstehenden Updates der Versionsreihe 5.2. - ist Elasticsearch 5.2.15 die neueste Version der 5.2-Reihe?

  • Ja, das ist die jüngste und ist auch installiert.

    Von 5.2 ist alles auf dem letzten Stand


    -> Somit sind keine weiteren Updates in 5.2 verfügbar.

  • Also, ich interpretiere die Fehlermeldung ...

    "Das Update erfordert eine Aktualisierung des Paketes „WoltLab Suite Core: Elasticsearch“ (installierte Version: 5.2.15) auf Version 5.3.0, es wurden aber keine passenden Updates gefunden."

    ... so, dass das fehlende Update in der Version 5.3.0 nicht auf den Paketservern zu finden ist.

    Diese wird aber benötigt, wie es scheint. Auch darf ich das nicht per Hand updaten.


    Ich freue mich echt jedes Mal auf ein Forums-Update. Wirklich.
    Das ist so spaßig. :D

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!