Error beim Aufrufen des Forums

  • Affected Version
    WoltLab Suite 3.1

    Hallo liebe Woltlab-Community,

    anfangs möchte ich sagen, dass ich absoluter Neuling bin, was Web-Foren und Woltlab angeht. Ich moderiere eine kleine Community und habe das Forum quasi funktionsfähig "geerbt". Nun habe ich allerdings einige Probleme damit. Beim Aufrufen der Startseite kommt eine Fehlermeldung: "DOMDocument::loadHTML(): Tag woltlab-metacode invalid in Entity, line: 2". Leider kann ich damit nicht viel anfangen, soweit ich weiß kam dieser Fehler aus dem "nichts", es wurden keine Änderungen an der Administrationsoberfläche getätigt. Was diese Betrifft, so treten vereinzelt auch Fehler auf. Bspw. beim manuellen Klick auf "Updates suchen" im "Pakete"-Reiter kommt der Fehler: "Unknown named parameter $ignoreCache". Außerdem werden die "Update-Server" als offline angezeigt mit dem Fehler: "Die Paketliste konnte nicht abgerufen werden (200)". Beim Versuch Pakete zu deinstallieren wird ein Fehler ausgegeben, der darauf hinweist, dass bestimmte Dateien nicht vorhanden sind. Ähnlich war es, als ich versuchte, einen neuen Benutzer zu löschen. Ein Fehler mit Hinweis auf fehlende Dateien wurde ausgegeben, dies konnte ich umgehen, indem ich manuell Dateien mit diesem Namen erstellt und an den richtigen Pfad gebracht habe.

    Nun meine Fragen, hängt dieser Fehler eher mit dem Webspace und beschädigten Dateien zusammen, oder liegt ein Fehler mit meinem Woltlab-Forum vor? Wie sollte ich weiter vorgehen? Kann eine Neuinstallation sinnvoll vorgenommen werden, am besten ohne Daten (Nutzer und Beiträge) zu verlieren?

    PS: Da ich nicht sicher bin, welche Teile der Fehlermeldung erstens überhaupt relevant, und zweitens "safe to share" sind, habe ich mich hier zurückgehalten. Bei Bedarf kann ich weitere Informationen zur Verfügung stellen.

    Liebe Grüße und Danke im Voraus ^^

  • Go to Best Answer
  • Bitte vollständigen Fehler posten.

    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

  • Dieser Error wird beim Aufrufen der Startseite ausgegeben:



    Dieser beim Aufrufen des Forums:

  • Tritt der Fehler bei allen Seiten/Foren auf? Woltlab Suite 3.1 ist aus 2018.

    Ich denke mit PHP 8.0 wurde die Software nicht getestet, da 5.4 in einer aktuellen Fassung lediglich fuer 8.0 freigeben wurde.

    Regards,


    Alexander / Aebian

    • Best Answer

    Ich würde schon fast behaupten, du nutzt die 3.1 mit PHP 8.0.

    Das ist nicht supported. PHP 8.0 ist erst mit 5.4 kompatibel.

    Ich glaube deine Version geht nur bis PHP 7.3, kann mich da aber täuschen.

    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

  • Zombfort

    Selected a post as the best answer.
  • Danke für die Antworten, das klingt sehr plausibel. An sowas hatte ich garnicht gedacht. Ich melde mich, wenn ich herausgefunden hab, wie ich das ändere und es klappen sollte ^^

  • Hallo,


    Ich melde mich, wenn ich herausgefunden hab, wie ich das ändere

    vielleicht kannst Du den dortigen Betreiber ja auch davon überzeugen, seine Lizenz zu erweitern und dann auf die aktuelle Version umzustellen. :)


    Damit hätte ich sich dann auch automatisch das "Problem" mit PHP 8.0 und zukünftig auch den Folgeversionen ab 8.1 aufwärts erledigt.

    Software und Server-Umgebung sollten möglichst immer etwa auf "Augenhöhe" sein, was man zwar sicher nicht immer zu 100% schafft (und weswegen es ja jeweils Übergangszeiten gibt), aber zumindest annähernd sollte man das versuchen.


    Und es ist sicher allemal der bessere Weg, die Applikation zu aktualisieren, als PHP- und MySQL-Versionen "downzugraden" (blödes Denglish).

    Gruß

    Jörg

    (Jaydee)

  • Haben erstmal PHP auf 7.4 zurückgestellt und nun geht alles wieder, danke für die schnelle Hilfe, ist erledigt ^^

  • Für en schnellen Übergang ist das sicher erst mal eine Lösung. Mittelfristig würde ich aber trotzdem über ein Upgrade nachdenken. :)


    Nicht nur dass der Support für diese Version (auch was Sicherheits-Updates betrifft) in überschaubarer Zeit komplett endet, auch PHP 7.4 läuft ja von der Pflege her nicht mehr ewig (nach meinem letzten Kenntnisstand bis etwa Ende November 2022, also kein ganzes Jahr mehr) und auch diese Version wird dann von den Hostern mit Sicherheit nach und nach deaktiviert. Derzeit sind wir bei Version 8.1.

    Gruß

    Jörg

    (Jaydee)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!