Stil Schriftgrösse

  • Affected Version
    WoltLab Suite 5.4

    Hallo zusammen,


    wir sind gerade im Testboard drin und arbeiten da an versch. Sachen. Dabei ist mir aufgefallen das bei den Stils die Schrift recht klein ist.


    Meine Frage nun, gibt es ein Plugin mit dem sich jedes Mitglied individuell die passende Schriftgröße einstellen kann, ohne dass das ganze Forum vergrößert wird.


    Ja ich weiss man kann im ACP in jedem einzelnen Stil die Schriftgrösse ändern, anpassen, aber dann ist sie eben auch auf Handy grösser, was weniger gut ist.



    Liebe Grüsse

    Leandra

  • Hallo Leandra,


    mit dem sich jedes Mitglied individuell die passende Schriftgröße einstellen kann, ohne dass das ganze Forum vergrößert wird.

    ein entsprechendes Plugin wäre mir jetzt zwar nicht bekannt (mag es trotzdem geben), aber zumindes jeder etwas bessere Browser bietet die Möglichkeit, Schriftgrößen mehrerer "Standard-Klassen" für Websites individuell anzupassen.

    Am besten ging das allerdings im ganz alten Opera, da konnte man wirklich für jede einzelne Schrift (plus Klasse) eine separate Minimal- und Standardgröße festlegen und speichern.

    Ansonsten hilft in einigen Browsern leider fast nur der Seiten-Zoom.

    Gruß

    Jörg

    (Jaydee)

  • ok, wo im Browser kann man das für Websites einstellen? Ich habe den Google Chrome und den Firefox, nutze aber öfters den Chrome.

    Ich weiss das ich Seite zoomen kann aber damit wird dann eben alles grösser, das ganze Forum.

  • Der Firefox ist da nach wie vor extrem kniepig ausgestattet (braucht für fast alles irgendwelche Plugins und blockiert ansonsten seinerseits sehr viel aus "vermeintlichen Sicherheitsgründen"), weshalb ich persönlich ihn schon länger kaum noch nutze (außer zum Testen eigener Websites). Dort geht es fast nur über den Zoom und ansonsten eine pauschal einstellbare Schriftgröße.


    Im

    Google Chrome

    hingen ist es schon deutlich flexibler: Einstellungen -> Darstellung -> Schriftart anpassen -> (gewünschten Font auswählen) usw., das siehst Du dann schon dort.

    Da kannst Du einmal pauschal Minimal- und Standard-Schriftgrößen festlegen und dann wie gesagt noch mal einzeln pro Font.

    Gruß

    Jörg

    (Jaydee)

  • Du hast recht, in der Tat hat er inzwischen ganz ähnliche Optionen.


    Hier also der Vollständigkeit halber auch der genaue Pfad:

    Extras -> Einstellungen -> Allgemein -> Sprache und Erscheinungsbild  -> Schriftarten & Farben.


    Unter "Erweitert" gibt es dann noch einige Optionen mehr. Das Häkchen bei "Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten erlauben" muss dann ggf. entfernt werden, damit die Einstellungen auch im Forum greifen.

    Gruß

    Jörg

    (Jaydee)

  • Es ging mir eigentlich nicht um den Browser, weil die Mitglieder ja nicht alle den selben benutzen.


    Die Frage war, ob es eine Möglichkeit evt ein Plugin gibt, wo die Mitglieder selber die Schriftgrösse ändern/einstellen könnten. Vor allem diejenigen die schlechte, bzw kranke Augen haben. Merke ich auch bei mir, meine Augen sind krank, werden nie wieder besser nur schlechter, im schlimmsten Fall kann es zu Erblindung führen. Habe also auch mit kleinen Schriften Probleme, weil es sehr anstrengend, selbst wenn man nur kleinere Texte lesen will.


    In anderen Foren hatte ich da schon richtig Probleme und wäre froh gewesen wenn ich ganz einfach beim Forum was ändern hätte können. Das grösser und kleiner scrollen beim Browser ist eine Möglichkeit aber wenn man dann ein Bild mitten im Beitrag hat, fällt das dann riesig aus und schon muss man wieder kleiner scrollen um danach wieder grösser zu scrollen damit der restliche Text gelesen werden kann. Das ist sehr mühsam, finde ich.


    Hoffe ihr versteht was ich meine.

  • Danke für den Tipp. Das wäre super wenn es so ginge, aber geht nicht. Vermute mal weil der verlinkte Beitrag von 2018 ist und die Codes so nicht mehr passen. Schade, das wäre eine gute Lösung.


    Habe es in drei versch. Stils, in Testforum (wsc 5.3) so gemacht wie die Anleitung sagt, aber hat nichts gebracht. Sehe keine Buttons wie unten im verlinkten Beitrag steht das man die sehen kann.


    Könnte vielleicht irgendwer mal schauen wo diese Code Zeilen angepasst werden müssten und sie entsprechend ändern, bin leider nicht so Fachfrau was solche Code Dinger angeht.

  • Falls es um die Seite geht, die in deinem Profil angegeben ist: Unter <div id="content" class="content"> wird der erwähnte Templatecode nicht ausgegeben, was eigentlich nur heißen kann, dass das entsprechende Template nicht bearbeitet wurde.

  • Falls es um die Seite geht, die in deinem Profil angegeben ist: Unter <div id="content" class="content"> wird der erwähnte Templatecode nicht ausgegeben, was eigentlich nur heißen kann, dass das entsprechende Template nicht bearbeitet wurde.

    Das kannst du im Forum nicht finden, weil ich es im Testforum (Testumgebung) ausprobierte. Habe mir abgewöhnt irgendwelche Dinge direkt im Forum auszuprobieren. Den Fehler machte ich in der Anfangszeit öfters und hatte damit auch schon das Forum ins Nirvana verfrachtet. Passiert mnir niocht so schnell wieder.


    Der link in Profil ist das Forum = Live Board und das Testforum/Testboard ist nur zum Testen da = Testinstallation.

  • Den Fehler machte ich in der Anfangszeit öfters und hatte damit auch schon das Forum ins Nirvana verfrachtet. Passiert mnir niocht so schnell wieder.

    Deine Einstellung zum Testforum ist grundsätzlich richtig.

    Wenn das "Zerschießen" allerdings durch manipulierte Templates zustande kam, kannst Du das allerdings sehr schnell wieder retten, indem Du entweder die Template.Group im betroffenen Style wieder auf "Standard" änderst, oder aber mindestens das eigene Template wieder aus der Gruppe löschst. Ab da wird dann wieder automatisch der Standard verwendet.

    Gruß

    Jörg

    (Jaydee)

  • das man da nun erst eine neue Templategruppe erstellen muss, und dann bei Stils so einstellen muss. etwas einfacher gesagt.

    Richtig, deshalb schrieb ich ja unter anderem das:


    Wenn das "Zerschießen" allerdings durch manipulierte Templates zustande kam, kannst Du das allerdings sehr schnell wieder retten, indem Du entweder die Template.Group im betroffenen Style wieder auf "Standard" änderst

    Wenn Du dort nicht Deine eigene Gruppe aktivierst, haben die Änderungen (in dem Stil) natürlich keine Auswirkung.

    Daher kannst Du bei mehreren Styles auch fallweise entscheiden, OB Änderungen greifen sollen und WELCHE jeweils (bei mehreren Gruppen).

    Gruß

    Jörg

    (Jaydee)