pageHeaderUser (Ohne Plugin)

  • Affected Version
    WoltLab Suite 5.4

    Hallo zusammen,


    Ich würde ja gerne in den Template eine weitere Usermenu erweitern wollen, genauso wie Kontrollzentrum. Möchte ungern ein Plugin dazu nutzen wollen.


    Im Kontrollzentrum hab ich schon eine erweiterungs code gefunden & eingebaut unter den Template pageHeaderUser


    Hab mal ein Screenshot gemacht von mipu


    Mit freundlichen Grüßen

    Andy & Danke im Vorraus!

  • Schau mal hier vielleicht ist das was für dich.


    https://wbbsupport.de/forum/thread/325-css-mega-men%C3%BC/

    Ne ne mipu, möchte das nicht :) aber danke.

    Wirklich sinnvoll ist das aber nur mittels Plugin umsetzbar.

    Mag sein, aber ich möchte halt einiges Probieren an den Codes.


    Wenns nicht geschieht, muss ich weiter selbst probieren & rum suchen, basteln etc bb ...

    Mit freundlichen Grüßen

    Andydeluxe97 ;)

    Edited once, last by Andydeluxe97 ().

  • Alles gut mipu, Thema ist erledigt ;)


    Dachte wenigst hilfe stellung, wie & wo man das einbaut & welchen code man nutzen muss. Anscheind bin ich hier nicht willkommen...


    Meine meinung! erwerben des plugins von anderen, ist echt eine überlegnungs wert.


    Viel Spaß euch!

    Mit freundlichen Grüßen

    Andydeluxe97 ;)

  • Dachte wenigst hilfe stellung, wie & wo man das einbaut & welchen code man nutzen muss. Anscheind bin ich hier nicht willkommen...

    Du hast die Hilfestellung bekommen, allerdings weigerst du dich. Siehe:

    Wirklich sinnvoll ist das aber nur mittels Plugin umsetzbar.

    Sei doch froh, dass ein erfahrener Entwickler dir den Tipp gibt, dies im besten und sinnvollsten Fall per Plugin zu entwickeln. Wenn du es direkt in deinem Paket modifizieren willst, kannst du es auch direkt als eigenes Paket entwickeln. Wenn du dazu konkrete Fragen hast, schieß sie raus und dir wird geholfen.

    Mag sein, aber ich möchte halt einiges Probieren an den Codes.

    Das Paket welches du derzeit nutzt und modifizieren willst, kennst du in deiner Laufzeitumgebung am besten. Ob es dort Sinn macht direkt im Quellcode zu arbeiten bezweifele ich stark. Spätestens mit dem nächsten Update sind deine Änderungen futsch.

    Anscheind bin ich hier nicht willkommen...

    Hier ist jeder willkommen. Deine Fragestellung und die zur Verfügung gestellten Informationen sind aber recht dürftig.

    erwerben des plugins von anderen, ist echt eine überlegnungs wert.

    Natürlich kann das Plugin auch jemand anderes entwickeln, aber dann beschäftigst du dich mit dem Code nicht und verfehlst doch dein eigenes gesetztes Ziel dich mit dem Code zu beschäftigen.

  • Du hast die Hilfestellung bekommen, allerdings weigerst du dich. Siehe:

    Sei doch froh, dass ein erfahrener Entwickler dir den Tipp gibt, dies im besten und sinnvollsten Fall per Plugin zu entwickeln. Wenn du es direkt in deinem Paket modifizieren willst, kannst du es auch direkt als eigenes Paket entwickeln. Wenn du dazu konkrete Fragen hast, schieß sie raus und dir wird geholfen.

    Das Paket welches du derzeit nutzt und modifizieren willst, kennst du in deiner Laufzeitumgebung am besten. Ob es dort Sinn macht direkt im Quellcode zu arbeiten bezweifele ich stark. Spätestens mit dem nächsten Update sind deine Änderungen futsch.

    Hier ist jeder willkommen. Deine Fragestellung und die zur Verfügung gestellten Informationen sind aber recht dürftig.

    Natürlich kann das Plugin auch jemand anderes entwickeln, aber dann beschäftigst du dich mit dem Code nicht und verfehlst doch dein eigenes gesetztes Ziel dich mit dem Code zu beschäftigen.

    Ist ja auch inordnung wie du es geschrieben hast, meiner meinug über nehm ich die haftung dafür was geändert wird. Plugins kauf mag sein, aber geld wächst auch nicht auf bäumen. möchte demnächst ja wieder bei Woltlab lizenz forum verlängern... Sowie Filebase. Wenn ich da plugin kaufe, kann ich dies wieder nicht machen.


    Aber naja gut, mal sehn wie ich alles hand haben kann, mein wünsch wäre dies eine, mehr ist es nicht :)


    P.s: möchte ja auch ungern stress/beef what ever machen, weil das es unnötig ist. ;)

    Mit freundlichen Grüßen

    Andydeluxe97 ;)

  • Plugins kauf mag sein, aber geld wächst auch nicht auf bäumen.

    Du verwechselst eventuell etwas.


    Plugins sind nicht zwangsläufig mit einem Kauf und Kosten verbunden nur weil es hier einen Plugin Store gibt. Du kannst Plugins auch selber entwickeln und für dich benutzen. Das ist also genau das, was du tun willst.


    Wenn wir von „ein Plugin ist das einzig sinnvolle“ sprechen, meinen wir nicht, dass du Geld ausgeben musst. Wir meinen damit, dass du die Umsetzung im Code in Form eines Plugins erledigen sollst.

  • Du verwechselst eventuell etwas.


    Plugins sind nicht zwangsläufig mit einem Kauf und Kosten verbunden nur weil es hier einen Plugin Store gibt. Du kannst Plugins auch selber entwickeln und für dich benutzen. Das ist also genau das, was du tun willst.


    Wenn wir von „ein Plugin ist das einzig sinnvolle“ sprechen, meinen wir nicht, dass du Geld ausgeben musst. Wir meinen damit, dass du die Umsetzung im Code in Form eines Plugins erledigen sollst.

    ja das stimmt schon, Soviel ahnung von entwickeln hab ich weder rum auch nicht. Daher will ich selbst in den codes die schon stehen dran was machen. Hafte dann auch selbst usw etc bb

    Es ginge auch ohne, aber das will man sich nicht antun, zumal das auch nicht zwingend Update-sicher ist.

    na doch, ich habe mir die datei gesichert vorher, bevor update gemacht wurden ist :) dann hab ich zu mindest die template gelöscht & erneut gemacht. Arbeite lieber daran sehr gerne damit ich auch irgendwann weiß wie es funktioniert oder eher gesagt wie es geht.

    Mit freundlichen Grüßen

    Andydeluxe97 ;)

  • Schau mal hier vielleicht ist das was für dich.


    https://wbbsupport.de/forum/thread/325-css-mega-men%C3%BC/

    Hallo,


    ich will mich recht herzlich entschuldigen, hab mir mal diesen plugin doch genau angeschaut & es ist doch genau so gebaut wie bei mipu.


    Tut mir leid zusammen !


    Ich wusste ich nicht das genau so entwickelt wurde :( ... Verzeihung an euch !

    ----------------------

    Nehme alles zurück was ich geschrieben habe!!!!!!!

    Mit freundlichen Grüßen

    Andydeluxe97 ;)

  • Mein Fehler, tut mir leid

    Das Mega Menü ist nicht von mipu.

    Aber das Userpanel Mod-Plugin.

    In Hoffnung auf positiven Verbleib gehen Grüße raus