Artikelerstellung - weisse Seite bei Artikelbildauswahl

  • Affected Version
    WoltLab Suite 5.4

    Betriebssystem Windows 10

    Browser: Firefox 90.0.2 64 bit


    Ablauf:

    • Auf Website in der Artikelübersicht auf Artikel hinzufügen klicken
    • Kategorie ausgewählt
    • Datum und Uhrzeit ausgewählt - Linksklick zum schließen des Dialogs in freies Feld
    • Zeitgesteuerte Veröffentlichung
    • Datum und Uhrzeit erneut auswählen beim erscheinenden Datumsfeld - Linksklick zum schließen des Dialogs in freies Feld
    • Bild auswählen anklicken
    • Ergebnis: Weiterleitung zu leerer weisser Seite mit dem Namen article-add

    Das ganze wird nur beim ersten Aufruf der entsprechenden Seite ausgelöst. Lade ich die Website nicht neu, und gehe mit dem Browser-Zurück-Button auf meine Seite und erstelle einen Artikel funktioniert die Eingabe des Artikels beim zweiten Anlauf und das Artikelbild-Fenster öffnet sich. Lade ich die Website neu, kommt der Fehler erneut.


    Auf Anfrage kann ich Zugang ermöglichen. Der Fehler taucht komischerweise aber nicht immer auf. Es scheint wichtig zu sein, das Datum UND die Uhrzeit anzuwählen und anzupassen. Ändere ich nur das Datum funktioniert es.

    Quote from Marquis de La Fayette

    Auflehnung ist das Heiligste aller Rechte und die Notwendigste aller Pflichten.

    Edited 2 times, last by Lantis ().

    • Official Post

    Hallo,


    die Schilderung lässt auf einen JavaScript-Fehler schließen. Kannst du es bitte einmal mit den offenen Entwickler-Werkzeugen von Firefox versuchen zu reproduzieren? Falls das Problem auftritt, sollte eine entsprechende Meldung im Tab "Console" auftauchen, die uns den Grund für den Fehler liefert.

  • Ok, mach ich morgen vormittag. Ich muss heute noch bis 01:00 Uhr arbeiten.

    Quote from Marquis de La Fayette

    Auflehnung ist das Heiligste aller Rechte und die Notwendigste aller Pflichten.

  • Leider konnte ich dieses Verhalten nicht mehr provozieren. Trotz mehrmaliger Versuche. X/

    Quote from Marquis de La Fayette

    Auflehnung ist das Heiligste aller Rechte und die Notwendigste aller Pflichten.

  • Jetzt habe ich den Fehler bekommen, allerdings im ACP unter der Seitenerstellung, als ich ein Bild über die Media-Galerie einbinden wollte.


    Code
    Ein Versuch wurde unternommen, eine Nicht-UTF8-Kodierung für JSON zu verwenden, das per XMLHttpRequest geholt wurde. Nur UTF-8 wird für die Dekodierung von JSON unterstützt.
    Quote from Marquis de La Fayette

    Auflehnung ist das Heiligste aller Rechte und die Notwendigste aller Pflichten.

  • Als ich eben auf Artikel bearbeiten geklickt habe, gab es noch eine Meldung zu dieser anderen mit dem Ergebnis einer weissen Seite:


    Code
    Die Ressource unter "https://fdg-clan.de/font/fontawesome-webfont.woff2?v=4.7.0" wurde vorab geladen ("link-preload"), aber nicht innerhalb der ersten Sekunden verwendet. Es wird eine Überprüfung empfohlen, ob alle preload-Attribute korrekt gesetzt sind.

    Ich finde das ziemlich nervig.


    Ich musste eben erstmal schauen wie ich unter Ionos die Fehlerprotokollierung aktiviere und bin so wie dort beschrieben vorgegangen.


    Dementsprechend kann ich momentan erstmal nichts weiter zur Verfügung stellen, da die Fehlerprotokolierung nicht aktiv war.

    Quote from Marquis de La Fayette

    Auflehnung ist das Heiligste aller Rechte und die Notwendigste aller Pflichten.

  • Ich kann dazu leider keine Fehler liefern. Es trat aber immer mal wieder auf in letzter Zeit.


    Kann das auch an der Schwachen 16mbit Leitung liegen dass er ab und zu etwas nicht so lädt wie er soll? :)

    Quote from Marquis de La Fayette

    Auflehnung ist das Heiligste aller Rechte und die Notwendigste aller Pflichten.

    • Official Post

    Kann das auch an der Schwachen 16mbit Leitung liegen dass er ab und zu etwas nicht so lädt wie er soll? :)

    Eher unwahrscheinlich. Eine "weiße Seite" ist praktisch stellvertretend für eine vom Webserver unterdrückte PHP-Fehlermeldung. Nur liefert diese eben keine Aussage darüber, was genau das Problem ist.

  • Kannst du mir einen Tipp geben wie ich das eventuell rausbekommen kann?


    Mit einer php.ini im Verzeichnis des Forums hat es leider nicht funktioniert so wie mein Webhoster Ionos das beschreibt.

    Quote from Marquis de La Fayette

    Auflehnung ist das Heiligste aller Rechte und die Notwendigste aller Pflichten.

  • In Ordnung. Dann werde ich das mal weiterleiten. Du kannst es ja erstmal als nicht reproduzierbar kennzeichnen.

    Quote from Marquis de La Fayette

    Auflehnung ist das Heiligste aller Rechte und die Notwendigste aller Pflichten.

  • Ich habe mir mal die weisse Seite im Quelltext angesehen. Der title tag sagt "Zugriff verweigert" und in der Adresszeile ist /article-edit/xx eingetragen . Ich glaube zwar nicht das der Quellcode für euch nützlich ist, das ist aber momentan alles was ich habe.


    Ich habe jetzt erstmal die php Version von 8.0 auf 7.4 umgestellt.



    Also irgendwas stimmt nicht, der Fehler tritt nach wie vor immer mal wieder auf.

    Quote from Marquis de La Fayette

    Auflehnung ist das Heiligste aller Rechte und die Notwendigste aller Pflichten.

    Edited once, last by Lantis ().

  • Jetzt habe ich schon wieder öfter eine weisse Seite.


    Folgende Fehler habe ich in der Konsole festgestellt.


    Quote from Marquis de La Fayette

    Auflehnung ist das Heiligste aller Rechte und die Notwendigste aller Pflichten.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!