Unterstützung für WebP-Grafiken fehlt

  • Hallo,


    ich habe zum Testen mal die 5.4 Beta runtergeladen und wollte sie installieren.

    (Ich habe bislang nur ein ganz altest WBB 2.3, das wird mal Zeit, dass ich mich mal nach etwas neuem umsehe. :D)


    Beim Installieren wird mir gesagt, dass die Unterstützung für WebP-Grafiken fehlen würde.

    In der php-Info steht aber unter gd, WebP Support enabeld.


    Muss ich irgendetwas im Vorfeld noch installieren oder einstellen?

    • Official Post

    Eine ImageMagick-Installation ohne WebP ist ziemlich ungewöhnlich, das Format gibt es bereits seit 2010. Falls es sich um ein Webhosting-Angebot handelt, ist dem Anbieter wahrscheinlich ein Irrtum unterlaufen, in dem Fall sollte eine kurze Anfrage an diesen ausreichen.

  • Ok, habe meinen Anbieter kontaktiert.

    Das wird definitiv irgendwann geupdatet werden, er kann aber zur Zeit noch gar nicht sagen, wann das sein wird.


    Gibt es eine Möglichkeit, das dann solange unter GD laufen zu lassen?

    Ich will es ja auch erst einmal nur testen.

    Oder muss ich dazu jetzt tatsächlich warten bzw. mir einen anderen Webhoster suchen?

    • Official Post

    Das wird definitiv irgendwann geupdatet werden, er kann aber zur Zeit noch gar nicht sagen, wann das sein wird.

    Wenn ich mir so die Liste der bekannten Sicherheitslücken in alten ImageMagick-Versionen anschaue, sollte es eher früher als später passieren. Es ist ein wenig sehr fragwürdig, dass ein Webhoster (den man schließlich dafür bezahlt, sich um so etwas zu kümmern!) offenbar die bereitgestellte Softwareumgebung nicht angemessen pflegt.


    Gibt es eine Möglichkeit, das dann solange unter GD laufen zu lassen?

    Prinzipiell würde es reichen, die "imagick"-Erweiterung zu deaktivieren, dann würde automatisch GD verwendet.

  • Wenn ich mir so die Liste der bekannten Sicherheitslücken in alten ImageMagick-Versionen anschaue, sollte es eher früher als später passieren. Es ist ein wenig sehr fragwürdig, dass ein Webhoster (den man schließlich dafür bezahlt, sich um so etwas zu kümmern!) offenbar die bereitgestellte Softwareumgebung nicht angemessen pflegt.

    Das hier war seine Begründung:

    Das ImageMagick von Debian 9 kann kein WebP, das ließe sich nur durch eine Betriebsystemaktualisierung auf Debian 10 lösen. Dabei würde dann auch MariaDB von 10.1 auf 10.3 geupdated, womit allerdings wieder Typo3 7.x oder älter Probleme hat. Es sind aber einige Kunden mit 4.x, 6.x und 7.x Versionen vorhanden.


    Prinzipiell würde es reichen, die "imagick"-Erweiterung zu deaktivieren, dann würde automatisch GD verwendet.

    Ok, kann ich das selber machen oder müsste das auch der Webhoster übernehmen?

    • Official Post

    Das ImageMagick von Debian 9 kann kein WebP

    Debian 9 ist seit dem 6. Juli 2020 (vor >1 Jahr) bereits End of Life (*) und Debian 11 steht praktisch schon vor der Tür.


    (*) Es gibt noch das inoffizielle LTS ("Long Term Support") das ~2022 endet.


    Ok, kann ich das selber machen oder müsste das auch der Webhoster übernehmen?

    Bei den typischen Verwaltungsoberflächen wie Plesk und Co. ist das per Mausklick möglich. Die obigen Ausführungen lassen aber nicht unbedingt hoffen, gerade wenn man als Kunde alte Software untergeschoben bekommt, weil irgendwelche anderen Kunden antike Software (*) einsetzen.


    (*) Typo3 v7 LTS wird seit 2018 nicht mehr gepflegt.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!