xampp Darstellungs Problem?

  • Ich nehme an, dass du im XAMPP Control Panel Apache und MariaDB bzw. MySql gestartet hast.


    Wie hast du dein WBB aufgerufen? Angenommen, es befindet sich z.B. im Ordner c:/xampp/htdocs/portal/, dann bekomme ich eine ähnliche Darstellung wie in deinem Screenshot mit dem Aufruf: file:///C:/xampp/htdocs/portal/

    Der korrekte Aufruf wäre allerdings (in meinem Beispiel): localhost/portal/


    lg,

    Chris

  • Schau auch mal nach, ob die index.php in der Apache Config unter XAMPP/apache/conf/httpd.conf als Index eingetragen und das dir_module aktiviert ist:

    Code: httpd.conf
    <IfModule dir_module>
        DirectoryIndex index.php index.pl index.cgi index.asp index.shtml index.html index.htm \
                       default.php default.pl default.cgi default.asp default.shtml default.html default.htm \
                       home.php home.pl home.cgi home.asp home.shtml home.html home.htm
    </IfModule>
    Code: httpd.conf
    LoadModule dir_module modules/mod_dir.so

    ~ DMedia

  • Wenn ich das mache bekomme ich folgendes.


    Objekt nicht gefunden!

    Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut.

    Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

    Error 404

    localhost

  • Ja habe ich aber ich kann leider nicht wirklich daraus erkennen was das problem ist, beim php_error.log bekomme ich das er den angegebenen Pfad nicht finden kann.

  • Du hast recht es fehlen die index.php und global.php ich spiele gerade die Dateien noch mal ein und schaue das diesmal alle da sind ich melde mich dann wider dauert einen moment.

  • Vielen dank an alle es lag wirklich an den fehlenden Dateien, ich habe nun die Pfade angepasst mit localhot/wbb3 und bekomme nun Folgenden fehler.

    Code
    Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in C:\xampp\htdocs\wbb3\wcf\lib\core.functions.php on line 27
    
    
    
    Fatal error: Uncaught TypeError: Argument 1 passed to WCF::handleException() must be an instance of Exception, instance of Error given in C:\xampp\htdocs\wbb3\wcf\lib\system\WCF.class.php:254
    Stack trace:
    #0 [internal function]: WCF::handleException(Object(Error))
    #1 {main} thrown in C:\xampp\htdocs\wbb3\wcf\lib\system\WCF.class.php on line 254

    Was bedeutet das und wie kann ich es beheben?

  • Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in C:\xampp\htdocs\wbb3\wcf\lib\core.functions.php on line 27

    Das bedeutet, du verwendest eine höhere PHP Version als 7.2, in welcher die Funktion als veraltet eingestuft wurde.

    Das ist auch der Grund für den unten stehenden Fehler, da das WBB3 nur bis PHP 5.6 lauffähig ist.

    ~ DMedia

  • Du kannst ja im Hauptverzeichnis mal eine phpinfo.php mit folgendem Inhalt anlegen und das kontrollieren in dem du sie im Browser aufrufst:

    PHP: phpinfo.php
    <?php
    phpinfo();
    ?>

    ~ DMedia

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!