Session Cookies über Subdomains

  • Affected Version
    WoltLab Suite 5.3

    Hallo zusammen,


    nach einem Serverumzug und damit verbundenen Updates für das Woltlab Forum habe ich auch die Struktur der Installation etwas angepasst. Unter der Hauptdomain example.com wird der Nutzer auf das Dashboard geleitet, während unter forum.example.com das eigentliche Forum abrufbar ist. Bei vielen Nutzern gibt es damit keine Probleme, manche haben aber scheinbar Probleme damit über den Wechsel der Domain hinweg eingeloggt zu bleiben. Sie können sich also bspw. teilweise unter forum.example.com nicht einloggen, auf der Hauptadresse example.com allerdings schon. Ich vermute daher, dass es sich um ein Problem mit den Session-Cookies handelt. Nach etwas herumprobieren ist es für mich allerdings immer noch nicht nachvollziehbar, wieso das Problem nur bei manchen Usern auftritt. Selbst mit demselben Browser konnte ich den Fehler nicht reproduzieren. Auch haben die entsprechenden Nutzer versucht alle bisherigen Cookies und aktiven Logins zu löschen, um Komplikationen mit der alten Installation auszuschließen.


    Meine Frage wäre daher, wo in dem Fall das Problem liegen könnte und vor allem, wieso das Problem bei gleichem Browser bei manchen Personen auftritt, bei anderen allerdings nicht?


    Vielen Dank für euren Input!


    Beste Grüße

  • Ist halt auch blöd das Woltlab selbst das macht, da könnte man denken das es Problemlos möglich ist.

    • Official Post

    Kratom.Ink Die Unterstützung für Installationen mit mehreren Subdomains wird ab 5.4 als "deprecated"/"veraltet" markiert und mit 5.5 entfernt.


    Ist halt auch blöd das Woltlab selbst das macht, da könnte man denken das es Problemlos möglich ist.

    Wir haben noch diverse ausstehende Änderungen an der Website, sonst hätten wir diesen Unsinn bereits mit dem Upgrade auf 5.4 bei uns abgeschafft.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!