PHP von 7.3 auf 7.4 Geupdatet danach Fehler.

  • Affected Version
    WoltLab Suite 5.2

    Hallo! Wir haben heute PHP von version 7.3 auf version 7.4 Geupdatet seitdem ist alles was beim aufrufen des Forums erscheint folgendes


    PHP
    <?php
    /**
     * @author    Matthias Schmidt
     * @copyright    2001-2018 WoltLab GmbH
     * @license    GNU Lesser General Public License <http://opensource.org/licenses/lgpl-license.php>
     * @package    WoltLabSuite\Core
     */
    require_once('./global.php');
    \wcf\system\request\RequestHandler::getInstance()->handle('wcf');

    Hat da irgendeiner eine idee? Unser Betriebssystem ist Debian 10

  • Das schaut eher so aus, als würde php gar nicht ausgeführt werden.

    Aktuell zeigt die Seite das:

    Das wäre seine URL: https://speargaming.de/

    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

  • Wurde der Webserver entsprechend angepasst? Denn der lauscht wahrscheinlich noch auf einem (nicht mehr) vorhandenen Socket

    Ich habe dieses Tutorial befolgt.https://php.watch/articles/Ubuntu-PHP-7.4


    und davon nur den Debian Part, mehr nicht. was könnte ich noch machen? bin was webserver angeht nicht der erfahrenste ^^

  • du musst deinem webserver schon mitteilen, welchen socket er nehmen soll für php

    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

  • ja stimmt

    „If you can only do one thing, hone it to perfection. Hone it to the utmost limit!“ – Zenitsu Agatsuma

  • Die wahrscheinlich sinnvollste Antwort auf diese Frage wäre wohl "sich jemanden ins Boot holen, der mit Server-Konfigurationen ausreichend vertraut ist, wenn Dir selber die Erfahrung dazu fehlt.".

    Auf jeden Fall müsste erst mal geklärt werden, warum der PHP-Interpreter bei Dir nicht arbeitet. Das kann ein falscher Socket (wie erwähnt) sein, es gibt aber auch noch weitere mögliche Gründe dafür.

    Gruß

    Jörg

    (Jaydee)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!