Bootstrap.js einbinden

  • Affected Version
    WoltLab Suite 5.2

    Hallo Zusammen,


    ich möchte gern von folgender Adresse die JavaScript-Daten einbinden: https://stackpath.bootstrapcdn.com/bootstrap/4.1.3/js/bootstrap.min.js


    Über das Plugin von Sonnenspeer CMS: PHP in Seiten habe ich mir dazu eine kleine Testseite erstellt. Leider reagieren die Buttons überhaupt nicht auf die Aktion die hinterlegt sind und über das Script funktionieren müssten. Lokal als "normale" PHP-Seite funktionieren die Buttons auch problemlos.


    <a href="javascript:void(0);" class="btn btn-success" data-type="add" data-toggle="modal" data-target="#modalUserAddEdit"><i class="fa fa-plus"></i> New User</a>


    Edit: das Modal das angesprochen wird ist korrekt vorhanden. Nur wird es eben weder angezeigt noch klappt das klicken auf dem Button.

    Es würde um folgende Funktion einer Seite gehen, die ich gern umsetzen möchte: https://www.codexworld.com/php-crud-operations-jquery-ajax-mysql/


    Grund dafür ist noch meine Nachfrage ist mein Vorhaben, das ich schon unter hier gepostet hatte.


    Ich habe ebenfalls schonmal versucht, die Datei lokal im Installationsverzeichnis liegen zu lassen, jedoch auch dort ohne Funktion. Gibt es denn Einschränkungen bei der Nutzung von JavaScript-Dateien / Funktionen oder sollte generell alles funktionieren?


    VG Shorty

    VG Shorty

    Edited once, last by _shorty ().

  • Ich gehe mal stark davon aus dass du die Datein nicht richtig einbindest und deshalb z.B das Modal noch gar nicht existiert, wenn Javascript drauf zugreifen will.


    Hast du derartige Fehler?

    Probier mal das Modal manuell zu triggern.

  • Ich gehe mal stark davon aus dass du die Datein nicht richtig einbindest und deshalb z.B das Modal noch gar nicht existiert, wenn Javascript drauf zugreifen will.


    Hast du derartige Fehler?

    Probier mal das Modal manuell zu triggern.

    Das Modal wird direkt beim ersten laden der Seite erstellt und ist dann nur per display:none ausgeblendet. Es funktionieren komischerweise keine Buttons auf der Seite. Der einzige Button der funktioniert ist einer, der direkt ein onclick-Event besitzt.


    Ich habe dir mal den Code der Seite gepostet. Ehrlich gesagt, finde ich den Fehler nicht warum die Buttons nicht gehen, dafür aber der Deletebutton :/

    VG Shorty

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!