Update von 4.1. auf 5.2. schlägt fehl

  • Affected Version
    WoltLab Suite 5.2

    Hallo


    Ich habe versucht ein Forum von der 4.1. auf die 5.2. upzudaten. Das schlägt aber leider fehl und es kommt unten genannte Meldung.

    Woran kann dies liegen?

    Vorher habe ich zuerst ein Update von WCS 3.0 auf 3.1. gemacht

    Requested URL
    /acp/index.php?install-package/&t=95dd1e172b17fa5756fad0e1e35912aae1f22b82
    Referrer
    https://das-dunkelbunt.de/acp/index.php?package-update/
    Error Message
    Die Aktualisierung erfordert PHP in Version 7.0.22 oder höher.
    Type
    wcf\system\exception\SystemException
    File (Line)
    /www/xxxxs/xxxx/xxx/xxxx/update_com.woltlab.wcf_5.2_preUpdate.php (25)
    Stacktrace
    1. /www/htdocs/w00fb719/wbb5/lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (72): include(…)
    2. /www/htdocs/w00fb719/wbb5/lib/system/package/plugin/ScriptPackageInstallationPlugin.class.php (50): wcf\system\package\plugin\ScriptPackageInstallationPlugin->run(…)
    3. /www/htdocs/w00fb719/wbb5/lib/system/package/plugin/AbstractPackageInstallationPlugin.class.php (70): wcf\system\package\plugin\ScriptPackageInstallationPlugin->install(…)
    4. /www/htdocs/w00fb719/wbb5/lib/system/package/PackageInstallationDispatcher.class.php (673): wcf\system\package\plugin\AbstractPackageInstallationPlugin->update(…)
    5. /www/htdocs/w00fb719/wbb5/lib/system/package/PackageInstallationDispatcher.class.php (144): wcf\system\package\PackageInstallationDispatcher->executePIP(…)
    6. /www/htdocs/w00fb719/wbb5/lib/acp/action/InstallPackageAction.class.php (73): wcf\system\package\PackageInstallationDispatcher->install(…)
    7. /www/htdocs/w00fb719/wbb5/lib/action/AbstractDialogAction.class.php (68): wcf\acp\action\InstallPackageAction->stepInstall(…)
    8. /www/htdocs/w00fb719/wbb5/lib/action/AbstractAction.class.php (47): wcf\action\AbstractDialogAction->execute(…)
    9. /www/htdocs/w00fb719/wbb5/lib/system/request/Request.class.php (83): wcf\action\AbstractAction->__run(…)
    10. /www/htdocs/w00fb719/wbb5/lib/system/request/RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    11. /www/htdocs/w00fb719/wbb5/acp/index.php (9): wcf\system\request\RequestHandler->handle(…)
  • Ja, das verstehe ich aber nicht. Auf den Server laufen auch 2 andere Seiten von mir, da ging dies auch ohne Probleme.

    Muss ich mal schauen, ob er bei den einnen Account ein anderes PHP hat, was mich aber wundert

  • Also eigentlich würde auch php 5.6 reichen laut dem Log oben, nutzt du echt noch eine Ältere version ?



    Quatsch etwas weiter unten steht es ja mindestens 7.0.2 wobei ich gleich die 7.3 nehmen würde.

  • Danke für den Denkanstoss :)

    Ich habe das Problem gefunden. Bei der Domainverwaltung in den Account war noch PHP 5.6. aktiviert. Ich habe das jetzt auf die entsprechende geändert und da lief das Update durch :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!