Fehlermeldung: Bitte installiere{if !LANGUAGE_USE_INFORMAL_VARIANT}

  • Affected Version
    WoltLab Suite 5.2

    So, nachdem ich nun alles bereinigt habe kommt beim Aufruf der Paketliste Installieren folgende Fehlermeldung:

    Bitte installiere{if !LANGUAGE_USE_INFORMAL_VARIANT}n Sie{/if} zuerst alle ausstehenden Updates, bevor {if LANGUAGE_USE_INFORMAL_VARIANT}du{else}Sie{/if} auf eine neue Version {if LANGUAGE_USE_INFORMAL_VARIANT}umsteigst{else}umsteigen{/if}.

    Im Spoiler die komplette Fehlermeldung.

    Was ist zu tun ?

    Display Spoiler

    Bitte installiere{if !LANGUAGE_USE_INFORMAL_VARIANT}n Sie{/if} zuerst alle ausstehenden Updates, bevor {if LANGUAGE_USE_INFORMAL_VARIANT}du{else}Sie{/if} auf eine neue Version {if LANGUAGE_USE_INFORMAL_VARIANT}umsteigst{else}umsteigen{/if}.

    Stacktrace:

    #0 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/data/package/update/PackageUpdateAction.class.php(599): wcf\data\package\update\PackageUpdateAction->createQueue('update')

    #1 [internal function]: wcf\data\package\update\PackageUpdateAction->prepareUpdate()

    #2 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/data/AbstractDatabaseObjectAction.class.php(204): call_user_func(Array)

    #3 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/action/AJAXProxyAction.class.php(75): wcf\data\AbstractDatabaseObjectAction->executeAction()

    #4 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/action/AJAXInvokeAction.class.php(104): wcf\action\AJAXProxyAction->invoke()

    #5 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/action/AbstractAction.class.php(47): wcf\action\AJAXInvokeAction->execute()

    #6 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/action/AJAXInvokeAction.class.php(63): wcf\action\AbstractAction->__run()

    #7 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/system/request/Request.class.php(83): wcf\action\AJAXInvokeAction->__run()

    #8 /homepages/14/d407714533/htdocs/test-forum/wcf/lib/system/request/RequestHandler.class.php(96): wcf\system\request\Request->execute()

    #9 /homepages/14/d407714533/htdocs/test-forum/wcf/acp/index.php(9): wcf\system\request\RequestHandler->handle('wcf', true)

    #10 {main}

  • Es gibt noch ausstehende Updates die mit der 3.1er Reihe kompatibel sind, deaktiviere bitte erst die Update-Server für 2019 und installiere die Updates. Anschließend die 2019er-Server wieder aktivieren und erneut nach Updates suchen.

  • Da werden keine Updates für die 3.1 er Reihe gefunden.

    Es sind nur beide WL Tornado update + store Update Server aktiv.

    Jetzt alle 3.1 ´er Updateserver aktiviert.. bin auf dem neuesten Stand.. keine Updates für 3.1.11 vorhanden..

    Edited once, last by 30957 (January 3, 2020 at 1:33 PM).

  • Ich jetzt alle Plugins von A bis Z im einzelnen auf aktualität geprüft. Ich bin auf dem neuesten Stand, immer noch das gleiche Problem und komm mit dem Release 5.2 nicht weiter. Was kann ich noch tun ?

  • Die identische Meldung hatte ich ebenfalls in meiner Testumgebung und dachte auch, dass ich doch alle Plugins aktuell hätte. Es haben sich dann aber noch vor dem großen Upgrade ein paar Sachen von SoftCreatR auf die jeweilige 5.2er-Version aktualisieren lassen (alle anderen Pakete manuell für den Update-Prozess erstmal deaktiviert). Anschließend kam die beschriebene Fehlermeldung bei mir nicht mehr.

    Gruß aus Südhessen

  • Nun, ich habe nur ein Plugin von SoftCreatR im System. (MediaElement.js-Integration) und das ist aktuell.

    Ich hab das Ticket abgesetzt, warten wir es ab. Ich möchte da jetzt nicht zwischen funken.

    Gruß

  • MediaElement.js-Integration

    Das kannst Du mit/vor dem Update auf WSC 5.2 deinstallieren, da es damit nicht mehr kompatibel sein soll (Funktion jetzt überflüssig?) und somit nicht mehr weiter gepflegt wird.

    Gruß aus Südhessen

  • Ursache ist der fehlerhafte Update-Server https://wbbsupport.de/update/server/14-stable/ von mipu, dieser liefert für das Paket de.wbbsupport.wsc.userMarkup den selben Wert in den <fromversions> doppelt aus:

    XML
    <fromversions>
            <fromversion><![CDATA[3.1.0]]></fromversion>
            <fromversion><![CDATA[3.1.1]]></fromversion>
            <fromversion><![CDATA[3.1.1]]></fromversion>
    </fromversions>
  • Hallo, erst einmal vielen Dank für die tolle Unterstützung. So kann ein kleiner Fehler ( mipu ) große Auswirkung haben und einem Kunden und dem Support stundenlang den Nerv rauben. Das hat mir in meiner Planung einen Tag gekostet.

    Nochmals vielen Dank an WL..

    Gruß aus Aachen

    Rainer

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!