Update-Fehlermeldung

  • Affected Version
    WoltLab Suite 3.1

    Hallo liebe Community!


    Ich wollte mein Burning Board updaten, doch dann kam diese Fehlermeldung (Siehe Anhang). Ich bitte um Hilfe!



    Mit freundlichen Grüßen

    Alex

  • "Die folgenden installierten Pakete schließen die Installation auf Grund von Inkompatibilitäten aus" bedeutet:

    Die angezeigten Pakete müssen vor dem Update deinstalliert werden, weil sie nicht kompatibel sind.

    Gremlins sind harmloser als Trolle. Beide erzeugen nichts Gutes, aber Gremlins darf man folgenlos zumindest vor Mitternacht füttern!

  • Trag mal noch folgende Updateserver ein:

    • https://www.cls-design.com/shop/update/3-tornado/
    • https://www.cls-design.com/update/tornado/
    • https://update.woltlab.com
    • https://store.woltlab.com
    • https://www.wbb-elite.de/shop/index.php?update/3-wsc3-0/

    Vorausgesetzt du hast für alle Updates die Lizenzen. Und dann nochmal nach Updates suchen lassen und schauen, was raus kommt. ;)

  • Die angezeigten Pakete müssen vor dem Update deinstalliert werden, weil sie nicht kompatibel sind.

    Wie kommt man denn auf so etwas?


    In der Regel müssen Pakete 'nur' auf dem neuesten Stand sein und die entsprechenden Update-Server müssen eingetragen sein. Dann funktioniert das auch mit dem Upgrade.

  • Wie kommt man denn auf so etwas?

    Weil ich meine das hier schon öfter so gelesen zu haben.

    Aber sollte mich meine Erinnerung in der Hinsicht trügen oder ich was falsch verstanden haben,

    dann muss ich meine Äußerung wohl revidieren. Bei der Fülle an täglichen Infos hier wirft man schonmal was durcheinander :(


    P.S.: Allerdings muss ich sagen, dass die Fehlermeldung dann auch etwas verwirrend ist. Empfinde ich zumindest so.

    Gremlins sind harmloser als Trolle. Beide erzeugen nichts Gutes, aber Gremlins darf man folgenlos zumindest vor Mitternacht füttern!

  • Ja, klingt tatsächlich etwas verwirrend, ist aber ganz einfach ;)


    Die Server prüfen, ob es von der installierten Version ein Update-Pfad zur einer Version gibt, die im nächsten WSC installiert sein darf. Wird keiner gefunden, mault der Server mit der o.a. Meldung. Meist liegt das eben daran, dass das System nicht auf dem neuesten Stand ist.

    Manchmal kann es natürlich auch sein, dass es einfach keine entsprechende Nachfolgeversion eines Pakets gibt. Dann muss das Paket tatsächlich vorher deinstalliert werden.

  • Manchmal kann es natürlich auch sein, dass es einfach keine entsprechende Nachfolgeversion eines Pakets gibt. Dann muss das Paket tatsächlich vorher deinstalliert werden.

    Das hatte ich im Kopf. Dann habe ich das wohl durcheinander geworfen bzw. nicht an die Möglichkeit fehlender Updates gedacht.

    Danke für die Erklärung :)

    Gremlins sind harmloser als Trolle. Beide erzeugen nichts Gutes, aber Gremlins darf man folgenlos zumindest vor Mitternacht füttern!

  • mal eine ganz dumme Frage dazu, wie kann denn das Forum, Status OK haben, mit schätzungsweise richtigen Versionen von

    Moderated User Groups, Legal Notice und Importer


    Wenn der Core das nicht richtig hat?


    Warum stört der Calender als "Hauseigene" App dabei die Seite mit einem update auf neu zu bringen?


    Das wäre mir jetzt so als Erstes mal aufgefallen, wieso der Core vom Forum unterschiedlich sein soll bei diesen Punkten?


    der Rest scheinen ja tatsächlich Drittanbieter-Plugins zu sein, die da ggf. keine Version haben


    kann man die oben erwähnten Pakete einzeln vor dem update nachziehen? Das zumindestens das Hauseigene erst mal alles so ist wie es soll?

    Hunde die bellen, beißen nicht? -> nun, ich bin kein Hund. -> Ich belle nicht. - Ich Beiße! 8o

    • Official Post

    Der manuelle Upload kann nicht für ein Upgrade verwendet werden, da ein Upgrade immer im Ganzen erfolgen muss. Die Fehlermeldung ist die Folge davon, dass nur ein Teil der Pakete aktualisiert werden soll - genau dies ist in diesem Fall aber gar nicht möglich. Lösung: Das automatische Update nutzen.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Warum stört der Calender als "Hauseigene" App dabei die Seite mit einem update auf neu zu bringen?

    Das ist zum Beispiel dann der Fall, wenn der Kalender in 3.0 vorliegt, für das Forum aber ein Upgrade auf 5.1 gekauft wurde. WoltLab will ja nicht, dass man den Kalender 3.0 in einem WSC 5.1 installieren kann bzw. ein Upgrade ohne Kauf aller Upgrades durchführen kann (auch wenn es technisch vermutlich möglich wäre).

  • der Rest scheinen ja tatsächlich Drittanbieter-Plugins zu sein, die da ggf. keine Version haben

    Zwei davon sind von mir und die sind mit bestehender Lizenz upgradefähig.

  • Zwei davon sind von mir und die sind mit bestehender Lizenz upgradefähig.

    das sollte auf keinen Fall ein Angriff sein, da stand geschrieben ggf. <- gegebenen Falls ;)

    Hunde die bellen, beißen nicht? -> nun, ich bin kein Hund. -> Ich belle nicht. - Ich Beiße! 8o

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!