Elasticsearch Typo

  • .de + .en (Letzte Sprachvariable)

    wcf.acp.rebuildData.elasticsearch.error.deletePlugin

    Beim Übersetzen stellte ich fest, daß es die URL zu Delete By Query API nicht mehr gibt:

    https://www.elastic.co/guide/e…gins-delete-by-query.html

    Es wurde durch die folgende URL ersetzt:

    https://www.elastic.co/guide/e…docs-delete-by-query.html

  • Dukemaster

    Changed the title of the thread from “wcf.acp.rebuildData.elasticsearch.error.deletePlugin - Elasticsearch Typo” to “Elasticsearch Typo”.
  • Woltlab Suite 3.x unterstützt, soweit ich weiß, nur den 5.x Release von Elasticsearch

    Danke für die Anmerkung. Ich wollte heute zum ersten Mal die 6.6 Version auf Server installieren und mich mit elasticsearch befassen, sprich testen. Weiss jetzt nicht welche Version und ob es überhaupt sinnvoll ist eine ältere Version draufzutun.

    Es wäre hilfreich wenn jemand von WoltLab etwas sagen würde, wenigstens peripher. Eine Nebenfrage wäre auch, ob und wann WoltLab versionstechnisch mitgeht. Denn es gibt einiges zu beachten, nicht nur bei der Installation, mehr noch bei den nicht wenigen Konfigurationsmöglichkeiten.


    Wen es interessiert:

    Habe eben die Übersetzungen von elasticsearch integration und LDAP-Authentifizierung online gestellt. Damit ist jetzt wirklich alles von WoltLab in spanisch und portugiesisch verfügbar. Die beiden neuesten Tools auch in polnisch.

  • Die Installation hat super funktioniert. Liest sich bei elastic schwerer als es ist.


    Der Spoiler ist nur temporär, den kopiere ich nachher wieder raus und lösche ihn dann.

    Habe hier grade keine Möglichkeit den Inhalt zu speichern.

    • Official Post

    Ich habe die Sprachvariable entfernt, das "Delete by Query"-Plugin wird nur für die Version für WCF 2.1 benötigt. Ab der WoltLab Suite 3 verwenden wir separate Indizes pro Typ, wodurch der gesamte Ablauf anders ist, so wird beispielsweise der gesamte Index gelöscht, anstatt wie bei WCF 2.1 die Dokumente zu löschen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!