Sitemaps kaputt?

  • Affected App
    WoltLab Suite Core

    Wenn ich die Sitemaps meines Forums versuche aufzurufen, bekomme ich im Backend den folgenden Fehler dazu ausgespuckt:


    Requested URL
    /sitemaps/sitemap.xml
    Referrer
    Error Message
    Call to a member function getRequestObject() on null
    Type
    Error
    File (Line)
    /var/www/vhosts/XXXX/httpdocs/lib/system/box/SEOTextBoxController.class.php (37)
    Stacktrace
    1. /var/www/vhosts/XXXX/httpdocs/core/lib/system/box/AbstractBoxController.class.php (51): wbb\system\box\SEOTextBoxController->loadContent(…)
    2. /var/www/vhosts/XXXX/httpdocs/core/lib/system/box/AbstractBoxController.class.php (63): wcf\system\box\AbstractBoxController->getContent(…)
    3. /var/www/vhosts/XXXX/httpdocs/core/lib/data/box/Box.class.php (278): wcf\system\box\AbstractBoxController->hasContent(…)
    4. [internal function] (?): wcf\data\box\Box->hasContent(…)
    5. /var/www/vhosts/XXXX/httpdocs/core/lib/data/DatabaseObjectDecorator.class.php (86): call_user_func_array(…)
    6. /var/www/vhosts/XXXX/httpdocs/core/lib/data/box/PhpBox.class.php (20): wcf\data\DatabaseObjectDecorator->__call(…)
    7. /var/www/vhosts/XXXX/httpdocs/core/templates/compiled/12_wcf_1_userException.php (4477): wcf\data\box\PhpBox->render(…)
    8. /var/www/vhosts/XXXX/httpdocs/core/lib/system/template/TemplateEngine.class.php (321): include(…)
    9. /var/www/vhosts/XXXX/httpdocs/core/lib/system/exception/NamedUserException.class.php (35): wcf\system\template\TemplateEngine->display(…)
    10. /var/www/vhosts/XXXX/httpdocs/core/lib/system/exception/IllegalLinkException.class.php (31): wcf\system\exception\NamedUserException->show(…)
    11. /var/www/vhosts/XXXX/httpdocs/core/lib/system/request/RequestHandler.class.php (99): wcf\system\exception\IllegalLinkException->show(…)
    12. /var/www/vhosts/XXXX/httpdocs/index.php (9): wcf\system\request\RequestHandler->handle(…)


    Jemand eine Idee?



    Betriebssystem

    Linux


    Webserver

    Apache


    PHP-Version

    7.2.13


    MySQL-Version

    10.0.37-MariaDB-0+deb8u1

    • Official Post

    Hallo,


    bitte an den Anbieter des oben genannten Plugins wenden ( Darkwood.Design). Dieser muss sein Plugin dementsprechend anpassen, sodass IlllegalLinkException (bzw. NamedUserException) korrekt behandelt wird und geprüft wird, ob RequestHandler::getInstance()->getActiveRequest() null zurück gibt.


    Zusätzlich dazu, Muschelschaf, rufst du die Sitemap augenscheinlich falsch auf. Der Link /sitemaps/sitemap.xml ist relativ zum WSC-Verzeichnis, nicht zum WSF (WoltLab Suite Forum) Verzeichnis.


    Grüße


    Josh

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!