Probleme mit PHP 7,2

  • Vor einigen Wochen hat unser Anbieter die PHP Version auf einen neueren Stand gebracht.

    Wir hatten glaub ich eine 5er Version.

    Der Sprung war dann auf 7.2

    Nach der Umstellung haben sich diverse User gemeldet, daß sie das Forum nicht mehr erreichen könnten.

    Bei mir selbst ging aber alles problemlos, so daß ich das gar nicht bemerkt hatte.

    Nach einigem Suchen hier im Forum hatte ich zumindest herausgefunden, daß ein Plugin evtl. dafür verantwortlich sein könnte.

    Allerdings konnte ich nicht rausfinden welches.

    Es wurden keine Fehler angezeigt, nur eine weiße Seite, daß das Netzwerk derzeit nicht erreichbar sei.

    Da ich nicht zurückstellen konnte auf die 5er Version, habe ich zumindest auf die Version zurückgestellt, die möglich war, das ist 7.0

    Damit lief alles wieder einwandfrei.

    Nun will der Anbieter im Dezember aber auch diese Version abschalten, dann ist 7.2 Pflicht.

    Dann wird also wieder das Problem bestehen, daß das Forum nicht erreichbar ist.

    Gibt es irgendeine Möglichkeit herauszufinden, welches Plugin es sein könnte?

    Kann man das irgendwie simulieren um den Fehler zu finden?

    Wie gesagt, habe keinerlei Fehlermeldungen oder so finden können.

    Würde das Problem am liebsten vor der Umstellung geklärt haben....

    Bitte gleich mal um Nachsicht, da ich nicht der Experte in diesen Angelegenheiten bin, aber einer muß sich ja kümmern...;)

  • Weiße Seiten sollten aber auch in den Fehlerlogs des Servers vermerkt sein. Im Zweifel musst Du Dir Hilfe von Anbieter holen, wenn Du selbst nicht "belesen" bist in den Logdateien. Hier wird Dir wahrscheinlich niemand ohne die Angaben aus den Logdateien helfen können.

  • A-WE

    Ich habe bei mir gerade mal getestet: 7.1.23 funktioniert bei mir

    Mit PHP 7.2 bekomme ich eine Fehlermeldung bzgl. EasyMedia.

    Steht im ACP im Fehlerprotokoll

    7.1.23 wird von meinem Provider bis 12/2019 unterstützt

  • Könnt ihr damit etwas anfangen?

  • PilloryPageMenuItemProvider.

    Muss irgendeine Art Pranger sein. Bitte klären, ob das Paket für die betriebene Version geeignet ist oder den Entwickler kontaktieren.


    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier und hier.

  • Da wir den Pranger zwar hatten, aber eigentlich niemals genutzt haben, habe ich die beiden Pakete dazu deinstalliert.

    Danach war unser Forum wieder einwandfrei zu erreichen.

    Scheint also erstmal alles an Fehlern gewesen zu sein.

    Sollte sich nix mehr zeigen, danke ich schon mal allen, die sich hier Mühe gemacht haben zu helfen...:thumbup:

  • Die Fehlermeldung Parameter must be an array or an object that implements Countable sagt relativ deutlich, dass eine Anpassung des Pakets an PHP 7.2 erforderlich ist. Ob Josh das macht, wird er selbst beantworten müssen.


    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier und hier.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!