Registration Issues (Can't Get Past Disclaimer Page)

  • Affected Version
    WoltLab Suite 3.1

    Hi guys,

    I'm doing some testing with my website:

    We are experiencing an issue with the Disclaimer page. We have the settings marked to force users to accept our disclaimer before registering and upon accepting the Disclaimer, it just refreshes itself. I was able to get past it once and have not been able to get past it again. Another use i'm testing the site with online is having the same issues. The disclaimer page is just refreshing itself.

    Any one have any ideas?


    Jonathan Weinberger

  • Did you try the obvious ? Clearing cache, trying a different browser, flushDNS etc

    Smile , it's good for health

  • Scratch that. It started working on it's own again, incognito mode doesnt load it now and flush dns etc does not solve the problem.

  • Cloudflare is know cause such issues due to its caching. See whether Cloudflare team has any opinion on the issue.

    Where is this image from ?

    f12 in chrome. -- network setting

    I found some articles similar to wordpress issues. I set up Page Rules and excluded Admin and /register /disclaimer from being included but still not working :(

  • I have set my name servers back to Hostgator. Deleted the website in Cloudflare. Need to make sure the registration page worked prior to Cloudflare.

  • I think Cloudflare has some options to remove cache. They do extensive caching from what I heard.

    Smile , it's good for health

  • I think Cloudflare has some options to remove cache. They do extensive caching from what I heard.

    So the DNS servers are now back on Hostgator. Clearing cache on my local machine, flushing DNS, and clearing cache on WoltLab. People are still experiencing issues including myself. It seems to be like 50/50. Some can get past the disclaimer and some can't.

  • I've spend some minutes debugging that behaviour remotely. Here are my observations.

    Generally you start at the main page by clicking on the "Register Yourself" button. Which will send a http request for /register. That will result in /register (302) --> /disclaimer (200). So far so good...

    Now you might or might not read the disclaimer. You will scroll down and hit the "Accept" button. Now there will be a POST request to /disclaimer (302) that redirects to /register (302) which again redirects back to /disclaimer (200).

    This issue occurs in more than 50% of the requests I made. And I think it is a configuration issue of your nginx server! It seems your nginx has a quite agressive caching policy.

    In all failing cases the request chain is: /disclaimer (302) -> /register (302) -> /disclaimer (200)

    If you look closely at the http headers you'll find that the second request /register will be answered with:

    Server: nginx/1.14.0

    X-Acc-Exp: 600

    X-Proxy-Cache: HIT

    Which means to me the FIRST request to /register WAS cached for 600 seconds. The first request to /register was that done via main page which correctly redirected to /disclaimer. But now you nginx will do so for the next 600 seconds.

    All you have to do is... just remain > 5 minutes on the disclaimer page and then hit the "Accept" button. This worked in 3 out of 3 tries. Excuse me that I only waited three times for 5 minutes... but it allways worked for me.

    Also if you've waited for more then 5 minutes the http header reports:

    Pragma: no-cache

    Server: nginx/1.14.0

    X-Acc-Exp: 0

    X-Proxy-Cache: EXPIRED

    But whenever I was faster then 5 minutes it fails (redirects back to /disclaimer). I don't know why it worked for you on a mobile? Perhaps your caching policy is different for mobile users?

  • Wow!! Thank you so much for taking the time to do this. I will contact my host provider and see if there’s anything I can do about limiting that wait time.

    Thank you again!! Will report back here with an update!

  • So, behavior is still sporadic. Sometimes it works for me and sometimes it doesn't. Same with individuals helping test. It's like 50/50 working. With that setting mentioned above, I'm on a shared cloud server, so they won't be able to adjust that setting.

    I'm now setting up AWS Webserver. I should be using that anyway. Will update once the website is transferred to that.

  • Switching to AWS has fixed this issue.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!