Sind die ganzen Woltlab Update Server offline?

  • Affected Version
    WoltLab Suite 3.1

    Habe gerade festgestellt, alle Woltlab Update Server sind offline.

    Letzter Zugriff 11.Juni 2018 Fehler, Paketliste konnte nicht abgerufen werden.

    So wird es in meinem ACP angezeigt.

    Auch die Server von Softcreatr und CLS Design hatten letzten Zugriff am 11.Juni 2018, sind aber als online gekennzeichnet und ohne Fehlermeldung.

  • Problem liegt bei Dir... die Server sind da... kannst'e glauben. Oft (nicht immer) hilft ein Restart der PHP-FPM-Pools, wenn PHP-FPM zum Einsatz kommt, wenn nicht, musste weiter suchen.

  • Das andere identische Forum zeigt die Woltlab Update Server grün, letzter Zugriff vor 22 Stunden.

    Dort wurde am 25.7. dieser Fehler im ACP protokolliert.

    Requested URL
    /index.php?categoryID=22&page=UserBlog&s=fcc3932b63c17ee2580b8225d4b0fff24730ed8c&userID=4909
    Referrer
    WoltLab Suite
    3.1.4
    PHP
    7.1.20
    Error Message
    Connecting to MySQL server 'localhost' failed
    Type
    wcf\system\database\exception\DatabaseException
    File (Line)
    /var/www/vhosts/xxxxxxx.de/httpdocs/lib/system/database/MySQLDatabase.class.php (65)
    Stacktrace
    1. /var/www/vhosts/xxxxxx.de/httpdocs/lib/system/database/Database.class.php (119): wcf\system\database\MySQLDatabase->connect(…)
    2. /var/www/vhosts/xxxxx.de/httpdocs/lib/system/WCF.class.php (359): wcf\system\database\Database->__construct(…)
    3. /var/www/vhosts/xxxxxxx.de/httpdocs/lib/system/WCF.class.php (164): wcf\system\WCF->initDB(…)
    4. /var/www/vhosts/xxxxxxx.de/httpdocs/global.php (13): wcf\system\WCF->__construct(…)
    5. /var/www/vhosts/xxxxxxx.de/httpdocs/index.php (8): require_once(…)
    Error Message
    SQLSTATE[HY000] [2002] No such file or directory
    Type
    PDOException
    File (Line)
    /var/www/vhosts/xxxxxxx.de/httpdocs/lib/system/database/MySQLDatabase.class.php (45)
    Stacktrace
    1. /var/www/vhosts/xxxxxxx.de/httpdocs/lib/system/database/MySQLDatabase.class.php (45): PDO->__construct(…)
    2. /var/www/vhosts/xxxxxx.de/httpdocs/lib/system/database/Database.class.php (119): wcf\system\database\MySQLDatabase->connect(…)
    3. /var/www/vhosts/xxxxxx.de/httpdocs/lib/system/WCF.class.php (359): wcf\system\database\Database->__construct(…)
    4. /var/www/vhosts/xxxxxxxx.de/httpdocs/lib/system/WCF.class.php (164): wcf\system\WCF->initDB(…)
    5. /var/www/vhosts/xxxxxxxx.de/httpdocs/global.php (13): wcf\system\WCF->__construct(…)
    6. /var/www/vhosts/xxxxxxx.de/httpdocs/index.php (8): require_once(…)

    Bei denen am 25.7. vorgekommen, ansonsten alles okay, Update Server funktionieren, Forum ist schnell.

    Bei mir im ACP wird dieser Fehler angezeigt.

    Requested URL
    /?form=Search
    Referrer
    WoltLab Suite
    3.1.3 pl 1
    PHP
    7.1.20
    Error Message
    Error while sending STMT_PREPARE packet. PID=13002
    Type
    wcf\system\exception\ErrorException
    File (Line)
    /var/www/vhosts/xxxxxxxx.de/httpdocs/wcf/lib/system/WCF.class.php (346)
    Stacktrace
    1. [internal function] (?): wcf\system\WCF::handleError(…)
    2. /var/www/vhosts/xxxxxxxxx.de/httpdocs/wcf/lib/system/database/Database.class.php (243): PDO->prepare(…)
    3. /var/www/vhosts/xxxxxxxxx.de/httpdocs/wcf/lib/data/easypoll/PollEditor.class.php (37): wcf\system\database\Database->prepareStatement(…)
    4. /var/www/vhosts/xxxxxxxx.de/httpdocs/wcf/lib/system/event/listener/EasyPollParserListener.class.php (66): wcf\data\easypoll\PollEditor::getLastPoll(…)
    5. /var/www/vhosts/xxxxxxxx.de/httpdocs/wcf/lib/system/event/EventHandler.class.php (144): wcf\system\event\listener\EasyPollParserListener->execute(…)
    6. /var/www/vhosts/xxxxxxxx.de/httpdocs/wcf/lib/system/event/EventHandler.class.php (177): wcf\system\event\EventHandler->executeInheritedActions(…)
    7. /var/www/vhosts/xxxxxxxx.de/httpdocs/wcf/lib/page/AbstractPage.class.php (141): wcf\system\event\EventHandler->fireAction(…)
    8. /var/www/vhosts/xxxxxxx.de/httpdocs/lib/page/BoardListPage.class.php (76): wcf\page\AbstractPage->assignVariables(…)
    9. /var/www/vhosts/xxxxxx.de/httpdocs/wcf/lib/page/AbstractPage.class.php (294): wbb\page\BoardListPage->assignVariables(…)
    10. /var/www/vhosts/xxxxxxx.de/httpdocs/wcf/lib/page/AbstractPage.class.php (114): wcf\page\AbstractPage->show(…)
    11. /var/www/vhosts/xxxxxxx.de/httpdocs/wcf/lib/system/request/Request.class.php (83): wcf\page\AbstractPage->__run(…)
    12. /var/www/vhosts/xxxxxx.de/httpdocs/wcf/lib/system/request/RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    13. /var/www/vhosts/xxxxxxxx.de/httpdocs/index.php (9): wcf\system\request\RequestHandler->handle(…)

    Mit der Fehlermeldung keine Woltlab Update Server, letzter Kontakt 11.Juni.

    Keine Ahnung was das bedeutet da oben, aber vielleicht ist was kaputt.

  • Hast du mal deine ausgehenden Firewall-Regeln geprüft?

    Übrigens ist es mir auch schonmal passiert, dass die Firewall von WoltLab meinen Server mal für paar Stunden ausgesperrt hat. Am nächsten Tag ging es wieder.

  • Hast du mal deine ausgehenden Firewall-Regeln geprüft?

    Übrigens ist es mir auch schonmal passiert, dass die Firewall von WoltLab meinen Server mal für paar Stunden ausgesperrt hat. Am nächsten Tag ging es wieder.

    Bei ihm sind aber die Paketserver von drei unterschiedlichen Anbietern offline, damit wird kaum eine Remote-Firewall sein. Die Hinweise deuten auf eine Verkorksung auf seiner Seite hin, sei es FPM-Pool, Firewall, Routing oder sonst was... auf jeden Fall wird die Lösung mit ziemlich hoher Wahrscheinlichkeit näher an seinem System liegen als sonst wo.

  • Bei ihm sind aber die Paketserver von drei unterschiedlichen Anbietern offline, damit wird kaum eine Remote-Firewall sein. Die Hinweise deuten auf eine Verkorksung auf seiner Seite hin, sei es FPM-Pool, Firewall, Routing oder sonst was... auf jeden Fall wird die Lösung mit ziemlich hoher Wahrscheinlichkeit näher an seinem System liegen als sonst wo.

    Sorry habe wieder nicht richtig gelesen ^^

  • Ich habe jetzt unter Paketliste nach Updates suchen gemacht.

    Von dem ewig langen Laden mal abgesehen, wurde Gallery von 3.1.3 auf 3.1.4 upgedatet

    Das Forum von 5.1.3pl1 auf 5.1.4

    Importer 3.1.3 auf 3.1.4

    Jetzt werden mir alle Woltlab Server als online angezeigt, nur https://update.woltlab.com ist weiter rot. Zeigt aber auch 0 Pakete an, schon immer.

    Als Fehler kommt.

    Code
    Beim letzten Verbindungsversuch trat folgender Fehler auf:
    Die Paketliste konnte nicht abgerufen werden (404)

    Nur das lange Laden bei jedem Aufruf im Forum ist immer noch da.

  • Problem liegt bei Dir... die Server sind da... kannst'e glauben. Oft (nicht immer) hilft ein Restart der PHP-FPM-Pools, wenn PHP-FPM zum Einsatz kommt, wenn nicht, musste weiter suchen.

    Mehrfach neu gestartet, FPM 7.1.20 hat sich nichts geändert.

    Gab keine Probleme, mehrfacher Start FPM ohne jedes Problem.

    Mein Forum lahmt immer noch, das andere nicht. Da beide Foren auf dem gleichen vServer sind mit identischen Einstellungen, keine Ahnung wo es dann noch hängen kann.

    Ganzer Server neu gestartet, kein Problem.

  • So ich habe jetzt umgestellt auf PHP 5.6.37 und FastCGI, es ist jetzt schneller, aber noch nicht so schnell wie früher, also vor einer Woche. Irgendwas muß durch Plesk installiert worden sein, letzte Woche bei den automatischen Updates.

    Nach der Umstellung jetzt auf ältere PHP Version und FastCGI haben wir jetzt nur noch etwa eine halbe Gedenkminute, statt einer ganzen.

    Besser als nichts.

    Noch nicht die Top Lösung, aber es ist eine.

  • Plesk hat vor kurzer Zeit viele PHP-Updates bekommen. Bei mir läuft mit allen Updates und 7.2.8 alles fehlerfrei. Und das auf Dedis und VPSen... Linuxe (CentOS) und sogar unter Windows :)

    Viele Grüsse aus Stuttgart, Kind Regards from Stuttgart
    TheSonic

  • Da hast Du Glück gehabt, unser Ubuntu 14.04.5 LTS mag das nicht. Plesk ist bei uns 17.0.17 Update 54, zuletzt aktualisiert 30.7. 2:50 Uhr

    Vergangene Woche Sonntag oder Montag muß das passiert sein. Ab Montag ist das den Nutzern aufgefallen, mit der Gedenkminute.

    Zusätzlich zur Umstellung auf die ältere Version habe ich von Localhost auf 127.0.0.1 umgestellt.

    Mehr fällt mir jetzt nicht ein.

  • 14.04 LTS läuft noch bis April 2019, ist also sehr wohl noch aktuell.

    Dafür haben wir es ja, bei Strato kann man das nicht im Betrieb aktualisieren. Da ist immer neuer Server fällig, bei vServern.

    Neue gibt es nur noch mit einer IPv4, unserer hat noch 2.

    Also bleiben wir vorerst noch da drauf.

  • 14.04 LTS läuft noch bis April 2019, ist also sehr wohl noch aktuell.

    Dafür haben wir es ja, bei Strato kann man das nicht im Betrieb aktualisieren. Da ist immer neuer Server fällig, bei vServern.

    Neue gibt es nur noch mit einer IPv4, unserer hat noch 2.

    Also bleiben wir vorerst noch da drauf.

    Du solltest mal zwischen aktuell und gerade noch supported differenzieren. Aktuell ist Ubuntu 20.04 LTS, Dein 14.04 ist gerade noch supported und kurz vor EoL. Gleiches gilt für ein Plesk... 17.8.x ist die aktuelle Version... 17.5.x und 17.0.x sind noch supported. Aktuell ist was anderes... ich könnte bei Deinem PHP 7.1.x weitermachen; über die von Dir sicher nicht aktuelle eingesetzte DB möchte ich erst gar nicht spekulieren.

    Dein System ist noch supported ja... gerade so. Aber Aktuell ist es sicher nicht.

    Einfach mal so in die WIndows-Welt übertragen, wäre nach Deiner Definition Windows7 noch aktuell... 8)

  • Ja ich nutze Win 7 Pro auf allen meinen Rechnern. Gibt auch keinen Grund für mich was anderes zu nehmen. Funktioniert alles was ich brauche, mein WIN XP Pro funktioniert auch noch.

    An der Arbeit gibt es auch noch WIN XP und NT.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!