Nur sichere Bilder erlaubt. Einfügen von unsicheren Bildern verhindern?

  • Affected Version
    WoltLab Suite 3.1

    Bei mir kann der IMG-BBCode weiterhin in Nachrichten und Signaturen verwendet werden. Allerdings habe ich eingestellt, dass nur sichere Bilder erlaubt sind. Unsichere Bilder werden also in Beiträgen nicht angezeigt. Oder anders gesagt, die Suite versucht, aus nicht sicheren Links sichere Links zu machen. Bei einigen Bildern klappt das, aber andere lassen sich über einen sicheren Link nicht anzeigen.


    Mir fiel nun allerdings auf, dass beim Erstellen eines Beitrags oder der Signatur im Editor eben diese unsicheren Bilder angezeigt werden, als wären die Links erlaubt.


    Beispiel:

    http://sig.sysprofile.de/quicksys/sysp-50075.png


    Füge ich das Bild über den Editor ein...



    ...wird das Bild ganz normal im Editor angezeigt.



    Erst nach dem Absenden des Beitrages wird das Bild nun nicht mehr angezeigt.



    Wie kann ich direkt schon beim Erstellen im Editor verhindern, dass Bilder aus unsicheren Quellen überhaupt erst angezeigt werden? Geht das?

  • Dann scheint diese ganze Funktion leider nicht wirklich optimal zu funktionieren... Was bringt es mir, wenn ich externe unsichere Bilder verbiete, sie aber trotzdem per Editor eingefügt werden können und der Beitrag dann hässlich aussieht? :/

  • Dann scheint diese ganze Funktion leider nicht wirklich optimal zu funktionieren... Was bringt es mir, wenn ich externe unsichere Bilder verbiete, sie aber trotzdem per Editor eingefügt werden können und der Beitrag dann hässlich aussieht? :/

    Können sie nicht. Der Editor zeigt nur eine falsche Vorschau an.


    Ist unschön, ja. Mach am besten einen Bugreport, dann kann sich das jemand ansehen.

    "A life is like a garden. Perfect moments can be had, but not preserved, except in memory. LLAP" — Leonard Nimoy

  • Hab ein ähnliches Problem, bei mir sind es aber Quellen die sehr wohl mit HTTPS anfangen.

    Trotzdem wird es im späteren Beitrag/Signatur nur folgend angezeigt:

    Projekte:

    XIVDATA - Eorzea Database


    A red dragon falls from the heavens... Ah, that memory has been lost. A shame. It was a favorite of mine...


  • Externe Bilder hast du aber zugelassen?

    Bis zu einem gewissen Zeitpunkt, hat es in einer anderen Installation auch funktioniert. Dachte erst es läge am Template, da es aber nun bei 2 Installationen der Fall ist.

    Projekte:

    XIVDATA - Eorzea Database


    A red dragon falls from the heavens... Ah, that memory has been lost. A shame. It was a favorite of mine...


  • Die Einbindung externer Inhalte wurde spätestens durch das Update zur DSGVO abgeschaltet. Die entsprechende Einstellung heißt „Bilder von externen Seiten erlauben. Aber bevor du externe Bilder wieder zulässt, solltest du erstmal deine Hausaufgaben machen, weshalb sie abgeschaltet wurden, und welche rechtlichen Voraussetzungen dafür bestehen, externe Dienstleister zu verwenden.

  • ... der zumindest urheberrechtlich ein Problem darstellen kann.

    Schon klar, aber in dem einem Forum wo er läuft, dürfte das kein Problem darstellen :).

    Da wir dort nur eigene Grafiken verwenden.

    Projekte:

    XIVDATA - Eorzea Database


    A red dragon falls from the heavens... Ah, that memory has been lost. A shame. It was a favorite of mine...


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!