Tägliche Fehlermeldungen seit Tagen

  • Affected Version
    WoltLab Suite 3.0

    Moin,

    ich hab seit Tagen, es ist mir erst später aufgefallen, protikollierte Fehlermeldungen.

    Erst hab ich an Hand der Browserkennung gedacht, das wären irgendwelche Bots oder Spammer. Dann hab ich folgende in den Fehlermeldungen angezeigte per Browserkennung ausgeschlossen und es gab keine Fehlermeldungen mehr. Oder hab ich damit Suchmaschinen-Roboter ausgesperrt?

    Mozilla/5.0 (compatible; Yahoo! Slurp; http://help.yahoo.com/help/us/ysearch/slurp)

    Mozilla/5.0 (compatible; AhrefsBot/5.2; +http://ahrefs.com/robot/)

    Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)

    Googlebot-Image/1.0

    Nun hab ich mal genauer geguckt und frage mich, ob das vielleicht am installierten SEO Plugin, wo ich aber noch keine Daten eingegeben habe liegen könnte?

    Requested URL
    /index.php/SearchResult/15676?highlight=
    Referrer
    WoltLab Suite
    3.0.11 pl 1
    PHP
    7.1.2
    Error Message
    Call to a member function getRequestObject() on null
    Type
    Error
    File (Line)
    /home/www/lib/system/box/SEOTextBoxController.class.php (37)
    Stacktrace
    1. /home/www/wcf/lib/system/box/AbstractBoxController.class.php (51): wbb\system\box\SEOTextBoxController->loadContent(…)
    2. /home/www/wcf/lib/system/box/AbstractBoxController.class.php (63): wcf\system\box\AbstractBoxController->getContent(…)
    3. /home/www/wcf/lib/data/box/Box.class.php (271): wcf\system\box\AbstractBoxController->hasContent(…)
    4. /home/www/wcf/lib/data/box/Box.class.php (256): wcf\data\box\Box->hasContent(…)
    5. /home/www/wcf/templates/compiled/16_wcf_1_userException.php (2489): wcf\data\box\Box->render(…)
    6. /home/www/wcf/lib/system/template/TemplateEngine.class.php (320): include(…)
    7. /home/www/wcf/lib/system/exception/NamedUserException.class.php (35): wcf\system\template\TemplateEngine->display(…)
    8. /home/www/wcf/lib/system/exception/IllegalLinkException.class.php (31): wcf\system\exception\NamedUserException->show(…)
    9. /home/www/wcf/lib/system/request/RequestHandler.class.php (97): wcf\system\exception\IllegalLinkException->show(…)
    10. /home/www/index.php (9): wcf\system\request\RequestHandler->handle(…)

    Wenn da jemand einen Tipp hätte wäre super.

    Gruß

    Herbert

  • Quote

    File: /home/www/lib/system/box/SEOTextBoxController.class.php (37)

    Bitte melde den Fehler beim Autor des Plugins. Solltest du nicht wissen von wem es ist, schaue bitte in die im Zitat erwähnte Datei, dort sollte der Entwickler vermerkt sein.

    Edit: Es sollte dieses sein:

    Darkwood.Design
    September 20, 2023 at 9:26 AM
  • Danke,

    das Plugin ist von Darkwood Studios, werd ich kontaktieren.

    Meine erste Frage, klemm ich mir mit der Aussperrung wichtige Suchmaschine-Roboter aus?

    Gruß

    Herbert

  • Meine erste Frage, klemm ich mir mit der Aussperrung wichtige Suchmaschine-Roboter aus?

    Wie willst du denn Suchmaschinen aussperren? Das geht u.a. nur über ein Plugin das explizit die Aussperrung vor nimmt oder auch über .HTACESS usw. Wahrscheinlicher ist, das der Inhalt deiner Box von Suchmaschinen nicht gelesen werden können, wenn du z.B. der Gruppen "Gästen" und "Jeder" verbietest diese Box zu sehen.

  • SoftCreatR Gut, das ist eine eindeutige Antwort, danke.

    Ich war nur unsicher weil auf der Benutzer-Online Seite nie eine Browserkennung bei den Suchmaschienen-Robotern zu sehen ist.

    Wie willst du denn Suchmaschinen aussperren?

    Ich hab vor 2 Tagen in der Blacklist die Browserkennungen ausgeschlossen und seit dem gab es keine Fehlermeldungen mehr. Aber jetzt mach ich das rückgängig.

    wenn du z.B. der Gruppen "Gästen" und "Jeder" verbietest diese Box zu sehen.

    Das hab ich nicht, alle dürfen sehen, es steht nur noch nichts drin.

    Gruß

    Herbert

    Edited 2 times, last by HTB (December 4, 2017 at 8:42 AM).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!