Gallery Suite keine Bilder nach import

  • Affected App
    WoltLab Suite Gallery

    Hallo WL,

    mit der Beta3 ist ja auch eine Betaversion von der neuen Galerie da.

    Diese habe ich mir dann auch gleich installiert.

    Und auch aus meinem aktiven System die Bilder importiert.

    Sie stehen auch in der Datenbank so wie sind sie im Verzeichnis UserImage der Galerie.

    Trotzdem werden die Bilder nicht angezeigt, das selbe Problem habe auch mit den Attachments.

  • Diesen Fehler bekomme ich beim Import von meinem anderen Forum in das Testforum.

  • Hab ich nach gesehen und es ist keine Log da.


    Die Kategorien legt er an aber alles andere eben nicht.

    Keine Bilder etc.

    Requested URL
    /cms/acp/index.php?worker-proxy/&t=7d99566f315d13b2a1785c333dcf5432bc6a7aa2
    Referrer
    https://beta.tourneo-forum.de/cms/acp/index.php?data-import/
    WoltLab Suite
    3.1.0 Beta 3
    PHP
    7.1.1
    Error Message
    Could not execute statement 'INSERT INTO gallery1_image_marker (imageID,positionX,positionY,userID,description,markerID) VALUES (?,?,?,?,?,?)'
    Type
    wcf\system\database\exception\DatabaseQueryExecutionException
    File (Line)
    /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/database/statement/PreparedStatement.class.php (105)
    Query Parameter 1
    null
    Query Parameter 2
    860
    Query Parameter 3
    380
    Query Parameter 4
    null
    Query Parameter 5
    'Rostblase...'
    Query Parameter 6
    1
    Stacktrace
    1. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/data/DatabaseObjectEditor.class.php (36): wcf\system\database\statement\PreparedStatement->execute(…)
    2. /var/www/virtual/tourneo-forum.de/beta/htdocs/gallery/lib/system/importer/ImageMarkerImporter.class.php (39): wcf\data\DatabaseObjectEditor::create(…)
    3. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/exporter/WBB4xExporter.class.php (1953): gallery\system\importer\ImageMarkerImporter->import(…)
    4. [internal function] (?): wcf\system\exporter\WBB4xExporter->exportGalleryImageMarkers(…)
    5. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/exporter/AbstractExporter.class.php (152): call_user_func(…)
    6. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/worker/ImportWorker.class.php (95): wcf\system\exporter\AbstractExporter->exportData(…)
    7. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/acp/action/WorkerProxyAction.class.php (92): wcf\system\worker\ImportWorker->execute(…)
    8. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/action/AbstractAction.class.php (47): wcf\acp\action\WorkerProxyAction->execute(…)
    9. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/action/AJAXInvokeAction.class.php (63): wcf\action\AbstractAction->__run(…)
    10. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/request/Request.class.php (83): wcf\action\AJAXInvokeAction->__run(…)
    11. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/request/RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    12. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/acp/index.php (9): wcf\system\request\RequestHandler->handle(…)
    Error Message
    SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'imageID' cannot be null
    Type
    PDOException
    File (Line)
    /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/database/statement/PreparedStatement.class.php (93)
    Stacktrace
    1. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/database/statement/PreparedStatement.class.php (93): PDOStatement->execute(…)
    2. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/data/DatabaseObjectEditor.class.php (36): wcf\system\database\statement\PreparedStatement->execute(…)
    3. /var/www/virtual/tourneo-forum.de/beta/htdocs/gallery/lib/system/importer/ImageMarkerImporter.class.php (39): wcf\data\DatabaseObjectEditor::create(…)
    4. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/exporter/WBB4xExporter.class.php (1953): gallery\system\importer\ImageMarkerImporter->import(…)
    5. [internal function] (?): wcf\system\exporter\WBB4xExporter->exportGalleryImageMarkers(…)
    6. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/exporter/AbstractExporter.class.php (152): call_user_func(…)
    7. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/worker/ImportWorker.class.php (95): wcf\system\exporter\AbstractExporter->exportData(…)
    8. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/acp/action/WorkerProxyAction.class.php (92): wcf\system\worker\ImportWorker->execute(…)
    9. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/action/AbstractAction.class.php (47): wcf\acp\action\WorkerProxyAction->execute(…)
    10. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/action/AJAXInvokeAction.class.php (63): wcf\action\AbstractAction->__run(…)
    11. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/request/Request.class.php (83): wcf\action\AJAXInvokeAction->__run(…)
    12. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/lib/system/request/RequestHandler.class.php (96): wcf\system\request\Request->execute(…)
    13. /var/www/virtual/tourneo-forum.de/beta/htdocs/cms/acp/index.php (9): wcf\system\request\RequestHandler->handle(…)

    So noch mal Probiert um zu testen ob er jetzt eine Log anlegt.

  • Hallo Matthias,

    habe letzte Woche gleiche(n) Fehler reproduziert und irgendwo hatte ich auch schon dokumentiert, jedoch nur nebenbei in anderem Thread nicht als eigenständige Fehler-Meldung, nämlich daß der Image Marker immer wieder einen Abbruch mit Endlosschleife erzeugt.

    Umgebung:

    BurningBoard + Blog + Galerie + Kalender meines hiesigen 3.0.0pl11 Produktivsystems in eine neu-installierte 3.1.0 Beta 3 per ACP-Datenimportfunktion zu importieren.

    Unterschied zum Import vom Themenersteller Harald Nigg :

    Die realen Bilder (+Anhänge+Avatare+Smileys) hatte ich zum Zeitpunkt des Import-Tests noch nicht in die neue Installation kopiert/verschoben gehabt.

    Denn ich wusste zu dem Zeitpunkt auch noch nicht, daß die reale Existenz der Bilder beim Import abgefragt wird. Das hat Alexander Ebert danach erklärt.

    Gruß

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!