Editor erzeugt nach jeder Überschrift einen Pseudo-Absatz

  • Affected App
    WoltLab Suite Core

    Hallo!


    Es gab seit dem Redactor schon immer wieder Fehlermeldungen wegen aller möglicher Leerzeilen, wenn ich nicht irre. Dabei habe ich schon etwas den Überblick verloren. Aktuell verwende ich die Suite in Version 3.0.9 und habe (schon seit langem) weiterhin folgenden Fehler:


    Nach jeder Überschrift <h2>Überschrift</h2>wird im Quelltext ein <p></p> beim Absenden des Foren-Beitrags erzeugt. Im Forum ist mir dies noch relativ egal, aber identisch passiert es auch im Lexikon. Bei jedem erneuten Speichern/Absenden des Beitrags wird eine weitere Pseudo-Leerzeile darunter eingefügt, so dass man mit der Zeit massenweise dieser <p></p> im Quelltext der Beiträge hat. Bei der Anzeige werden diese vom System unterdrückt, aber im Quellcode-Modus sieht man sie und sie blähen den Quellcode unnötig auf. Außerdem stören diese Pseudo-Leerzeilen extrem beim Versionsvergleich von älteren und neueren Versionen der Lexikon-Artikel.


    Dieser Fehler tritt bei allen <h2>,<h3,<h4> ... Überschriften auf.


    Beispiel vor dem Absenden:

    Beispiel nach dem ersten Senden:

    Beispiel nach dem erneuten Bearbeiten und Senden:

    Gruß aus Südhessen

  • Bei der Anzeige werden diese vom System unterdrückt

    Da muss ich mich nochmal korrigieren bzw. genauer ausdrücken. Das WSC unterdrückt da gar nichts. Die <p></p> werden alle mit dem HTML mit ausgegeben. Erst die Webbrowser ignorieren die Zeilen und machen keine echten (und somit bei 10 Stück hintereinander dann riesige) Absätze bei der Anzeige daraus.

    Gruß aus Südhessen

  • Das passiert schon seit Ewigkeiten und in allen Apps (z.B. auch in der Filebase). Teilweise habe ich da 50x diese Absätze hintereinander, je nachdem wie oft ein Eintrag bearbeitet worden ist. Ich dachte, das muss so... :/

  • Ich dachte, das muss so...

    Wenn da meinetwegen immer ein <p></p> stehen würde, könnte ich damit leben. Aber bei einem Lexikon-Eintrag, der zigfach bearbeitet wird, möchte ich nicht unter jeder Überschrift oder sonst wo jedesmal 20 ... 30 ... dieser Pseudo-Absätze stehen haben. Und wie oben schon gesagt: Es stört da halt auch den Versionsvergleich und somit das Arbeiten mit dem System. Da denke ich mit Wehmut an MediaWiki zurück.

    Gruß aus Südhessen

  • Das identische Problem tritt jetzt noch bei <pre> Elementen auf - sorry, dass ich dies nicht gleich berichtet hatte.


    Soll ich dafür einen weiteren Thread anlegen?

    Gruß aus Südhessen

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!