FontAwesome 5 Support

  • App
    WoltLab Suite Core

    Momentan wird die Version 5 von FontAwesome entwickelt, es soll aber noch in diesem Monat die finale Version geben. Eventuell wäre das ja, da bislang noch kein Feature-Freeze herrscht, noch etwas für die 3.1 Version von WSC?

    Quote

    Hoo boy. Last Friday we released Font Awesome 5 Beta 7. It's awesome:

    • Easy upgrades. We just finished full icon parity to easily upgrade from 4 to 5 with our shim file. No muss, no fuss.
    • 2,148 icons. That's up from 675 icons in v4. They're spread across 3 styles (solid, regular, and light). Our best icons ever.

    We're finishing up the last bits of version 5 and are expecting to release before the end of this month!

  • Während der Kickstarter-Phase wurde dazu gesagt, dass FontAwesome 5 Free zu den gleichen Konditionen kostenfrei und Open Source bleiben soll, wie auch die aktuelle 4er. Steht auch in abgespecktee Version in der FAQ, mal sehen.

  • Gibts eigentlich schon mal so nen kleiner vergleich FA4 vs FA5 ?

    Also paar Icons mal nebeneinander, hab leider keine Lizenz gekauft bei der kickstarter kampagne :/

  • Bleiben die Klassennamen gleich?

    Nein, die ändern sich. Es fallen z.B. alle -o weg So wir dann aus star-o z.B. star

    Laut FA soll ein Wechsel von 4 auf 5 problemlos durchführbar sein.

    Wobei das so ganz problemlos laut dem was ich bei Github bisher gelesen habe unter Umständen dann doch nicht funktioniert. Zumindest, wenn man nicht (nur) mit den Klassen gearbeitet hat, sondern über CSS/JS die Werte dynamisch zugewiesen hat.

    Aze Discord ist dabei

  • Es würde mich brennend interessieren, ob sie es endlich geschafft haben, ein TS³ sowie ein Discord Icon zu implementieren.

    Discord ja, TeamSpeak wenn ich im richtigen Ordner geschaut habe nicht, nein.

    Einen Vergleich gibt es meine ich nicht direkt, man kann auf der Webseite paar Beispiele sehen wenn man etwas weiter unten auf den Button "Psst! Check out a sneak peek of some icons." klickt.

  • Es spricht ja nichts dagegen die pro Icons einzubinden und beliebig zu verwenden. Die Icons der Standardsoftware werden allerdings durch die Free schon zu 100% abgedeckt. Pro benötigt man also nur für spezielle Anwendungsfälle.

    Entwicklung und Design moderner Webapplikationen

    kostenloser Support • Vorschläge teilen • Plugins kaufen

    Darkwood.Design

  • Eine Umsetzung für 3.1 wird es aus technischen Gründen nicht geben, insbesondere ist FontAwesome 5 in der Benutzung nicht abwärtskompatibel und würde daher umfangreiche Anpassungen erfordern. Dies ist insbesondere im Hinblick auf die angestrebte Abwärtskompatibilität zu 3.0 für uns nicht akzeptabel, auch sehe ich aktuell keine belastbare Lösung die kurzfristig umgesetzt werden kann.

    Die genauen technischen Hintergründe habe ich auf GitHub im Issue #2496 (auf Englisch) dargelegt.

    Eine Unterstützung von FontAwesome 5 in zukünftigen Versionen schließe ich an dieser Stelle explizit nicht aus. Lediglich für die Version 3.1 wird es keine Änderung in dieser Richtung geben.

    Alexander Ebert
    Senior Developer WoltLab® GmbH

  • Alexander Ebert December 10, 2017 at 8:53 PM

    Added the Label Won’t be implemented
  • Wann auch immer eine neuere oder andere Variante implementiert wird, wäre es gut, dass dann die bisher verwendeten Icons nicht plötzlich aus den alten Beiträgen und Artikeln verschwinden. Somit würde ich dann eine parallele Implementierung wünschen.

    Gruß aus Südhessen

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!