WBB 3.18 Gallery Bilder in WBB 4.1.11 Gallery Importieren

  • Hallo,

    Was mach ich falsch.

    Ich möchte meine WBB3 Gallery Bilder in die Neue Version WBB4 importieren,die Beide Datenbanken liegen beim gleichen Hoster.
    Ich hab den Importer benutzt und dort alle Benutzer und Gallerybilder ausgewählt,dann die Daten der alter Datenbank (Wbb3xxx)eingegeben mit Passwort.
    Er Läuft auch soweit durch,nur sind keine Bilder oder Alber oder sonst was in der Gallery (WBB4) zu sehen.
    Ich hab nach dem Import auch alles aktualisiert

    Was mach ich falsch...bzw was hab ich vergessen. ?( ;(

  • Hallo,

    Ich habe beide Foren beim gleichen Hoster und hab dann den importer benutzt ist doch soweit richtig oder nicht.
    Jetzt möchte ich die Gallerybilder von der alten WBB3 in die Neue WBB4 Gallery übertragen und dort steht doch das ich die Datenbanknamen und Passwort eingeben muß was ich auch gemacht habe,was also hab ich falsch gemacht, wie bekomme ich die Bilder in die Neue Gallery rüber.

  • Hallo, das ist soweit richtig. Nur der Datenpfad muss auch angegeben werden und es müssen auch Daten vorhanden sein (nicht nur Datenbank).

    Wenn Du den genauen Pfad nicht kennst, wo die Daten vom alten Forum liegen, dann verwende das:
    Datenimport mit Burning Board 4

    Anhang herunterladen, entpacken und ins alte Forum per Ftp hochladen und über den Browser aufrufen. Dann hast Du den Pfad zur Installation.

  • Hallo,
    danke für deine Antwort auf meine Frage.
    Also wenn ich mein FTP starte sind beide Foren dort zu sehen,die alte und die Neue.Ich hab ja schon einmal den Importer benutzt um alle User usw.ins Neue WBB4 zu bekommen soweit so gut,nur weiß ich nicht genau was ich mit den Bildern genau machen soll muß ich im importer jetzt noch extra ein Pfad mit eingeben,dachte es würde so langen wenn beide Foren im Root liegen.

    Also ich hab nochmal alles geprüft..
    Datei-System-Zugang
    im Importer steht der Pfad der Neuen WBB4 drinne (Pfad zur Installation /www/htdocs/w*******/Forumname/)

    Der alte Pfad WBB3 ist genau der gleiche nur halt der Forumname ist ein andere

    Und mit Pfad.zip hab ich genau diesen Pfad

    Muß ich beim importer unter Datei-System-Zugang Pfad zur Installation
    den alten Pfad von WBB3 eingeben,oder den Neuen der jetzt schon drinne steht wenn ich den importer starte..

    Bei Datenquelle hab ich im Importer Burning Board 3.1.x gewählt..

    Endlich ich hab's jetzt.

    Es müssen die alten Daten vom Forum & Datenbank drinne stehen,und natürlich auch der alte Pfad wenn die Foren beim gleichen Hoster liegen.
    Ich hab den Fehler gemacht das im Importer der vorgegebenen Pfad vom Neuen WBB4 schon drinne stand,der hätte nur geändert werden müssen.

    Danke an T1NO für deine Hilfe.

    Edited 2 times, last by DER DUKE (October 9, 2016 at 8:32 PM).

  • Moin ihr alle,

    ich hab leider jetzt erst sehen können das etwas in der Wbb4 Gallery nicht stimmt.Die Bilder wurden mit dem importer jetzt vom alten ins Neue WBB4 übertragen aber wenn ich auf die Bilder klicke dann kommt diese Meldung.

    Fatal error: Call to a member function getAvatar() on null in /www/htdocs/w0253da8/Forumxxx/gallery/lib/data/album/AlbumAction.class.php on line 327

    Kann mir einer von euch bitte sagen was ich da machen kann.

    Danke

  • Beim Import von wbb3 nach wbb4 wird alles übernommen, DB, Avatare und Dateianhänge, nur nicht die Bilder aus der Gallerie.

    Die Galeriebilder des wbb3 Forums liegen im Ordner http://www.neuesforum.de\wbb3\wcf\images\photos

    Der Pfad http://www.neuesforum.de\wbb3\ verweist auf das wbb3 Forum.

    Wbb4 liegt direkt unter http://www.neuesforum.de

    Die Photos sollten doch im neuen Ordner gallery landen?

    Sowohl der Unterordner userImages als auch images ist jedoch leer.

  • Ok, ich beantworte mal meine Frage selber:

    Zum exportieren muss im alten Forum die Version 1.1.3 unserer Community Gallery installiert sein. Nur aus der Version ist hinterher der Import in die WoltLab Gallery 2.x möglich.

    Ursache erkannt, nur finde ich unter mein Konto nicht mehr die Version 1.1.3

    Über die Update Funktion bekomme ich einen Fehler.

    Quote

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

  • nur finde ich unter mein Konto nicht mehr die Version 1.1.3

    Die Galerie in der Version 1.1.3 gehört zur Softwaregeneration WCF1.1/WBB3.1. Die Unterstützung für diese Versionsreihe wurde vor kurzem eingestellt und die Downloads aus dem Kundenbereich entfernt. Wende Dich bitte mit Deinem Problem direkt an die Kundenbetreuung in der Hoffnung darauf, dass man Dir die benötigte Version unbürokratisch zur Verfügung stellt.


    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier und hier.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!