Alle User haben die IP 127.0.0.1

  • Hallo zusammen,


    es geht um www.chaos-linie.de


    Dienstag gabs einen Serverumzug.
    Jetzt haben alle User die IP 127.0.0.1 (sieht man in der Wer ist wo online Liste) und wir fragen uns die ganze Zeit, warum der Multihunter Alarm schlägt. LOL.
    Das haben wir jetzt eben erst gesehen.


    Wie gibt man denen denn die normale IP wieder?


    Liebe Grüße,
    Zero :)

  • Gegenfrage: Welche Manipulation Eurerseits (incl. eventueller Plugininstallationen) könnte dafür verantwortlich sein?





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Hallo norse,


    also der Multihunter arbeitet ja mit IP Adressen und so, aber er verändert doch nicht die IPs, oder?
    Dann habe ich nochmal gesucht, da stand von SoftCreatR, dass bei einem Plugin von ihm die User eine 127.0.0.1. IP bekommen, wenn sie manuell angelegt wurden. Jedoch sehe ich da kein IP Plugin von ihm.


    Ich hänge mal die Paketliste an. Vielleicht bin ich auch blind?


    • Official Post

    Die wahrscheinlichste Ursache: Es wird eine Reverse-Proxy eingesetzt (z.B. nginx vor einem Apache) und Apache ist nicht ausreichend konfiguriert um die Original-IP-Adressen der Besucher durchzureichen. Sollte dieser Fall zutreffend sein, solltest du dich an deinen Anbieter werden, denn nur der kann dies im Zweifel korrigieren.

  • Wird eventuell ein Reverse-Proxy (Apache2 / Nginx) eingesetzt?
    Ggf. ist dieser inkorrekt konfiguriert, sprich er "reicht" die Besucher-IP nicht korrekt an den Webserver weiter.


    Wende dich am besten an deinen Anbieter.


    E: @Alexander Ebert war schneller. :D

  • @Alexander Ebert Per Email habe ich jetzt eine Antwort erhalten. Einen Teil der Email poste ich hier rein:


    "Es handelt sich hierbei nicht um ein Reverse Proxy Problem sondern um ein Abfrage Problem der IP Adresse.

    Seit dem Serverupdate wird in der PHP.ini nicht mehr nach der REMOTE_ADRESS abgefragt. Hierfür wird ein neues Servermodul mod_remoteip benötigt.


    Bis dieses Update durchgeführt wird, kann es noch sehr lange dauern.


    Fragen Sie bitte bei Woltlab nach ob nach einem anderen verfahren, nämlich


    HTTP_X_REAL_IP
    HTTP_X_FORWARDED_FOR


    abgefragt werden kann, dann werden auch die tatsächlichen IP's abgefragt.


    Das können Sie gerne so an Woltlab weitergeben."


    Soll ich da ein Ticket für eröffnen?

    • Official Post

    Diese beiden Header sind uns bekannt, werden aber absichtlich nicht berücksichtigt da sie sich auf Servern ohne Reverse-Proxy zum fälschen der IP-Adresse eigenen.


    Mit der php.ini hat dies im übrigen überhaupt nichts zu tun, das ist eine reine Sache des Webservers, da hilft dann nur warten.

  • auch wenn es schon 4 Wochen her ist, würde ich da gerne einmal einhaken:
    welcher webhoster ist das, der hier verwendet wird? Wir sind bei HostEurope und seit einer Wartung bei denen haben wir ähnliche Probleme.
    Zum einen auch das mit der selben IP und aber noch ein weiteres:
    Durch diese 127.0.0.1 IP Vergabe kommen einige des öfteren nicht ins forum. Ursache: Irgendwelche "Spammer" versuchen sich einzuloggen und werden
    dann im Protokoll für fehlgeschlagene Anmeldungen gelistet.
    Wenn dabei aber vom System festgestellt wird, daß die IP zuviele gültige Anmeldeversuche unternommen hat, werden die "guten" user erstmal für die eingestellte Zeit ausgesperrt....
    Was kann man da tun, außer die Schwelle entsprechend hoch zu setzen?

  • Wenn ihr mir einen FTP-Zugang zu den betroffenen Foren zur Verfügung stellt, kann ich mir das gerne anschauen und ggf. beheben.

  • Hallo zusammen


    hänge mich mal hier mit rein.
    Auch wir haben im Forum das gleiche Problem, gleicher Hoster.
    Laut einer Mail ist man auch nicht Willens etwas zu ändern. :( :(
    Was mich interessiert, kann man das abstellen und wenn ja, wo?

    mit freundlichem Gruss



    Uli

  • SoftCreatR: hab dir eine Nachricht geschickt mit entsprechenden Daten....


    Hatte natürlich auch bei HostEurope nachgefragt und ebenfalls leider nur unnütze Antworten bekommen, finden keinen Fehler, alles sei gut...

  • Ich werde Morgen mit den Kollegen bei Host Europe über das Problem sprechen, da ich es reproduzieren konnte und eine Behebung nur bedingt möglich ist. Zudem sollte es nicht Sache des Kunden sein, sich um die Behebung zu bemühen.

  • @All


    Nach Rücksprache mit meinen Kollegen wird es bei Host Europe diese Woche noch einen Fix geben. Es handelt sich hierbei scheinbar um einen Bug im Apache2-Modul rpaf.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!