über htaccess Domain-Weiterleitungen einrichten. Wie mache ich das?

  • Hallo,


    Ich möchte einerseits das psychoseforum.de auf www. psychoseforum.de weitergeleitet wird, über die htaccess und zusätzlich möchte ich das die www und nicht www psychoseforum.com und psych-forum.de auf die www. psychoseforum.de Adresse weitergleitet wird.


    Macht es Sinn das über die htaccess Datei einzurichten? Derzeit funktionieren zwar und man kommt über die beiden Domains bei meiner Hauptdomain an, aber wenn man es über die htaccessdatei normal lösen sollte damit die Weiterleitungen richtig funktionieren und SEO freundlich sind würde ich das gerne richtigstellen.


    Meine derzeitige htaccess Datei ist diese hier, für die SEO-Linkumschreibung.

    Code
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    	RewriteRule ^index.php/(.*) index.php?$1 [L,QSA]
    	RewriteCond %{REQUEST_FILENAME} !-f
    	RewriteCond %{REQUEST_FILENAME} !-d
    	RewriteRule ^(.*)$ index.php?$1 [L,QSA]
    </IfModule>

    Vielleicht könnt ihr mir da weiterhelfen wie ich das bewerkstelligen kann und am besten die htaccess Datei umschreibe.


    Gruß

  • zusätzlich möchte ich das die www und nicht www psychoseforum.com und psych-forum.de auf die www. psychoseforum.de Adresse weitergleitet wird.

    Code: .htaccess
    Redirect 301 / http://www.psychoseforum.de/

    Die .htaccess einfach in jeden Domainordner. Eventuell kannst Du aber auch beim Domainhoster eine Umleitung einstellen.

  • Danke,
    das funktioniert im Grunde schon, also die Umleitung habe ich über den Hoster direkt drin und man kommt auch immer auf der www. Hauptdomain heraus. Dachte nur das man in die .htaccess bei der Hauptdomain etwas reinschreiben muss damit das für die Suchmaschiene eindeutig ist etwa von kein (www) zu www. und von den einzelnen Domain Adressen hin zur Hauptdomain. Damit das darin festgelegt wird. Ich dachte vielleicht schreibt das später dann die Forensoftware noch um weil man da ja bei den einzelnen Anwendungen die Seitenadresse angibt.


    Also ob man das schon vorher machen kann damit gleich die psychoseforum.de Domain mit www. ankommt nach der htaccess


    Hier der Fehler:

  • Habe eine Lösung gefunden.


    Zeile 3 und 4 hinzugefügt. Jetzt leitet er alles was ungleich meiner Hauptdomain ist auf die Hauptdomain weiter und gibt bei den ungleichen Domains den Statuscode 301 zurück den die Suchmaschine benötigt.


    Sieht zumindest gut aus.


    Apache Configuration: .htaccess
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    	Rewritecond %{HTTP_HOST} !^www.psychoseforum.de
    	RewriteRule (.*) http://www.psychoseforum.de/$1 [R=301,L]
    	RewriteRule ^index.php/(.*) index.php?$1 [L,QSA]
    	RewriteCond %{REQUEST_FILENAME} !-f
    	RewriteCond %{REQUEST_FILENAME} !-d
    	RewriteRule ^(.*)$ index.php?$1 [L,QSA]
    </IfModule>


    Hier die Beschreibung dazu:
    http://www.jinsiders.de/www-er…sseres-google-ranking/172

  • An der Stelle möchte ich mich nochmal einhaken.


    Möchte gerne alle Links auf https umleiten



    Also


    Code
    http://webseite
    http://www.
    https://www


    auf


    Code
    https://webseite


    Ich habe im Netz bestimmt schon 10 Versioneb durchprobiert... Über Portprüfungen und vielen anderen Kram, es kommt aber immer zu einem "Umleitungsfehler.... wird so aufgerufen, dass die Anfrage nicht beendet werden kann"


    Gebe ich stattdessen direkt https in die URL ein, geht es. Verstehe es nicht.

    Code
    http://webseite
    http://www.
    https://www
  • @Jan.D Kann man mit dem A-Record auch den Status 301 zurückgeben? Das ist auch wichtig und muss die Suchmaschine wissen um ausschließlich die Hauptdomain zu indexieren, vorher wurde bei mir der Status 307 zurückgegeben wie oben im Bild, nun 301 wie im Rewrite Befehl angegeben.


    Kenne mich da mit dem A-Record nicht weiter aus, wie das geht und ob da auch die Statusmeldung 301 unterstützt wird. Könntest du das erklären ob und wie das funktiert?




    @Muschelschaf ich möchte das mit der "https" später auch einrichten vielleicht funktioniert es wenn du es so machst:
    https://www.domain-frage.de/ss…1-weiterleitung-htaccess/


    Diese 2 Zeilen direkt nach der "RewriteEngine On" Zeile einfügen:

    Code
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]


    dann müsste es anhand meiner .htaccess Datei so aussehen:



    In der Zeile 5-6 müsstest du wenn du es so übernimmst, deinen Domainnamen einfügen. Das ist aber für die neue SEO Linkumschreibung die man vorher eingerichtet haben muss. Ansonnsten reichen die oberen Beiden Zeilen nach "RewriteEngine On" normal aus.


    @Muschelschaf, was auch sein könnte ist das du Serverseitig den Rewrite Modus abgeschalten hast.(also Rewritemodus beim Hostanbieter einschalten) Das war bei mir auch so standardmäßig abgeschalten und musste bei den Administrationseinstellungen des Servers erst eingestellt werden. Kann also sein das du deinen Server erst richtig konfigurieren musst und es daran liegt?


    Das Problem hatte ich etwa als ich die neue Linkumschreibung einrichten wollte nach dieser Anleitung: Konfiguration von benutzerfreundlichen URLs (SEO-URLs)


    Klappt also nur wenn der Server richtig konfiguriert ist und vielleicht liegt es bei dir auch an so etwas.


    Gruß

  • Kenne mich da mit dem A-Record nicht weiter aus, wie das geht und ob da auch die Statusmeldung 301 unterstützt wird. Könntest du das erklären ob und wie das funktiert?

    Mir ist kein Nachteil bekannt. Gut, wenn man konstruieren wollen würde, dann gäbe es durch die IP-Weiterleitung doppelten Content.


    Beispiel:


    Besucher ruft einen deiner nicht Hauptdomains auf und du machst einen A-Record - dann wird die "Adresse" quasi auf den Inhalt gespiegelt. Heißt:
    psych-forum.de wird auf psychoseforum.de weitergeleitet, die Adresse in der Browserzeile bleibt psych-forum.de

  • Funktioniert leider nicht :) Bekomme wieder den Umleitungsfehler.


    Meine Datei sieht wie folgt aus, ###### markiert die von dir genannte Stelle - Mod-Rewrite ist aktiviert, ist ein eigener Server



  • Hi @Muschelschaf,


    bin ja leider kein erfahrener Programmierer, ich hoffe es mischen sich vielleicht mal ein paar User ein die sich etwas besser auskennen ;)


    Quote

    Linie 1: <IfModule mod_rewrite.c>
    Mit diesem Befehl wird einfach sichergestellt, dass das Modul: mod_rewrite auf dem Apache Server geladen wird.


    Versuch mal die Rewrite Befehle damit einzuklammern, damit sichergestellt ist das dieser Rewrite Modus auch geladen wird.


    Nach diesem Schema würde ich das machen:


    Apache Configuration: .htaccess
    ... (alles vor "RewriteEngine on")
    <IfModule mod_rewrite.c>
    RewriteEngine on
    ... (Rewrite Befehle)
    </IfModule>



    Vielleicht klappt es damit.



    Bei mir gibt es Serverseitig vom Hoster auch eine Einstellmöglichkeit bei der man die Domain auf von http auf https leiten kann und SSL einschalten kann. Vielleicht muss diese Option Aktiviert oder Deaktiviert sein damit kein Umleitungsfehler passiert. Vielleicht darf die Umleitung nur einmal entweder in der .htaccess oder beim Serverhost vorgenommen werden oder an beiden Stellen eingeschaltet sein. Vielleicht auch da mal probieren und nach den Einstellmöglichkeiten schauen.


    Den anderen Teil deiner htaccess Datei verstehe ich nicht, wofür das genau notwendig ist und was damit gemacht wird? Könnte ja sein das auch da ein Fehler entsteht und du das anders besser lösen könntest?


    oder du probierst auch das mal indem du die Befehle mit http zu https machst in den Folgezeilen und Eventuell auch bei den Befehlen [HTTP_HOST] dann mit [HTTPS_HOST] bei den Folgezeilen nach der Weiterleitung auf HTTPS!



    Das wäre für meine .htaccess bei deiner wären es dann normal 8 Änderungen wo du das "s" oder "S" ergänzen müsstest nach der Weiterleitung auf HTTPS, erst nach den zwei Befehlszeilen (Zeile 3 und 4 in meinem Beispiel).

  • Hi @Muschelkuh,


    habe heute Nacht auf .Com umgestellt und denke dir bei deinen Fehler oben helfen zu können.


    hier erstmal meine verwendete Datei:


    Apache Configuration: .htaccess
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    	RewriteCond %{HTTP_HOST} !^psychoseforum\.com$ [NC,OR]
    	RewriteCond %{HTTPS} =off
    	RewriteRule ^(.*)$ https://psychoseforum.com/$1 [R=301,L]
    	RewriteRule ^index.php/(.*) index.php?$1 [L,QSA]
    	RewriteCond %{REQUEST_FILENAME} !-f
    	RewriteCond %{REQUEST_FILENAME} !-d
    	RewriteRule ^(.*)$ index.php?$1 [L,QSA]
    </IfModule>


    Im Grunde solltest du Zeile 3-5 so mit deiner Adresse übernehmen können und dann sollte es funktionieren. Inwieweit deine anderen Befehle und Zeilen da noch gültig sind weis ich nicht.
    Zeile 6-9 bei mir ist für die neue Linkumschreibung. vielleicht wäre es Sinnvoll das auch gleich mit umzustellen indem du erst einen Teil von dieser htaccess für die vereinfachten Linkumschreibung nutzt und dann auf HTTPS wechselst.


    Habe es gerade erst umgestellt also wenn du fragen hast, dann kann ich dir da weiterhelfen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!