Upgrade WBB 4.0 nach Transfert. Plugins lassen sich nicht upgraden. Viele Fragen :-(

  • Hallo ,


    Habe die komplette Webseite auf einen anderen Webserver mit Erfolg transferiert.
    Mit dieser Kopie möchte ich das Upgrade einmal durchgehen damit ich Fall von Problemen die Produktion nicht betroffen ist.
    Ja diese Domain wurde eine zusätzliche Lizenz gekauft (Auch wenn diese Domain nicht für das WBB öffentlich genutzt wird und auch nur für einen Test).
    Es war mir nicht möglich lokal eine Kopie zum laufen zu bekommen.


    Nun zum Problem:
    Bekomme eine ganze Reihe von plugins die zu Updaten wären:
    „Moderierte Benutzergruppen“ in Version „2.0.6“ verhindert eine Aktualisierung von „WoltLab Community Framework“ auf Version „2.1.11“
    „Impressum“ in Version „2.0.1“ verhindert eine Aktualisierung von „WoltLab Community Framework“ auf Version „2.1.11“
    „Datenimport“ in Version „2.0.11“ verhindert eine Aktualisierung von „WoltLab Community Framework“ auf Version „2.1.11“
    „Benutzer-Like-Listen“ in Version „1.0.2“ verhindert eine Aktualisierung von „WoltLab Community Framework“ auf Version „2.1.11“
    „voolia News-System“ in Version „1.0.5“ verhindert eine Aktualisierung von „WoltLab Community Framework“ auf Version „2.1.11“
    „Datenschutzerklärung“ in Version „1.1.2“ verhindert eine Aktualisierung von „WoltLab Community Framework“ auf Version „2.1.11“
    „Automatische Inhaltssicherung“ in Version „1.0.1 pl 4“ verhindert eine Aktualisierung von „WoltLab Community Framework“ auf Version „2.1.11“
    „Who read this thread“ in Version „1.0.0“ verhindert eine Aktualisierung von „WoltLab Community Framework“ auf Version „2.1.11“
    „Beiträge kopieren“ in Version „1.0.2“ verhindert eine Aktualisierung von „WoltLab Burning Board“ auf Version „4.1.11“
    „Dateianhangs-Lupe für WCF2.0“ in Version „1.0.0 pl 1“ verhindert eine Aktualisierung von „WoltLab Community Framework“ auf Version „2.1.11“


    Die Updates werden jedoch verweigert: Beispiel:
    An update of package be.bastelstu.sascha.maelstrom.mediaelementjs from version 1.1.0 pl 7 to 1.2.0 is not supported.


    Habe ich besser die Plugins gänzlich zu deinstallieren (und dabei unter Umständen Daten verlieren) ?


    Wie kann ich herausfinden welche Plugins mit dem neuen WCF obsolet sind.


    In der Beschreibung im Blog: ist die Rede von WCF 2.0.11 pl 1 bei mir läuft jedoch 2.0.13. Ist das ein Problem ?


    Finde leider nicht mehr den Threat mit der Liste der Plugins kompatibel für das WBB 4.1 / WCF 2.1


    Freue mich für jeden Tip. Danke im voraus.
    Beste Grüsse


    flscout

  • An update of package be.bastelstu.sascha.maelstrom.mediaelementjs from version 1.1.0 pl 7 to 1.2.0 is not supported.


    Das ist doch eigentlich eine eindeutige Meldung: Ein direktes Update von Version 1.1.0 pl 7 auf Version 1.2.0 wird nicht unterstützt. Es gibt nun zwei Möglichkeiten: Entweder muss das Paket entfernt und neu installiert werden oder Du nimmst ein schrittweises Update über eventuelle Zwischenversionen vor.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • Hallo ,


    Ist es im Endeffekt nicht sinnvoller ein neues WBB (4.1) zu installieren und die Daten aus dem WBB (4.0) exportieren und ins WBB 4.1 importieren anstelle eines Upgrades ?


    Das Upgrade entwickelt sich zum Spießrutenlauf.
    Für jedes Plugin muss man prüfen ob es für das WBB 4.1 / WCF 2.1 existiert bzw benutzbar ist
    Zentral findet man diese Infos nicht.
    Warum ein Plugin sich nicht upgraden läst ist auch nicht erkenntbar nur explizit dass es eben nicht geht.


    Ei / Huhn Problem:
    Es wird aufgefordert auf eine neuere Version upzugraden. Diese Versionen sind aber nicht upgradable weil die schon unter WBB 4.1/WCF 2.1 laufen müssten. Da ich aber erst auf 4.1/2.1 das WBB/WCF upgraden will geht das schon nicht. Wenn ich die Plugins deinstalliere um die Zwischenversionen zu installieren dann verliere ich die Daten der Benutzer bzw Inhalte. das Plugin betreffend. Das kann es dann auch nicht sein.


    Verzweifle am Upgrade.


    Beste Grüsse
    flscout

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!