Censorship: failing in Quick Reply editor (need users help)

  • Hello,

    This is continuation of: Censorship: post content is lost

    Current situation is:
    - if I got censorship enabled - it is working correctly everywhere except Quick Reply (in thread view),
    - In Quick Reply instead of message telling me what word is prohibited I got message that post need to be accepted by moderators (not true), post content disappearing from editor, so post author even do not have chance to replace content
    - tried to contact with Woltlab support but after some investigation we came to conclusion that this error is related somehow to my webserver configuration (using Litespeed, I got almost no impact on configuration)
    - WBB generates no PHP error (even with debug mode enabled), probably some AJAX call is blocked (but why only in quick reply and nohere else?)

    I don't know what is exactly blocked and I don't know about what exactly to ask my web server administration to change on their side to fix this.

    I won't change web server because I'm hosting there nearly 15 different services, on different scripts, eg. Wordpress and with different frameworks (eg. Laravel, CodeIgniter). None of them gives me any problem, only WBB with only one function. Need to debug this somehow and find reason. Please help.

  • After months of investigation and looking for solution I'm nowhere near fixing this :(

    Additional (related) problem:
    If Flood Prevention is enabled in User Group configuration - same situation is happening - if I will try to write post faster that Flood Prevention time - I got message that post need to be accepted by moderators (not true) and post content disappearing from quick reply editor

    Something is messing up situation when WBB is trying to show red bar in Quick Reply editor.

    With my hosting company we have tried to set up new VPS web serwer with updated configuration (also with php 7.0.3) and result was exacxtly the same. Tested both cache modes: filesystem and memcache, without difference.

    WBB support tried to help, but finally we came to conclusion that (maybe) this is related to some mod_security rules.
    Anyway LiteSpeed working with mod_security in his way, also there are no errors related to mod_security in error.log

    Hosting company gave up. I'm stuck. Maybe somebody is able to setup some web server with LiteSpeed to confirm this on default setup? Or maybe somebody have other idea to fix this somehow?

  • Still fighting...

    I found AJAX Debugger for Chrome and I started to look for differences when submitting post between localhost and my LiteSpeed web server

    Localhost, where post censoring works fine

    Important thing: post censoring is working with 431 error, probably this is critical

    Me web server where post censoring is failing

    Important consideration: there is no POST error - no 431 error, response is 200 OK, despite error 412 in Response Object
    Thus it looks like AJAX that error is not catched and script goes at it is OK

    I think that because error 431 is not triggered (instead 200 OK), script is going further. Without stopping it - post is going through WBB.min.js to part:
    this._successMessageNonVisible = 'wbb.post.moderation.redirect';

    Message is not visible, so it shows wbb.post.moderation.redirect (exactly: Your post requires manual approval and will not be displayed until then.)

    This 431 error whould be triggered from wcf\lib\system\exception\AJAXException.class.php
    Somehow it is not generated.

    Question is why it doesn't work, what can block it, how to change configuration on web server or fix this somehow.

    Edited 3 times, last by PolUser (May 11, 2016 at 5:30 PM).

  • LiteSpeed is known to mess with HTTP status codes and swaps them out using unclear/undocumented rules, besides the status codes being used are perfectly valid. I've never really worked with LiteSpeed, as such I can't provide any further assistance.

  • I'm still able to set up closed/hidden test if You would like to look at this closer.

    If anybody is able to recreate this with LiteSpeed and maybe detect can it be fixed with some setting change in LiteSpeed - please give a sign...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!