4.0.8 auf 4.0.11 updaten geht nicht

  • Affected App
    WoltLab Suite Forum

    Das Problem wurde hier im Forum schon locker 20 Mal behandelt, aber ich habe lediglich einen einzigen Bugreport gefunden (alle anderen Threads waren im Hilfe-Forum) und "Behoben" ist der Fehler eindeutig nicht.


    Ich möchte ein WBB 4.0.8 auf das WBB 4.0.11 via Autoupdate aktualisieren. Im ersten Schritt bekam ich folgende Fehlermeldung:


    Fatal error: tar archive 'files_update.tar' not found in '/tmp/package_39866b2ca07023da9360c23e34eac2463f27b2bd'.


    Daraufhin habe ich erstmal nur das WCF über das automatische Update aktualisiert, was funktionierte. Beim WBB erhalte ich nun aber folgende Fehlermeldung:


    Das Paket „User Conversation System“ (installierte Version: „2.0.7“) soll auf Version „2.0.9“ aktualisiert werden, ein Update wird jedoch nicht unterstützt.


    Ein manuelles Update auf 4.0.9, 4.0.10 oder 4.0.11 ging nicht. Auch ein manuelles Update des User Conversation Systems geht nicht, da es scheinbar keine Version 2.0.8 gibt (habe nur 7 und 9 gefunden).


    Ist somit ein Update also für immer unmöglich?


    Betriebssystem ist Windows 7 x64, Server ist das Paket "Wampserver" (x64).

  • Auch WoltLab ist nicht unfehlbar, in irgendeinem Paket wurde auf files_update.tar vergessen.
    Also entweder selbst die Initiative ergreifen und prüfen in welcher package.xml die besagte Datei verlangt, jedoch nicht im Archiv enthalten ist, oder gleich ein Support-Ticket (sofern in der Lizenz enthalten) schreiben.

    Mit freundlichen Grüßen!
    With kind regards!

    Wanna PayPal Me?


    Blog 2.0.x Extension-Kit 1.0.1
    Blog 2.1.x Extension-Kit 1.1.1
    Article "The Sweeet Core Thing" Threads Worker 3.0.0 *


    * no official release, just ask me!

  • Ich selbst habe leider keinen Support inklusive, daher der Bugreport.

    Welche Version von com.woltlab.wcf.infraction (Verwarnungen) hast du installiert?
    Sofern es nicht mittlerweile korrigiert wurde, fehlt in der 2.0.3 files_update.tar.

    Mit freundlichen Grüßen!
    With kind regards!

    Wanna PayPal Me?


    Blog 2.0.x Extension-Kit 1.0.1
    Blog 2.1.x Extension-Kit 1.1.1
    Article "The Sweeet Core Thing" Threads Worker 3.0.0 *


    * no official release, just ask me!

  • Ich selbst habe leider keinen Support inklusive, daher der Bugreport.

    Der Ticketsupport garantiert nur eine schnellere Antwort. Du kannst ein Ticket erstellen auch wenn du nichts zusätzlich in deiner Lizenz hast.

  • Aber ich Frage mich wieso so ein Fehler überhaupt passiert, es Heisst ja immer die Updates zu Installieren. Und dann macht Ihr es nicht und oh Update von 4.0.8 auf 4.0.11 geht nicht?


    Diejenigen die Brav das Update installiert haben, haben das Problem nicht.

  • Falsch.
    Wenn du keine Lizenz mit Ticket support hast (sproch lizenz vor dem 12.12.2013 gekauft, oder nur updated hast) hast du keinen Anspruch auf WL Ticket support


    Ja, Falsch ist das was du da schreibst. Ich beziehe mich auf mehrere Dinge.. Zum einen, weil ich das Ticketsystem nutzen kann ohne es es speziell bestellt/gekauft zu haben und weil es diverse Antworten dazu gibt, wie diese folgenden..


    Als Kunde kannst du jeder Zeit Fragen per Ticketsupport oder hier im Community Forum stellen. Das Community Forum ist ein Kunden helfen Kunden Forum, daher werden hier keine Antworten garantiert. In der Regel bekommt man aber schnell eine Antwort. Auch als kompletter Neuling

    Der Standard- und Professional-Support bezieht sich nur auf das Ticket-System, der Standardsupport garantiert eine Beantwortung innerhalb von zwei Werktagen - beim professional Support wird die Beantwortung innerhalb von 12 Stunden innerhalb der Bürozeiten gewährleistet.


    Wenn meine Schlussfolgerung falsch ist, bitte ich hier @Andrea Berg / @Alexander Ebert dieses doch richtig zu stellen.

  • Zum einen, weil ich das Ticketsystem nutzen kann ohne es es speziell bestellt/gekauft zu haben und weil es diverse Antworten dazu gibt, wie diese folgenden..

    Von wann ist deine Lizenz denn?
    Es gilt das was ich oben geschrieben habe, alle die eine Lizenz nach dem 12.12.2013 gekauft haben, können Ticket support nutzen, sonst nur wenn man den exta bestellt hat.king hat seine lizenz vor diesem tag gekauft und kann somit den ticket support nicht nutzen

  • Ich verstehe das du gerne Recht behalten möchtest und wiederhole mich noch einmal. Ich beziehe mich auf mehrere Quellen, nach dem unter "Mein Konto" demnach die Option "Ticket verfassen" bei jedem Kunden auftauchen sollte. Eine weitere Quelle ist das Kaufformular von WoltLab.



    Bis jetzt hast du keine Quelle genannt, wo ersichtlich ist das ich Falsch liege.

  • Der letzte Lizenzerwerb (Updatelizenz) war am 23. September 2013 und damit noch zu den alten Lizenzkonditionen. Der Ticketsupport ist wie gesagt erst seit dem 12. Dezember 2013 Bestandteil aller Lizenzen.


    Wenn du jetzt deine Lizenz z.B. um die WoltLab Filebase erweiterst, dann hast du auch Zugang zum Ticketsupport. Alternativ kannst du jeder Zeit den Professional Ticketsupport erwerben.

    Der Standard-Support ist seit dem 12. Dezember 2013 Bestandteil neuer Lizenzen. Deine Lizenzen und Updatezugänge wurden alle vor dem 12. Dezember 2013 erworben, daher haben diese keinen Zugang zum Standard-Support.


    Es wurde damals von dir lediglich der Updatezugang erworben. Der Supportzugang war eine separate Lizenz.


    Ein ganzes Thema für dich zum Lesen:
    Ticket-Support für WBB 4 nicht verfügbar


    Du kannst mir ruhig schon glauben wenn ich dir sage das ich Recht habe :D

  • Ich warte erst mal, wie dieser Thread gelabelt wird.


    Meiner Meinung nach kann es nicht sein, dass ein Update bei einem solch kleinen Versionssprung nicht funktioniert. Und ich bin ja nicht der einzige, das Update ist schlicht fehlerhaft. Da muss Woltlab schnell was tun.

  • Meiner Meinung nach kann es nicht sein, dass ein Update bei einem solch kleinen Versionssprung nicht funktioniert.


    Vorweg: ich hatte diesen Fall noch nicht in einem WBB und kann daher nicht aus eigener Erfahrung sagen, ob es hierbei ein Problem gibt, und muss dir einfach mal glauben. Aber wenn es so ist, dann muss das auf jeden Fall behoben werden, denn es ist schlicht und ergreifend nicht realistisch, dass jedes Forum jedes Update mitmacht. Ja, in meinen eigenen Projekten spiele ich alle Updates vorbildlich ein. Aber wenn ich mal überlege, wie es aussieht, wenn ich mich in Projekten von Kunden anmelde (kein einziges WBB dabei, daher auch keine Erfahrung dazu), da ist eine aktuelle Version welcher Software auch immer die absolute Ausnahme und nicht die Regel. Führe ich dort Aktualisierungen durch, dann kann man zu 99% davon ausgehen, dass ich einige Versionen zu überspringen habe. Es ist unabhängig von der Software definitiv eine alltägliche Situation, dass Versionen übersprungen werden.

  • Marcel ich glaube es liegt an der wbb4.0.9\upload\WCFSetup.tar.gz\WCFSetup.tar\install\packages\com.woltlab.wbb.tar\requirements\com.woltlab.wcf.conversation.tar\


    Die verlangt eine version 2.0.8, wie unten zu sehen,



    Allerdings wird mit wbb4.0.8\upload\WCFSetup.tar.gz\WCFSetup.tar\install\packages\com.woltlab.wbb.tar\requirements\com.woltlab.wcf.conversation.tar\


    nur version 2.0.7 ausgeliefert



    Und in WBB 4.0.10:




    Kann das daran liegen?

  • Kannst du mir sagen, bei welchem Paket genau diese Fehlermeldung kam?

    Ich kann dir dazu nur sagen, dass ich das Paket "Woltlab Burning Board 4.0.11" ausgewählt habe. Aber du meintest evtl. welches konkrete Paket darin, oder?

  • Wie kann man das rausfinden? Dann könnte ich ein neues 4.0.8 installieren und dann nochmal auf 4.0.11 updaten.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!