Temaspeak 3 Viewer geht nicht

  • Hallo zusammen,

    wenn ich das Plugin "Teamspeak 3 Viewer" installiere bekomme cih folgende Fehlermeldung.


    Code
    Information:
    
    
    
    
    ID: 46f5369b50f9d4db9b8fbc79ee04b128c734e92e
    Bitte teilen Sie dem Betreiber die oben stehende ID mit.
    Die Fehlermeldung kann mit dieser ID über „ACP » Protokoll » Fehler“ eingesehen werden.

    Kann damit Jemand anfangen ?

  • Ich bekommst nicht zum laufen. Hier mal der Fehlercode.

    Vielleicht hat ja Jemand ne Lösung.

  • Code
    TeamSpeak3_Transport_TCP->connect()
    Message: Connection refused

    Sagt doch schon alles, er kann sich nicht zum TS verbinden.
    Auf 4.1 funktioniert es aufjedenfall, verwende es selbst.

  • Hatte ich letztens auch, bei mir lag es an meine Firewall, da ich mittels IPtables alle Ports geschlossen hatte, jedoch der TS3 Server sich auf einem anderem Server befand und mein Server die Ports dazu nach außen nicht zuließ.
    Es gab hier keinerlei Einträge in den Logs, weder in den Logs des Webservers noch in den Logs des TS3 Servers.
    TeamSpeak3 Viewer - Connection refused ~ Fehler | Iptables

    Ob es in deinem Fall auch daran liegt kann ich nicht sagen, aber es ist die selbe Fehlermeldung, da er sich nicht mit dem TS3 Server verbinden kann.
    Kann natürlich auch fehlerhaften Zugangsdaten oder Ports liegen.


    wenn ich das Plugin "Teamspeak 3 Viewer" installiere bekomme cih folgende Fehlermeldung.

    Wobei bei mir der Fehler nicht bei der Installation kam, sondern beim aufrufen der Temaspeak 3 Viewer Seite.

  • Ich denke auch nicht dass es am Plugin liegt, denn in unserem zweitem Forum haben wir dieses Plugin auch schon mit der Version 4.0 und 4.1 ohne Probleme am laufen.
    Zuvor lief bei uns auch alles, bei uns kam der Fehler erst nachdem ich mit den Foren auf einem anderem Server umgezogen war und der TS3 Server jedoch noch auf dem alten Server verblieb.
    Es war die selbe Fehlermeldung, aber bei uns lag es an der Firewall was die Ports nicht frei gab.

  • Ich würde auf alle Fälle noch die IP vom Forum Server in die Whitelist des TS-Servers eintragen, es kann auch sein dass der Query User wegen zu viele Anfragen vom TS Server temporär oder permanent gebannt wurde.

  • HAllo zusammen,

    ich bekomme das Teil auch nicht zum laufen und folgende Fehlermeldung :

    Display Spoiler


    Wed, 20 Jan 2016 08:57:04 +0000
    Message: Connection refused
    File: /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/data/teamspeak3viewer/TeamSpeak3_Framework/Transport/TCP.php (54)
    PHP version: 5.6.17
    WCF version: 2.1.9 pl 1 (Typhoon)
    Request URI: /index.php?team-speak3-viewer/
    Referrer: http://www.gamermeetingpoint.de/
    User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
    Information: ""
    Stacktrace:
    #0 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/data/teamspeak3viewer/TeamSpeak3_Framework/Transport/TCP.php(108): TeamSpeak3_Transport_TCP->connect()
    #1 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/data/teamspeak3viewer/TeamSpeak3_Framework/Adapter/ServerQuery.php(76): TeamSpeak3_Transport_TCP->readLine()
    #2 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/data/teamspeak3viewer/TeamSpeak3_Framework/Adapter/Abstract.php(60): TeamSpeak3_Adapter_ServerQuery->syn()
    #3 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/data/teamspeak3viewer/TeamSpeak3_Framework/TeamSpeak3.php(320): TeamSpeak3_Adapter_Abstract->__construct(Array)
    #4 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/data/teamspeak3viewer/TeamSpeak3Viewer.class.php(30): TeamSpeak3::factory('serverquery://p...')
    #5 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/system/cache/builder/TeamSpeak3ViewerCacheBuilder.class.php(32): wcf\data\teamspeak3viewer\TeamSpeak3Viewer->connect('79.133.50.138', 10073, 10011, 'pommes', 'R3FQ04Ox')
    #6 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/system/cache/builder/AbstractCacheBuilder.class.php(40): wcf\system\cache\builder\TeamSpeak3ViewerCacheBuilder->rebuild(Array)
    #7 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/page/TeamSpeak3ViewerPage.class.php(37): wcf\system\cache\builder\AbstractCacheBuilder->getData()
    #8 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/page/AbstractPage.class.php(276): wcf\page\TeamSpeak3ViewerPage->assignVariables()
    #9 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/page/AbstractPage.class.php(100): wcf\page\AbstractPage->show()
    #10 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/system/request/Request.class.php(58): wcf\page\AbstractPage->__run()
    #11 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/wcf/lib/system/request/RequestHandler.class.php(139): wcf\system\request\Request->execute()
    #12 /var/www/vhosts/hosting6540.af940.netcup.net/httpdocs/index.php(10): wcf\system\request\RequestHandler->handle('wbb')
    #13 {main}

    lg
    @Pommes_maj0

  • Mit Sicherheit ist da eine Firewall die die Ports blockiert.
    Im TS sollte man auch die IP des Servers worauf das Forum läuft auch in die Whitelist eintragen.

    Wir haben diese Erweiterung bei uns eingerichtet und bei mir läuft es.

  • Du solltest noch deine IP beim TS Server whitelisten sonst kann es schnell passieren dass du blockiert wirst.

    Das Passwort R3FQ0xxx für den Query User pommes ist richtig eingetragen ? :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!