Registrierung seit ca. 2 Wochen nicht immer möglich (nicht bei jedem)

  • Affected App
    WoltLab Suite Core

    Hallo zusammen,


    seit etwa 2 Wochen bekomme ich immer wieder eMails von Usern die sich registrieren wollen aber nicht können.
    Es gibt unterschiedliche Meldungen, manchmal klappt die Registrierung aber die Bestätigung mit dem Aktivierungscode nicht, manchmal geht gar keine Registrierung. Ich versuche immer nach der Fehlermeldung nachzufragen oder bitte die User um Screenshots. Manche probiere es öfters, udn irgendwann klappt es dann doch. Bei einer Kundin konnte ich per TeamViewer jetzt selbst schauen und habe mich mit verschiedenen Email Adressen anmelden wollen und das ging auch mit keiner der eMails! Ich bin mir jetzt nicht mehr sicher, ich meine sie konnte sich über Chrome nicht anmelden, nach Eingabe der Daten und auf Senden Button, kam einfach die Seite mit "zugriff verweigert", hab dann mit ihr zusammen über Firefox versucht und es klappte direkt. Wir haben dann mit anderen Email Adressen versucht und jedesmal konnte man nichts dran machen.


    Nun habe ich bei ihr alle Plugins deaktiviert und danach noch mal probiert und es ging. Bis wir herausgefunden haben, das man sich bei Woltlab mit dem McAfee SiteAdvisor nicht anmelden kann. Nun musste ich ihr erklären, das es an diesem Plugin lag, aber ich kann doch nicht jetzt bei jedem Kunden alle Plugins checken. Der McAfee SiteAdvisor ist doch ein bekanntes Plugin, denn viele Kunden benutzen. Hier sollte man nachbessern, wobei ich mir auch nicht sicher bin, warum bei den anderen es nicht geklappt hat. Habe danach direkt immer nach dem Plugin gefragt.


    Bitte erspart euch diese Kommentare wie "melde dich bei McAfee, das ist deren Problem" den irgendwo muss es ja auch mit Woltlabs Registrierungsfunktion auch zusammen hängen, warum es nicht klappt und in anderen Foren doch, oder? Bis jetzt lief das doch seit dem ich Wbb4 einsetze (über 1 Jahr) ohne Probleme, was hat sich geändert?


    Edit: Ah und habe gerade die letzten 2 Wochen alle registrierten User nachgesehen, da sind 11 nicht aktivierte dabei, das ist wirklich sehr viel.

  • Moin Sascha, danke für die schnelle Antwort ;)


    Laut den anderen Thread haben ja auch noch andere User das selbe Problem, bei den liegt es am Chrome anscheinend.
    Es muss doch auch irgendwas an der Woltlab Software verändert worden sein, wenn auf einmal bekannte Browser oder bekannte Plugins ärger machen, oder?


    Nur so eine Idee.


    Ich habe übrigens bei den anderen Problem-Usern direkt als erstes geschrieben,
    falls sie diesen McAfee SiteAdvisor haben, das sie es abschalten sollen, aber das hatten sie nicht.
    Gab es vielleicht in der letzten Zeit irgendwelche Updates, die das hervorrufen könnten? Hast du ne Ahnung.


    Ich nutze Kaspersky und hatte noch nie irgendwelche Probleme :)

  • Hab in den letzten 3 Tagen, 2 neue Leute die sich nicht registrieren konnten.


    Ich bin jetzt auch etwas verwirrt, woran das liegen könnte - ob Chrome oder Irgendwelche Browser Plugins der Kunden.


    Es ist sehr schwierig, die Kunden danach zu fragen, nicht jeder beschäftigt sich dann so viel wie ein Admin.
    Ich möchte aber natürlich irgendwo herausfinden, woran das liegt oder das sich einer der Programmierer dieser Sache annimmt.


    Wenn an Woltlab nicht geändert wurde, was ich annehme (Saschas Beitrag oben), hat dann Google was abgeändert, also das mit den leeren / versteckten Feldern nehme ich an - wenn das so ist, sollte die Geschäftsführung nicht bei Chrome anklopfen und nachfragen? :D @Throwholics Florian hat da Recht, es sind einige User, die das selbe haben - man weiss sicher nicht wie viele Leute es gar nicht mitbekommen.

  • Wie lösen das Problem denn andere Webseiten? Ich meine, dass man eine Anleitung einblenden muss, damit man sich registrieren kann, ist ja sicher auch nicht der Weißheit letzter Schluss...?

    Lieber mehr sein als scheinen, als mehr scheinen als sein. :)

  • Jap vielleicht sollte man eine option einbauen wo man dies deaktivieren kann.
    Dass Chrome und andere Browser unsichtbare Felder ausfüllen finde ich aber auch sehr strange....

    ┌П┐(◉_◉)┌П┐

  • Kann man das denn wenigstens optional im ACP deaktivieren?


    Es wäre schön gewesen, darüber informiert zu werden. Meine Webseite ist zwar noch im Aufbau, aber ich hätte mich sicher schnell gewundert, dass keiner kommt, nachdem ich online ging.

    Lieber mehr sein als scheinen, als mehr scheinen als sein. :)

  • Das Problem lässt sich ausschließlich durch Entfernen des gesamten Honeypots beheben. Ich habe nun diverse Dinge ausprobiert und Chrome füllt die Dinger immer aus, egal wie sie benannt sind oder welchem Feldtypen sie entsprechen.


    Um dies zu bewerkstelligen OHNE Änderungen am Template vorzunehmen, reicht es, die Felder mittels CSS auszublenden. Dadurch bleiben die Felder bestehen und sind auch noch "irgendwie" funktional:


    CSS
    #tplRegister #fieldset1 {
    	display: none;
    }


    @Matrikular


    Das Ganze ist schon seit der ersten Beta des WCF inbegriffen und bisher gab es hier auch keine nennenswerten Probleme.

  • Das Problem lässt sich ausschließlich durch Entfernen des gesamten Honeypots beheben. Ich habe nun diverse Dinge ausprobiert und Chrome füllt die Dinger immer aus, egal wie sie benannt sind oder welchem Feldtypen sie entsprechen.



    Um dies zu bewerkstelligen OHNE Änderungen am Template vorzunehmen, reicht es, die Felder mittels CSS auszublenden:


    CSS
    #tplRegister #fieldset1 {
        display: none;
    }

    Vielen Dank für die Lösung. Vielleicht kommt ja von WoltLab selbst in dieser Richtung auch noch irgendwas. Bis dahin baue ich auf jeden Fall deine CSS-Anweisung bei mir ein.

    Lieber mehr sein als scheinen, als mehr scheinen als sein. :)

  • Die einfachste Lösung ist autofill=off zu erzwingen für das registrierungsformular.


    Das wird von Chrome ignoriert. Denn wenn du dir das Template anschaust wirst du sehen, dass dies bei den Honeypot-Feldern bereits der Fall ist. Und das Hinzufügen dieses Attributs bei den sichtbaren Feldern oder dem gesamten Formular hat keinen Effekt auf die Auto-Ausfüllen-Funktion von Chrome. Lediglich Firefox hält sich daran.

  • Nicht ganz. Chrome akzeptiert durchaus ein autofill=off für das ganze Formular. Ignoriert es aber auf Ebene der einzelnen Input-Felder.

    Streichen wir das, Chrome ignoriert mittlerweile auch das -.-

  • Gerade festgestellt, dass die neuste Chrome-Version das mittlerweile auch ignoriert.


    Was aber funktioniert ist die honeypot-Felder auf readonly zu setzen, mit einem script, dass dieses attribut entfernt sobald man das Feld fokussiert. Das verhindert ein Autofill.

  • Die einzig wirksame Methode ist tatsächlich, die Felder vollständig auszublenden. Denn aktuell bedient sich das WCF 2 einer Technik, die ich damals in meinem Honeypot-Plugin für das WCF 1 verwendet habe: Die Felder werden lediglich in einen für den Besucher nicht sichtbaren Bereich verschoben.

  • Ich teste das gerade mit <input type="text" id="username" name="username" value="" autocomplete="off" class="medium" tabindex="998" readonly onfocus="this.removeAttribute('readonly');"/> etc. eventuell hilft das.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!