WhatsApp Smileys für´s Forum

  • Ich habe soeben Version RC4 veröffentlicht. Wie schon zuvor, ist ein Update nicht möglich (dies wird während der gesamten Beta/RC-Phase auch so bleiben).


    Changelog:


    • Alternative Unicode-Sequenzen wurden hinzugefügt (ZWJ / iOS 8.3+)
    • Smilie-Codes werden nun wie erwartet sowohl vor dem beginnenden Doppelpunkt, als auch nach dem schließenden Doppelpunkt mit einem Leerzeichen von umschließenden Content getrennt
      Entgegen der ursprünglichen Planung werden mehrere, aufeinanderfolgende Leerzeichen nicht reduziert
    • Einträge im Errorlog werden nur noch hinzugefügt, wenn der Debug-Modus des WCF aktiviert ist (da sonst für eine vielzahl "normaler" Zeichen z.B. € ein Logeintrag erzeugt würde)
    • Das optionale Paket de.softcreatr.typhoon.editor.emoji wurde hinzugefügt, um die Darstellung der Smilies in Redactor zu ermöglichen (ansonsten werden nur die dazugehörigen Smilie-Codes angezeigt)

    Download: http://packages.softcreatr.de/…#de-softcreatr-wcf2-emoji

  • Version RC4 Installiert, keine Probleme, Vorgänger Deinstalliert, neue Installiert und unter wcf 2.0 / 2.1 getestet.
    Ich dachte immer , braucht kein Mensch aber man kennt sie zb unter WhatsApp und es macht einfach spass ;)

  • Version RC4 Installiert, keine Probleme, Vorgänger Deinstalliert, neue Installiert und unter wcf 2.0 / 2.1 getestet.


    Same here. :D


    Für Nutzer des erweiterten Smilie-Systems von @ramius gibt es lediglich das kleine Problem, dass man nach der Deinstallation der RC3 und Neuinstallation der RC4 die ganzen Emojis wieder neu den vorher definierten Smilie-Reitern im ACP zuordnen muss.


    Aber ist nurn Arbeitsaufwand von zwei Minuten. Nicht weiter tragisch. ^^

  • Die finale Version wird sich strukturell wahrscheinlich von den bisherigen Versionen unterscheiden. Die Smilie-Pakete werden nicht mehr separat als optionale Pakete mitgeliefert, sondern fester Bestandteil der Erweiterung. Das macht vieles wesentlich einfacher und auch eventuelle De- bzw. Neuinstallationen weniger aufwändig. Vorallem in Hinblick auf Unicode 9.0 (erscheint Mitte des Jahres) erleichtert es die Aktualisierung ungemein.


    Das beigefügte Smilie-PIP wird wahrscheinlich in ein separates Paket (Requirement) ausgelagert, damit auch andere Entwickler ihren Nutzen daraus ziehen können, wenn sie denn möchten. Zur Erinnerung: Das Emoji-Plugin liefert u.A. ein PIP mit, mit dem es möglich ist, die Sortierung von zu installierenden Smilies über die smilie.xml vorzugeben (siehe dazu auch Smiley-PIP erweitern)


    Auch hatte man mich gebeten zu erwägen, ob sich die Möglichkeit zum Ausblenden von Smilie-Kategorien nicht auch als separate Erweiterung anbieten ließe. Das wiederum werde ich mir noch überlegen.

  • Das ist jetzt vielleicht etwas Off-Topic nach diesen ganzen seriösen Beiträgen zum WCF-Plugin, aber meine Wohnung hat jetzt auch ein "Emoji-Plugin" spendiert bekommen. :D

    Images

    "Wir finden Worte, die wie Geschosse treffen, wir leisten Schwüre, die niemals zerbrechen. Wir steh'n zusammen auch wenn man uns nicht mag, wir leben schneller, schneller in den Tag. Unsere Metaphern sind teuflische Ikonen, harte Aphorismen, gewagte Abstraktionen. Ein Strauß von Versen im Idiomenbeet, verbale Blüten wie es geschrieben steht."


    (Saltatio Mortis)

  • Aber nicht weitersagen. ;)

    "Wir finden Worte, die wie Geschosse treffen, wir leisten Schwüre, die niemals zerbrechen. Wir steh'n zusammen auch wenn man uns nicht mag, wir leben schneller, schneller in den Tag. Unsere Metaphern sind teuflische Ikonen, harte Aphorismen, gewagte Abstraktionen. Ein Strauß von Versen im Idiomenbeet, verbale Blüten wie es geschrieben steht."


    (Saltatio Mortis)

  • Hi zusammen!


    Habe Versucht mir Plugin hochzuladen, es erscheint dieser Fehler.
    Das Paket „Emoji-Unterstützung“ (installierte Version: „1.0.0“) soll auf Version „1.0.0“ aktualisiert werden, ein Update wird jedoch nicht unterstützt.


    Was habe ich Falsch gemacht?



    Gruss
    Frank

  • du hast noch die vorige pluginversion installiert, diese musst du zuvor deintsallieren ;)


    Also für mich steht da, dass er versucht, die aktuell installierte Version auf die aktuell installierte Version zu aktualisieren?!

  • Also so langsam sollt ich es doch echt gelernt haben die meldungen auch ganz zu lesen, Asche über mein Haupt^^

  • Es gibt kein Problem, da Du bereits die aktuelle Version verwendest.





    Gruß norse

    Zugang zu meinen Arbeiten und dem dazugehörigen Support bekommt Ihr bei Interesse hier.

  • indem du einfach mit der aktuellen version zufrieden bist ?
    Du hast das plugin in der aktuellen version bereits installiert.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!