Column not found: 1054 Unknown column 'template_listener.niceValue' in 'order clause'

  • Affected App
    WoltLab Suite Forum

    Ich habe versucht upzudaten und dann kommt der obige Fehler und das Forum ist Schrott. ?(

    Dann habe ich die Datenbank gelöscht ein Backup eingespielt und der Fehler bleibt. :(

    Der Fehler steht auch noch im Log:

    Message: Could not execute prepared statement: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away

  • Habe genau das gleiche Problem... Update hällt an der Stelle an.

    Kann man was ändern, damit das Update durch läuft?

    Aktuell funktioniert leider das komplette Forum dadurch nicht mehr.

    Information:
    id: cac7fe106d0226f60bc123b055c20b66bb7fbaaa
    error message: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'template_listener.niceValue' in 'order clause'
    error code: 42
    sql type: wcf\system\database\MySQLDatabase
    sql error: Unknown column 'template_listener.niceValue' in 'order clause'
    sql error number: 42S22
    sql version: 5.6.23-nmm1-log

  • Message: Could not execute prepared statement: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away


    Heißt soviel, dass dein MySQL-Server die Verbindung unterbrochen hat, weil er abgestürzt ist o.ä.
    Normalerweise aktualisiert man das System auch nur, wenn man es davor auf einem nicht produktiven Forum getestet hat. ;)

  • Heißt soviel, dass dein MySQL-Server die Verbindung unterbrochen hat, weil er abgestürzt ist o.ä.
    Normalerweise aktualisiert man das System auch nur, wenn man es davor auf einem nicht produktiven Forum getestet hat.

    Normalerweise sollte die Sicherheitskopie des alten Standes aber wieder funktionieren.
    Ich habe ein nicht produktives Forum, da funktioniert ja auch alles eben ohne Inhalt, ansonsten identisch.

  • Habe jetzt das Forum komplett neu installiert, den Importer genutzt und die restlichen Tabellen für die Galerie und Kalender manuell rüber genommen.

    Ist zwar bestimmt nicht unbedingt im Sinne des Erfinders, aber auf jeden Fall eine Lösung.

  • @Woltlab-Team ( @Marcel Werk ) : ich habe genau den selben Fehler! Bekam es auch mit der Wiederherstellung wie der TE nicht zurück. Hab folgende Meldung als erstes bekommen, und inzwischen nur noch blanke Fehlermeldung-Anzeige mit ID. Die Käse hat meine Nacht geklaut und muss jetzt los. Bin heute Mittag wieder da, hoffentlich habt ihr eine Lösung für uns, ich will zwar nicht nachdenken, aber der Verlust des Forumstandes mit über einer halben Mio Beiträge würde mir unbeschreiblichen Schaden anrichten.


    Beste Grüße
    Baba_Isa

  • Dann habe ich die Datenbank gelöscht ein Backup eingespielt und der Fehler bleibt.

    Du musst auch ein Dateibackup einspielen.

    Beim Update wird nicht nur die Datenbank verändert, auch die Dateien. Eine Datei von 4.1 will hier auf eine Datenbankspalte zugreifen, die es in 4.0 noch nicht gab, daher der Fehler. Das kam bei mir auch nach einem DB Backup. Ich habe dann das Dateibackup wieder hochgeladen und den Cache im ACP geleert, dann lief mein Forum wieder. Hoffe das hilft euch weiter :)

    "Those who would give up essential Liberty, to purchase a little temporary Safety,
    deserve neither Liberty nor Safety."

    — Benjamin Franklin

  • I just had the same error...
    "Unknown column 'template_listener.niceValue' in 'order clause'"

    The reason was that one file had root as owner and thus the entire update failed and the entire site is lost ;)

    Glad I have backups, but in the future you might want to verify all access rights first :p

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!